summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2021-01-05 20:51:53 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2021-01-05 20:58:55 +0200
commitfe7b8f570d9ec3f06d8512520afdce2146c920e4 (patch)
tree584680b7bfff93fb9ea9cd63df1fc5f09c0b334c /app-arch/pixz
parentapp-editors/mg: Remove old (diff)
downloadgentoo-fe7b8f570d9ec3f06d8512520afdce2146c920e4.tar.gz
gentoo-fe7b8f570d9ec3f06d8512520afdce2146c920e4.tar.bz2
gentoo-fe7b8f570d9ec3f06d8512520afdce2146c920e4.zip
app-arch/pixz: Remove old
Bug: https://bugs.gentoo.org/707474 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'app-arch/pixz')
-rw-r--r--app-arch/pixz/Manifest1
-rw-r--r--app-arch/pixz/files/pixz-1.0.6-avoid-unaligned-accesses.patch44
-rw-r--r--app-arch/pixz/pixz-1.0.6-r1.ebuild46
3 files changed, 0 insertions, 91 deletions
diff --git a/app-arch/pixz/Manifest b/app-arch/pixz/Manifest
index d5f9c719c42d..e3e710507a23 100644
--- a/app-arch/pixz/Manifest
+++ b/app-arch/pixz/Manifest
@@ -1,2 +1 @@
-DIST pixz-1.0.6.tar.xz 119516 BLAKE2B 758a4985b946284587998ab2a653e51ded9838a7c77c7795c82c15c1693714468b07c2cbfd86a0c7ce7be34d9a5bd8fdc3285d503524ce299ba53179447e60ed SHA512 361a8d8b736c350e4e3fd19b5d36777129a087eb81439d05edc08f9378938583bef8fc70e440ffd22efb6dad1f6494c6c3e532d7dd1ab12c9350b6078aa993d7
DIST pixz-1.0.7.tar.xz 120876 BLAKE2B 23563837169611d54dc4540715537b2e16c66bd9682097e4f37957e7422b487f221603b11aa30a39fd05c77dbeddc1697ac9ffe208d984c1da885a67f79a180f SHA512 7f343cb74958b9582b60a2e916243e72421fad1ebecc5867c9e046c881e8a318da9bb885edd71da8fe6953fd5d5c2f5119133cd0bbbf4d0f9b35f8aecd61120d
diff --git a/app-arch/pixz/files/pixz-1.0.6-avoid-unaligned-accesses.patch b/app-arch/pixz/files/pixz-1.0.6-avoid-unaligned-accesses.patch
deleted file mode 100644
index 24c53c9acc4a..000000000000
--- a/app-arch/pixz/files/pixz-1.0.6-avoid-unaligned-accesses.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-https://github.com/vasi/pixz/pull/82
-
-From 8b9a198d86e435929ed0c2246217d241ed1e707c Mon Sep 17 00:00:00 2001
-From: Matt Turner <mattst88@gmail.com>
-Date: Sun, 1 Sep 2019 23:58:26 -0700
-Subject: [PATCH] Avoid unaligned accesses
-
-Architectures like SPARC do not allow unaligned accesses. Avoid them by
-memcpy()ing the data to an aligned buffer. On x86 systems where
-unaligned loads are fast, the memcpy() will be compiled away and the
-same code generated as before.
----
- src/endian.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/src/endian.c b/src/endian.c
-index 51aea58..122c7da 100644
---- a/src/endian.c
-+++ b/src/endian.c
-@@ -13,6 +13,7 @@ void xle64enc(uint8_t *d, uint64_t n) {
- #elif defined(__linux__) || defined(__FreeBSD__)
-
- #include <stdint.h>
-+#include <string.h>
- #ifdef __linux__
- #include <endian.h>
- #include <byteswap.h>
-@@ -37,11 +38,14 @@ void xle64enc(uint8_t *d, uint64_t n) {
- #endif
-
- uint64_t xle64dec(const uint8_t *d) {
-- return le64toh(*(uint64_t*)d);
-+ uint64_t tmp;
-+ memcpy(&tmp, d, sizeof(tmp));
-+ return le64toh(tmp);
- }
-
- void xle64enc(uint8_t *d, uint64_t n) {
-- *(uint64_t*)d = htole64(n);
-+ uint64_t tmp = htole64(n);
-+ memcpy(d, &tmp, sizeof(tmp));
- }
-
- #else
diff --git a/app-arch/pixz/pixz-1.0.6-r1.ebuild b/app-arch/pixz/pixz-1.0.6-r1.ebuild
deleted file mode 100644
index 4ef78d45feb3..000000000000
--- a/app-arch/pixz/pixz-1.0.6-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/vasi/${PN}.git"
- inherit git-r3 autotools
-else
- SRC_URI="https://github.com/vasi/pixz/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-fi
-
-DESCRIPTION="Parallel Indexed XZ compressor"
-HOMEPAGE="https://github.com/vasi/pixz"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="static"
-
-LIB_DEPEND=">=app-arch/libarchive-2.8:=[static-libs(+)]
- >=app-arch/xz-utils-5[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
-[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc"
-
-PATCHES=(
- "${FILESDIR}"/${P}-avoid-unaligned-accesses.patch
-)
-
-src_prepare() {
- default
- [[ ${PV} == "9999" ]] && eautoreconf
-}
-
-src_configure() {
- use static && append-ldflags -static
- append-flags -std=gnu99
- # Workaround silly logic that breaks cross-compiles.
- # https://github.com/vasi/pixz/issues/67
- export ac_cv_file_src_pixz_1=$([[ -f src/pixz.1 ]] && echo yes || echo no)
- econf
-}