summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-06-09 16:45:27 -0500
committerAaron Bauman <bman@gentoo.org>2020-06-12 22:05:56 -0400
commit5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c (patch)
treece0c5bce0629052916b6410aeb383bd7650936b9 /app-arch/lha/lha-114i_p20201004.ebuild
parentdev-libs/tre: Security bump (diff)
downloadgentoo-5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c.tar.gz
gentoo-5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c.tar.bz2
gentoo-5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c.zip
app-arch/lha: Security bump
Bug: https://bugs.gentoo.org/572418 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16155 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-arch/lha/lha-114i_p20201004.ebuild')
-rw-r--r--app-arch/lha/lha-114i_p20201004.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/lha/lha-114i_p20201004.ebuild b/app-arch/lha/lha-114i_p20201004.ebuild
new file mode 100644
index 000000000000..64f5b7ac288d
--- /dev/null
+++ b/app-arch/lha/lha-114i_p20201004.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_COMMIT="7c3cd95fdf0d2f9198bb779561724cd314bc39a6"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="https://github.com/jca02266/lha https://lha.osdn.jp"
+SRC_URI="https://github.com/jca02266/lha/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-file-list-from-stdin.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ dodoc olddoc/ChangeLog Hacking_of_LHa
+}