summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-14 09:10:09 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-14 09:11:46 +0200
commitf593e3ceffb4852d91cd62263c52bb33d38c3444 (patch)
treebb37b7db3614944386eb80cecaa7f1ef867fe25c /app-antivirus
parentsys-libs/glibc: disable stripping for cross-glibc (diff)
downloadgentoo-f593e3ceffb4852d91cd62263c52bb33d38c3444.tar.gz
gentoo-f593e3ceffb4852d91cd62263c52bb33d38c3444.tar.bz2
gentoo-f593e3ceffb4852d91cd62263c52bb33d38c3444.zip
app-antivirus/clamav: Remove automagic dep on dev-libs/icu (again)
Bug: https://bugs.gentoo.org/661328 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/clamav-0.102.0.ebuild1
-rw-r--r--app-antivirus/clamav/files/clamav-0.102.0-libxml2_pkgconfig.patch101
2 files changed, 102 insertions, 0 deletions
diff --git a/app-antivirus/clamav/clamav-0.102.0.ebuild b/app-antivirus/clamav/clamav-0.102.0.ebuild
index c2735a25d7d8..85d704dacfe6 100644
--- a/app-antivirus/clamav/clamav-0.102.0.ebuild
+++ b/app-antivirus/clamav/clamav-0.102.0.ebuild
@@ -47,6 +47,7 @@ RDEPEND="${CDEPEND}
HTML_DOCS=( docs/html )
PATCHES=(
+ "${FILESDIR}/${PN}-0.102.0-libxml2_pkgconfig.patch" #661328
"${FILESDIR}/${PN}-0.101.2-tinfo.patch" #670729
)
diff --git a/app-antivirus/clamav/files/clamav-0.102.0-libxml2_pkgconfig.patch b/app-antivirus/clamav/files/clamav-0.102.0-libxml2_pkgconfig.patch
new file mode 100644
index 000000000000..1a6303b5c8c2
--- /dev/null
+++ b/app-antivirus/clamav/files/clamav-0.102.0-libxml2_pkgconfig.patch
@@ -0,0 +1,101 @@
+https://bugs.gentoo.org/661328
+
+--- clamav-0.102.0/m4/reorganization/libs/xml.m4
++++ clamav-0.102.0/m4/reorganization/libs/xml.m4
+@@ -4,85 +4,29 @@
+ [AS_HELP_STRING([--disable-xml], [do not include DMG and XAR support])],
+ want_xml=$enableval, want_xml="auto")
+
+-XML_HOME=""
+-xmlconfig=""
+ if test "X$want_xml" != "Xno"; then
+- AC_MSG_CHECKING([for libxml2 installation])
+- AC_ARG_WITH([xml],
+- AS_HELP_STRING([--with-xml@<:@=DIR@:>@], [path to directory containing libxml2 library
+- @<:@default=/usr/local or /usr if not found in /usr/local@:>@]),
+- [with_xml_val=$withval]
++ PKG_CHECK_MODULES([XML], [libxml-2.0],
++ [found_xml=yes],
++ [
++ found_xml=no
++ AS_IF([test "x$want_xml" = xyes],
++ [AC_MSG_ERROR([--enable-xml set but cannot find libxml2])]
++ )
++ ]
+ )
+
+- AS_IF([test "x$with_xml_val" = "xno"], [XML_HOME=""],
+- [test "x$with_xml_val" = "xyes"], [XML_HOME="/usr/local"],
+- [XML_HOME="$with_xml_val"])
+-
+- AS_IF([test "x$XML_HOME" != "x"], [
+- AS_IF([test ! -x "$XML_HOME/bin/xml2-config"], [XML_HOME=""])
+- ])
+-
+- AS_IF([test "x$XML_HOME" = "x" -a "x$with_xml_val" = "xyes"], [
+- AS_IF([test -x "/usr/bin/xml2-config"], [XML_HOME="/usr"])
+- ])
+-
+- if test "x$XML_HOME" != "x"; then
+- AC_MSG_RESULT([$XML_HOME])
+- with_xml="yes"
+- else
+- AC_MSG_RESULT([not found])
+- fi
+-
+- found_xml="no"
+- XMLCONF_VERSION=""
+- XML_CPPFLAGS=""
+- XML_LIBS=""
+- case "$with_xml" in
+- yes) AC_PATH_PROG([xmlconfig], [xml2-config])
+- if test "x$xmlconfig" = x ; then
+- AC_MSG_NOTICE([can not locate xml2-config in PATH, will search default XML_HOME variants])
+-
+- if test "x$XML_HOME" != "x"; then
+- AC_MSG_CHECKING([xml2-config version])
+- XMLCONF_VERSION="`$XML_HOME/bin/xml2-config --version`"
+-
+- if test "x%XMLCONF_VERSION" != "x"; then
+- AC_MSG_RESULT([$XMLCONF_VERSION])
+- found_xml="yes"
+- XML_CPPFLAGS="`$XML_HOME/bin/xml2-config --cflags`"
+- XML_LIBS="`$XML_HOME/bin/xml2-config --libs`"
+- AS_ECHO("$XML_CPPFLAGS")
+- AS_ECHO("$XML_LIBS")
+- else
+- AC_MSG_ERROR([xml2-config failed])
+- fi
+- fi
+- else
+- found_xml="yes"
+- XMLCONF_VERSION="`$xmlconfig --version`"
+- XML_CPPFLAGS="`$xmlconfig --cflags`"
+- XML_LIBS="`$xmlconfig --libs`"
+- fi
+- esac
+-
+ working_xml="no"
+ if test "X$found_xml" != "Xno"; then
+-
+- readerresult=""
+- if test "x$xmlconfig" = x ; then
+- readerresult="$XML_HOME/include/libxml2/libxml/xmlreader.h"
+- else
+- readerresult="`$xmlconfig --prefix`/include/libxml2/libxml/xmlreader.h"
+- fi
+-
++ XML_HOME=$(${PKG_CONFIG} --variable prefix libxml-2.0)
+ AC_MSG_CHECKING([for xmlreader.h in $readerresult])
+
+- if test ! -f "$readerresult"; then
++ if test ! -f "$XML_HOME/include/libxml2/libxml/xmlreader.h"; then
+ AC_MSG_RESULT([not found])
+ else
+ AC_MSG_RESULT([found])
+ save_LIBS="$LIBS"
+ save_CPPFLAGS="$CPPFLAGS"
++ XML_CPPFLAGS="$XML_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $XML_CPPFLAGS"
+ save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS $XML_LIBS"