summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 07:15:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 07:47:30 +0100
commit2ad1705f6157dccd6b48c1861a2efecaee16ea4a (patch)
tree45748b3846999fdbe62d7801608a3e5b509d8b5d /app-admin
parentdev-python/boto3: Bump to 1.35.78 (diff)
downloadgentoo-2ad1705f6157dccd6b48c1861a2efecaee16ea4a.tar.gz
gentoo-2ad1705f6157dccd6b48c1861a2efecaee16ea4a.tar.bz2
gentoo-2ad1705f6157dccd6b48c1861a2efecaee16ea4a.zip
app-admin/awscli: Bump to 1.36.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.19.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b482c279f485..a1d73bbae4a1 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,4 +1,5 @@
DIST aws-cli-1.36.12.gh.tar.gz 2842234 BLAKE2B b9f333d7fa8b7aa9c0452b6da87c3b097f1b5027f1f9c36888448f5e5763a93696e1d25cca167a17d9ab7332c5491be500a44462eed44c18f886ec9f0816a248 SHA512 b7797a29230628201d808958c4f9660768646f1c1a3f53c39c09791fb8ff0cbfab000b950abc87541ff9e54723b726913a487cf5f164c8b82e609fd92dae7b14
DIST aws-cli-1.36.17.gh.tar.gz 2849378 BLAKE2B 67e79717e6ad2cdc62f79fdc6ab370e091677fff4e3f2a7872fc0f49e49e53cc395c50a5fd7ed1c46481dcc4f9b4425651bf0c09adc9f769f039647c5b33f794 SHA512 82412802be0056eaa791f725579151dab2fedbf1c6bbf5461cdde016e0d8adc977ae1fb6796696d844706f92d3a4c4bb6424e7a0e7b5a0d7b0a0c2e0070b774f
DIST aws-cli-1.36.18.gh.tar.gz 2849802 BLAKE2B c3986340d3772e9a76cdb34b39cefcb2fa5b9a784119d02f567ee8bf2b6e872e7ae4f3ec93f36322e6af91e0e8c0f3f24302fff3fa691e8f3902f246b840f802 SHA512 830e5288f3eaf9505cd2ead20bd44e4f59c876831b9a86198532554ea03a88ebd2ef060a196bad373fdf24c7eb3bb654a8322e43601843a1a1bca72d49e81870
+DIST aws-cli-1.36.19.gh.tar.gz 2850770 BLAKE2B 0eabde9e9f355491fc5de2030b46d4cb568c1665ade8814357d295d6d8f3b1faf9ea68fc9ab3101c627630af5559e7ec6096771d84f865c9ec62f015554f6508 SHA512 40c1103011566f0363f6e9ceeb86d3610f6fc857401ae2167b690cb4e7bf50dc4169c864ac7899b4b29d6ec9cf39679f1e1dcdb8883b274b70beb4add9c170e0
DIST aws-cli-1.36.9.gh.tar.gz 2836018 BLAKE2B aada8a63f5bedd5aeeddd56fe18bb49ae1763ba5c737f72aa2f2e00b57fa4e1ab52ec266ca6883859ec633ec2b1658383426809870ba1372d86f9d8e0a055ac6 SHA512 ec47c26012027071732d60f9bd8b3322c1c75b2362dffe7affd8cd6d70732e6239bfbb6531759a247bcb2f29613a88b196d10f405302d25a05ada7968bd7574e
diff --git a/app-admin/awscli/awscli-1.36.19.ebuild b/app-admin/awscli/awscli-1.36.19.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.19.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}