summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-12-31 21:46:13 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-31 21:46:28 +0100
commit203a8aa3740fe72a810b77a3e5830e477df3a17c (patch)
tree8fe6135c235f7182ee4d470dcee10d168d90589c /app-admin
parentmedia-tv/mythtv: Drop old (diff)
downloadgentoo-203a8aa3740fe72a810b77a3e5830e477df3a17c.tar.gz
gentoo-203a8aa3740fe72a810b77a3e5830e477df3a17c.tar.bz2
gentoo-203a8aa3740fe72a810b77a3e5830e477df3a17c.zip
app-admin/yadm: version bump.
Closes: https://bugs.gentoo.org/642660 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/yadm/Manifest1
-rw-r--r--app-admin/yadm/yadm-1.12.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/yadm/Manifest b/app-admin/yadm/Manifest
index a24ba32f0ef8..6b24d62501b7 100644
--- a/app-admin/yadm/Manifest
+++ b/app-admin/yadm/Manifest
@@ -1 +1,2 @@
DIST yadm-1.07.tar.gz 34240 BLAKE2B 11952a693c38aac2f2e7fa3efd469dc640941ef9c75a8a1e70974b4eea37c506df7480b2fce84ca8482c932295923ece4ff52cfc13bf9b52030dab0500f07c86 SHA512 9bbe33c82a137375cb27916ae5b5a06f06c25a75ae05688be473103c29154309d3472accc0aa0670a80a4714bc6523ab85c41fd6aa8d1909586437c5778b9144
+DIST yadm-1.12.0.tar.gz 47340 BLAKE2B ef710f56c96244c082bfcc887cae4aee00aaaadec5e7466500dde263c5e4f43df046e11742fd275e989bd9704b39a123f17248cd70d64f6ca552b28db6c44814 SHA512 402a67770154ce3ae7ab947ff4d4e26ca5040d343110fb749195ca5c3f4ee435aba1d8cdf02d4ecf4a81d3f331c1b891bed4fb3fcfcc893867e0fce45b9c8cd8
diff --git a/app-admin/yadm/yadm-1.12.0.ebuild b/app-admin/yadm/yadm-1.12.0.ebuild
new file mode 100644
index 000000000000..e6b2381a71ff
--- /dev/null
+++ b/app-admin/yadm/yadm-1.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A dotfile manager for the config files in your home folder"
+HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
+SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion test"
+
+DEPEND="
+ test? (
+ dev-tcltk/expect
+ dev-util/bats
+ dev-vcs/git
+ )"
+
+RDEPEND="
+ dev-vcs/git
+ app-crypt/gnupg
+ zsh-completion? ( app-shells/gentoo-zsh-completions )"
+
+src_compile() {
+ emake "${PN}.md"
+}
+
+src_test() {
+ # 109_accept_encryption tests are interactive, thus fail. Skip them
+ # 113_accept_jinja_alt.bats are depepending on the optional envtpl
+ while IFS="" read -d $'\0' -r f ; do
+ bats "${f}" || die "test ${f} failed"
+ done < <(find test -name '*.bats' -and -not -name '109_accept_encryption.bats' -and -not -name '113_accept_jinja_alt.bats' -print0)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "${PN}"
+ doman "${PN}.1"
+
+ dobashcomp completion/yadm.bash_completion
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins completion/yadm.zsh_completion _${PN}
+ fi
+}