summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-05-18 09:23:58 -0500
committerBen Kohler <bkohler@gentoo.org>2021-05-18 09:23:58 -0500
commitf17e79e566f4260e56c78b6609b2641da9f03399 (patch)
tree123993564e66485d3fb8bc0e3977a40ee0465040 /app-admin/ps_mem
parentx11-wm/blackbox: drop old (diff)
downloadgentoo-f17e79e566f4260e56c78b6609b2641da9f03399.tar.gz
gentoo-f17e79e566f4260e56c78b6609b2641da9f03399.tar.bz2
gentoo-f17e79e566f4260e56c78b6609b2641da9f03399.zip
app-admin/ps_mem: snapshot bump & add python3_10 support
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-admin/ps_mem')
-rw-r--r--app-admin/ps_mem/Manifest1
-rw-r--r--app-admin/ps_mem/ps_mem-3.13_p20201212.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/ps_mem/Manifest b/app-admin/ps_mem/Manifest
index 11bf64c967a9..77077acc5c21 100644
--- a/app-admin/ps_mem/Manifest
+++ b/app-admin/ps_mem/Manifest
@@ -1 +1,2 @@
DIST ps_mem-3.13_p20200417.tar.gz 18472 BLAKE2B 43e04d0357458107fb25600024243baaec703124fc58a819c011c847a52ad6fb7384ef38a5aa965e3ae88288cca6c76a15819466839eb729a63c4492eaa4ec0d SHA512 9694cec5d696a42dfe2f60dd024f541283e2f52aafb499ee2e551574133262bb0fc4bf6eb0e7075fb1b129aff6cd8fe6968f411f56ee1d31eb6f9aebff2d9852
+DIST ps_mem-3.13_p20201212.tar.gz 18513 BLAKE2B f3eea2008dbb60d34f8f3f1b6369f426685f35e5a39d40eb40dc682b01d20722f54cf965e3ee6a08ccaa14c17341c1c2ae3adbcb4b55c64798ed31ceb6f29ff7 SHA512 7f3f382d803ed2c5c7005f6b79ff8d19cb3d1aa1155717b5eeb94582c49886bce2e18d5ed41133294b7e3b7f2fbfe1d0a517619d0be6bbaf36fc71c7c5a181b6
diff --git a/app-admin/ps_mem/ps_mem-3.13_p20201212.ebuild b/app-admin/ps_mem/ps_mem-3.13_p20201212.ebuild
new file mode 100644
index 000000000000..28e3108ad2d3
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.13_p20201212.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 vcs-snapshot
+
+COMMIT="f26d3f416430d1e25659fa6dd5e7412029d8fa9c"
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/ps_mem"
+SRC_URI="https://github.com/pixelb/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}