summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 10:08:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 11:14:27 +0200
commit935cfce2e99b628fc05d0343c602350f94ca0a30 (patch)
tree9a430b6cf42bc8e203da553b505c796495f8d9f0 /app-admin/gentoo-retirement-scripts
parentapp-admin/undertaker-scripts: Prepare for rename (diff)
downloadgentoo-935cfce2e99b628fc05d0343c602350f94ca0a30.tar.gz
gentoo-935cfce2e99b628fc05d0343c602350f94ca0a30.tar.bz2
gentoo-935cfce2e99b628fc05d0343c602350f94ca0a30.zip
Rename app-admin/{undertaker → gentoo-retirement}-scripts
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/gentoo-retirement-scripts')
-rw-r--r--app-admin/gentoo-retirement-scripts/Manifest1
-rw-r--r--app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-1.ebuild37
-rw-r--r--app-admin/gentoo-retirement-scripts/metadata.xml9
3 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/gentoo-retirement-scripts/Manifest b/app-admin/gentoo-retirement-scripts/Manifest
new file mode 100644
index 000000000000..4cbfee2c0a9f
--- /dev/null
+++ b/app-admin/gentoo-retirement-scripts/Manifest
@@ -0,0 +1 @@
+DIST undertaker-scripts-1.tar.gz 6608 BLAKE2B 82aaf4395f480b2ac7194c9d0022a1001e0f6e3fd137db030bac8d0d0fa80e7f51a086dbdc611c6698a765b467178d9c85518947fd26cc062904142babec3d72 SHA512 a946e669628f1dba4ff6846fa79a5eb1ea44cf19b3ec2d5d24d6792f0d621e262514d346379be88c1abc529373e0cfadb83eed9ba1cd4d4e2f73a078fc20fe04
diff --git a/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-1.ebuild b/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-1.ebuild
new file mode 100644
index 000000000000..739728fb2bac
--- /dev/null
+++ b/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1
+
+MY_P=undertaker-scripts-${PV}
+DESCRIPTION="Scripts to help retiring Gentoo developers"
+HOMEPAGE="https://github.com/mgorny/gentoo-retirement-scripts/"
+SRC_URI="mirror://gentoo/40/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-bugzilla[${PYTHON_USEDEP}]
+ ')"
+
+src_compile() {
+ python_fix_shebang .
+}
+
+src_install() {
+ exeinto /opt/undertaker-scripts
+ doexe *.py
+ insinto /opt/undertaker-scripts
+ doins *.template
+}
diff --git a/app-admin/gentoo-retirement-scripts/metadata.xml b/app-admin/gentoo-retirement-scripts/metadata.xml
new file mode 100644
index 000000000000..996eb9fa78a2
--- /dev/null
+++ b/app-admin/gentoo-retirement-scripts/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>