summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-04 09:51:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-04 11:26:24 +0100
commit66dc6891e6a26cb3d7c31bad7ca92d90e6c69f4b (patch)
tree5f720a1975aa8b09de0202425e2d87d5aaad5151 /app-admin/awscli
parentdev-python/boto3: Bump to 1.20.48 (diff)
downloadgentoo-66dc6891e6a26cb3d7c31bad7ca92d90e6c69f4b.tar.gz
gentoo-66dc6891e6a26cb3d7c31bad7ca92d90e6c69f4b.tar.bz2
gentoo-66dc6891e6a26cb3d7c31bad7ca92d90e6c69f4b.zip
app-admin/awscli: Bump to 1.22.48
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.48.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index fc2145b5ab56..f1e7d7807167 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -9,3 +9,4 @@ DIST awscli-1.22.44.tar.gz 2150694 BLAKE2B db7e88a58ff42cf1ebc2b337ae408dd90d80a
DIST awscli-1.22.45.tar.gz 2151247 BLAKE2B b1f90eb47563d6fe1936fdaa486771778a8e1c2e449e2b6272bfac403100ad72ec53b0ff1925aec9e3e2497040d2998f2034d1d7777a927a68f97da47045a7cc SHA512 3cad811fdaeff8434750887fb3c6a8e6716ae4a1859294d73d25158f14cfe56226ca99994d3eaee1ab5c11a442720c450331948ab64805d33bd0bbec8a8c64d0
DIST awscli-1.22.46.tar.gz 2160630 BLAKE2B 628f60975b66fb60b4a91edb98856d9cc8cf7b88a1819048dfa25e8a4e3e3b73eade8bfd00355b7bd36a3c61d7028c8226071616aa325021a9e7805a65ff1eda SHA512 0a3eb819a5b34ae0b777f4e35b58ffe165e712bcbe4364643cb5a278f982138e0a4749944d312fd8d5998796758465f4814b67d7a230eb421cb04cf9193dcd5d
DIST awscli-1.22.47.tar.gz 2161197 BLAKE2B ede83ea2a0ca35aab53eea5950eab59a5f845f556eacfe7c053d8127b5c9526ba53e37f424796a96cb7608b45710d6886108451f934e3beb011d130639550856 SHA512 dfc2ab904ec5099d2c55b7752460b88fc37ac98e13cdc402ab7fdbe462170aabfc005be111cc0edc7c692a5f96f569d60888183e0c07d7e3e2c0ff34d2c6e683
+DIST awscli-1.22.48.tar.gz 2161566 BLAKE2B f9ced24e30951ec517753fa0d1e8c321d9f5d2b32374c82c794f669c012f6e56b69456fed550db2c1753d9cd9c0bf4c5a964c5dc656e66da99815ee063940323 SHA512 149d06dd400d4a5616d4da38c5b6ef4223da88f09ce77e82524dac1b1cb27deb047b032759f0188ba6a6fda456101e361655fa363fd2c50554a3a1e506e5ffe1
diff --git a/app-admin/awscli/awscli-1.22.48.ebuild b/app-admin/awscli/awscli-1.22.48.ebuild
new file mode 100644
index 000000000000..1f3430af8a9f
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.48.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}