summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-11-12 21:28:37 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-11-12 21:28:37 +0000
commitfb33f1d83a9108240e72b79b5ee3122f7141e11f (patch)
treecab2d6eee8d81e98ef3afe6975c3ad25037db956
parent2018-11-12 20:44:35 UTC (diff)
parentwww-client/google-chrome: decompress documentation (diff)
downloadgentoo-fb33f1d83a9108240e72b79b5ee3122f7141e11f.tar.gz
gentoo-fb33f1d83a9108240e72b79b5ee3122f7141e11f.tar.bz2
gentoo-fb33f1d83a9108240e72b79b5ee3122f7141e11f.zip
Merge updates from master
-rw-r--r--eclass/java-ant-2.eclass6
-rw-r--r--eclass/java-utils-2.eclass12
-rw-r--r--sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch25
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild34
-rw-r--r--www-client/google-chrome-beta/google-chrome-beta-71.0.3578.44.ebuild17
-rw-r--r--www-client/google-chrome-unstable/google-chrome-unstable-72.0.3602.2.ebuild16
-rw-r--r--www-client/google-chrome/google-chrome-70.0.3538.102.ebuild17
7 files changed, 105 insertions, 22 deletions
diff --git a/eclass/java-ant-2.eclass b/eclass/java-ant-2.eclass
index 8da5971844a0..1fd4feb39134 100644
--- a/eclass/java-ant-2.eclass
+++ b/eclass/java-ant-2.eclass
@@ -56,12 +56,10 @@ if [[ $? != 0 ]]; then
die "java-pkg_ant-tasks-depend() failed"
fi
-# We need some tools from javatoolkit. We also need portage 2.1 for phase hooks
-# and ant dependencies constructed above. Python is there for
-# java-ant_remove-taskdefs
+# We need some tools from javatoolkit. We also need ant dependencies
+# constructed above.
JAVA_ANT_E_DEPEND="${JAVA_ANT_E_DEPEND}
${ANT_TASKS_DEPEND}
- ${JAVA_PKG_PORTAGE_DEP}
>=dev-java/javatoolkit-0.3.0-r2"
# this eclass must be inherited after java-pkg-2 or java-pkg-opt-2
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index 1ba8bc5c5b5a..473b177e539a 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -1,4 +1,4 @@
-# Copyright 2004-2017 Gentoo Foundation
+# Copyright 2004-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: java-utils-2.eclass
@@ -25,21 +25,13 @@ export WANT_JAVA_CONFIG="2"
# Prefix variables are only available for EAPI>=3
has "${EAPI:-0}" 0 1 2 && ED="${D}" EPREFIX= EROOT="${ROOT}"
-# @VARIABLE: JAVA_PKG_PORTAGE_DEP
-# @INTERNAL
-# @DESCRIPTION:
-# The version of portage we need to function properly. Previously it was
-# portage with phase hooks support but now we use a version with proper env
-# saving. For EAPI 2 we have new enough stuff so let's have cleaner deps.
-has "${EAPI}" 0 1 && JAVA_PKG_PORTAGE_DEP=">=sys-apps/portage-2.1.2.7"
-
# @VARIABLE: JAVA_PKG_E_DEPEND
# @INTERNAL
# @DESCRIPTION:
# This is a convience variable to be used from the other java eclasses. This is
# the version of java-config we want to use. Usually the latest stable version
# so that ebuilds can use new features without depending on specific versions.
-JAVA_PKG_E_DEPEND=">=dev-java/java-config-2.2.0-r3 ${JAVA_PKG_PORTAGE_DEP}"
+JAVA_PKG_E_DEPEND=">=dev-java/java-config-2.2.0-r3"
has source ${JAVA_PKG_IUSE} && JAVA_PKG_E_DEPEND="${JAVA_PKG_E_DEPEND} source? ( app-arch/zip )"
# @ECLASS-VARIABLE: JAVA_PKG_WANT_BOOTCLASSPATH
diff --git a/sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch b/sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch
new file mode 100644
index 000000000000..7dc5feb2fc1f
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/files/plymouth-openrc-plugin-0.1.2-exit-at-mount-ro.patch
@@ -0,0 +1,25 @@
+From 9d3485d73244eea61205c4c84b2c37d489d5bbcb Mon Sep 17 00:00:00 2001
+From: tlhonmey <lperkins@zagmail.gonzaga.edu>
+Date: Wed, 31 Jan 2018 11:10:48 -0800
+Subject: [PATCH] Exit plymouth when we hit mount-ro rather than localmount.
+
+Newer versions of openrc appear to run localmount almost immediately upon shutdown, causing the plugin to send Plymouth the quit command before the splash is even displayed, resulting in no splash on shutdown.
+
+The job that cuts us off from writing to /var is now mount-ro, which runs near the end like it should and gives Plymouth time to show the splash.
+---
+ plymouth.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plymouth.c b/plymouth.c
+index e657e82..e9c925b 100644
+--- a/plymouth.c
++++ b/plymouth.c
+@@ -240,7 +240,7 @@ int rc_plugin_hook(RC_HOOK hook, const char *name)
+
+ case RC_HOOK_SERVICE_STOP_IN:
+ /* Quit Plymouth when we're going to lost write access to /var/... */
+- if(strcmp(name, "localmount") == 0 &&
++ if(strcmp(name, "mount-ro") == 0 &&
+ strcmp(runlevel, RC_LEVEL_SHUTDOWN) == 0) {
+ DBG("ply_quit(PLY_MODE_SHUTDOWN)");
+ if(!ply_quit(PLY_MODE_SHUTDOWN))
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..a073ee75df03
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/aidecoe/plymouth-openrc-plugin"
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/openrc:="
+RDEPEND="${DEPEND}
+ sys-boot/plymouth"
+
+PATCHES=( "${FILESDIR}/${P}-exit-at-mount-ro.patch" )
+
+src_install() {
+ insinto /$(get_libdir)/rc/plugins
+ doins plymouth.so
+}
+
+pkg_postinst() {
+ ewarn "You need to disable 'rc_interactive' feature in /etc/rc.conf to make"
+ ewarn "Plymouth work properly with OpenRC init system."
+
+ if has_version sys-apps/systemd; then
+ eerror "sys-apps/systemd is installed, please uninstall this package if you"
+ eerror "are booting with systemd"
+ fi
+}
diff --git a/www-client/google-chrome-beta/google-chrome-beta-71.0.3578.44.ebuild b/www-client/google-chrome-beta/google-chrome-beta-71.0.3578.44.ebuild
index 3a03ee42c9b5..710495360327 100644
--- a/www-client/google-chrome-beta/google-chrome-beta-71.0.3578.44.ebuild
+++ b/www-client/google-chrome-beta/google-chrome-beta-71.0.3578.44.ebuild
@@ -13,8 +13,10 @@ DESCRIPTION="The web browser from Google"
HOMEPAGE="https://www.google.com/chrome"
if [[ ${PN} == google-chrome ]]; then
+ KEYWORDS="-* amd64"
MY_PN=${PN}-stable
else
+ KEYWORDS="-* ~amd64"
MY_PN=${PN}
fi
@@ -24,7 +26,6 @@ SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd
LICENSE="google-chrome"
SLOT="0"
-KEYWORDS="-* ~amd64"
IUSE="+plugins"
RESTRICT="bindist mirror strip"
@@ -38,7 +39,6 @@ RDEPEND="
dev-libs/glib:2
dev-libs/nspr
>=dev-libs/nss-3.26
- gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype:2
@@ -94,6 +94,13 @@ src_install() {
rm -r etc usr/share/menu || die
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/google-chrome.1.gz ]]; then
+ rm usr/share/man/man1/google-chrome.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/google-chrome.1
+ fi
+
pushd "${CHROME_HOME}/locales" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die
@@ -104,9 +111,13 @@ src_install() {
-i "${CHROME_HOME}/${PN}" || die
fi
+ local suffix=
+ [[ ${PN} == google-chrome-beta ]] && suffix=_beta
+ [[ ${PN} == google-chrome-unstable ]] && suffix=_dev
+
local size
for size in 16 22 24 32 48 64 128 256 ; do
- newicon -s ${size} "${CHROME_HOME}/product_logo_${size}_beta.png" ${PN}.png
+ newicon -s ${size} "${CHROME_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
done
pax-mark m "${CHROME_HOME}/chrome"
diff --git a/www-client/google-chrome-unstable/google-chrome-unstable-72.0.3602.2.ebuild b/www-client/google-chrome-unstable/google-chrome-unstable-72.0.3602.2.ebuild
index 57fa25d49a63..710495360327 100644
--- a/www-client/google-chrome-unstable/google-chrome-unstable-72.0.3602.2.ebuild
+++ b/www-client/google-chrome-unstable/google-chrome-unstable-72.0.3602.2.ebuild
@@ -13,8 +13,10 @@ DESCRIPTION="The web browser from Google"
HOMEPAGE="https://www.google.com/chrome"
if [[ ${PN} == google-chrome ]]; then
+ KEYWORDS="-* amd64"
MY_PN=${PN}-stable
else
+ KEYWORDS="-* ~amd64"
MY_PN=${PN}
fi
@@ -24,7 +26,6 @@ SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd
LICENSE="google-chrome"
SLOT="0"
-KEYWORDS="-* ~amd64"
IUSE="+plugins"
RESTRICT="bindist mirror strip"
@@ -93,6 +94,13 @@ src_install() {
rm -r etc usr/share/menu || die
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/google-chrome.1.gz ]]; then
+ rm usr/share/man/man1/google-chrome.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/google-chrome.1
+ fi
+
pushd "${CHROME_HOME}/locales" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die
@@ -103,9 +111,13 @@ src_install() {
-i "${CHROME_HOME}/${PN}" || die
fi
+ local suffix=
+ [[ ${PN} == google-chrome-beta ]] && suffix=_beta
+ [[ ${PN} == google-chrome-unstable ]] && suffix=_dev
+
local size
for size in 16 22 24 32 48 64 128 256 ; do
- newicon -s ${size} "${CHROME_HOME}/product_logo_${size}_dev.png" ${PN}.png
+ newicon -s ${size} "${CHROME_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
done
pax-mark m "${CHROME_HOME}/chrome"
diff --git a/www-client/google-chrome/google-chrome-70.0.3538.102.ebuild b/www-client/google-chrome/google-chrome-70.0.3538.102.ebuild
index d7d8f612b2b9..710495360327 100644
--- a/www-client/google-chrome/google-chrome-70.0.3538.102.ebuild
+++ b/www-client/google-chrome/google-chrome-70.0.3538.102.ebuild
@@ -13,8 +13,10 @@ DESCRIPTION="The web browser from Google"
HOMEPAGE="https://www.google.com/chrome"
if [[ ${PN} == google-chrome ]]; then
+ KEYWORDS="-* amd64"
MY_PN=${PN}-stable
else
+ KEYWORDS="-* ~amd64"
MY_PN=${PN}
fi
@@ -24,7 +26,6 @@ SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd
LICENSE="google-chrome"
SLOT="0"
-KEYWORDS="-* amd64"
IUSE="+plugins"
RESTRICT="bindist mirror strip"
@@ -38,7 +39,6 @@ RDEPEND="
dev-libs/glib:2
dev-libs/nspr
>=dev-libs/nss-3.26
- gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype:2
@@ -94,6 +94,13 @@ src_install() {
rm -r etc usr/share/menu || die
mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/google-chrome.1.gz ]]; then
+ rm usr/share/man/man1/google-chrome.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/google-chrome.1
+ fi
+
pushd "${CHROME_HOME}/locales" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die
@@ -104,9 +111,13 @@ src_install() {
-i "${CHROME_HOME}/${PN}" || die
fi
+ local suffix=
+ [[ ${PN} == google-chrome-beta ]] && suffix=_beta
+ [[ ${PN} == google-chrome-unstable ]] && suffix=_dev
+
local size
for size in 16 22 24 32 48 64 128 256 ; do
- newicon -s ${size} "${CHROME_HOME}/product_logo_${size}.png" ${PN}.png
+ newicon -s ${size} "${CHROME_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
done
pax-mark m "${CHROME_HOME}/chrome"