summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-22 11:38:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-22 11:42:43 +0200
commitf63c083c1a08e065b311a042f1ee273e9c30eda9 (patch)
tree8f3edf0433dfc8b8ee9d0d4dee3e5f49fe7c2150
parentnet-im/cawbird: skip tests that require the network (diff)
downloadgentoo-f63c083c1a08e065b311a042f1ee273e9c30eda9.tar.gz
gentoo-f63c083c1a08e065b311a042f1ee273e9c30eda9.tar.bz2
gentoo-f63c083c1a08e065b311a042f1ee273e9c30eda9.zip
sci-physics/fastjet: add 3.4.0
Closes: https://github.com/gentoo/sci/pull/1158 Bug: https://bugs.gentoo.org/851912 Co-authored-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-physics/fastjet/Manifest1
-rw-r--r--sci-physics/fastjet/fastjet-3.4.0.ebuild75
-rw-r--r--sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch11
-rw-r--r--sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch75
4 files changed, 162 insertions, 0 deletions
diff --git a/sci-physics/fastjet/Manifest b/sci-physics/fastjet/Manifest
index 74c5e31c636f..7919615faa33 100644
--- a/sci-physics/fastjet/Manifest
+++ b/sci-physics/fastjet/Manifest
@@ -1 +1,2 @@
DIST fastjet-3.0.6.tar.gz 2216501 BLAKE2B 1aacab5c91cb70d66035deddc4929d60c51444f6f23396f947d704f607d5f2267ccc5e09ec633d6e0ec1255b3a6bc7e51e4ea49c4cb06d0e3b6953b601ab76ee SHA512 1f01b7ed0e07bd94c88faa123f72c2e3bcd81ad32ab4d03dc0a18dd18635f3b18ba8d339176b0ef1d6e58cecd9f37aaea30b4ad909d2782ce5be7c11e205c3a5
+DIST fastjet-3.4.0.tar.gz 2959127 BLAKE2B c99e89ee5cea3fd4e3edebdfebb50efd3c58e7ab15215a384c44120ac930882bd2d4e446b61977fe65dcc49056b958c6510abb7c5889024ae49776b1955bd023 SHA512 af8aeb6197f6bd82ec5f127647f49cd5d455c20e614c23d928b850fc97bc12c70cf6e3b09f1bb0308c2a080fcd4fa13416eea0195695060efaa0e400a687d7b7
diff --git a/sci-physics/fastjet/fastjet-3.4.0.ebuild b/sci-physics/fastjet/fastjet-3.4.0.ebuild
new file mode 100644
index 000000000000..f114cdf358f0
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.4.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{8..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ cgal? ( <sci-mathematics/cgal-5.3:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/fortran"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-siscone.patch
+ "${FILESDIR}"/${P}-gfortran.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ $(use_enable cgal) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch b/sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch
new file mode 100644
index 000000000000..639cbf253589
--- /dev/null
+++ b/sci-physics/fastjet/files/fastjet-3.4.0-gfortran.patch
@@ -0,0 +1,11 @@
+--- a/plugins/PxCone/Makefile.am 2022-07-20 18:25:01.390035710 +0200
++++ b/plugins/PxCone/Makefile.am 2022-07-20 18:25:43.261623399 +0200
+@@ -7,7 +7,7 @@
+ endif
+ libPxConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/../../include
+ libPxConePlugin_la_SOURCES = pxcone.f PxConePlugin.cc
+-libPxConePlugin_la_LIBADD = ../../src/libfastjet.la
++libPxConePlugin_la_LIBADD = ../../src/libfastjet.la -lgfortran
+
+ EXTRA_DIST = makefile.static pxcone.h
+
diff --git a/sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch b/sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch
new file mode 100644
index 000000000000..0aa29d07ab38
--- /dev/null
+++ b/sci-physics/fastjet/files/fastjet-3.4.0-system-siscone.patch
@@ -0,0 +1,75 @@
+diff -Nur fastjet-3.0.6.orig/configure.ac fastjet-3.0.6/configure.ac
+--- fastjet-3.0.6.orig/configure.ac 2014-05-06 10:29:55.240632504 -0700
++++ fastjet-3.0.6/configure.ac 2014-05-06 10:36:20.156246416 -0700
+@@ -261,6 +261,12 @@
+ fi
+
+ dnl SISCone
++AC_ARG_WITH(bundle-siscone,
++ [ --with-bundle-siscone Build the bundled SISCone library [default=no]],
++ [bundle_siscone=$withval],
++ [bundle_siscone=no])
++AM_CONDITIONAL(BUNDLE_SISCONE, test x$bundle_siscone != xno)
++
+ ACX_CHECK_PLUGIN(SISCone, siscone, SISCONE, yes,
+ [CONFIG_LIBS_PLUGINS=${CONFIG_LIBS_PLUGINS}" -lsiscone_spherical -lsiscone"
+ CONFIG_LIBS_PLUGINS_STATIC=${CONFIG_LIBS_PLUGINS_STATIC}" \${installationdir}/lib/libsiscone.a \${installationdir}/lib/libsiscone_spherical.a"])
+diff -Nur fastjet-3.0.6.orig/example/Makefile.am fastjet-3.0.6/example/Makefile.am
+--- fastjet-3.0.6.orig/example/Makefile.am 2014-05-06 10:29:55.239632499 -0700
++++ fastjet-3.0.6/example/Makefile.am 2014-05-06 10:36:20.156246416 -0700
+@@ -43,7 +43,7 @@
+ 03_plugin_CXXFLAGS = $(AM_CXXFLAGS) $(CGAL_CPPFLAGS) -I$(srcdir)/../include
+ 03_plugin_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ 03_plugin_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++03_plugin_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ else
+ EXTRA_DIST += 03-plugin.cc
+ endif
+@@ -125,7 +125,7 @@
+ fastjet_areas_LDADD = ../src/libfastjet.la $(CGAL_LIBS)
+ if BUILD_PLUGIN_SISCONE
+ fastjet_areas_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_areas_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+
+ fastjet_timing_plugins_SOURCES = fastjet_timing_plugins.cc CmdLine.cc
+@@ -135,7 +135,7 @@
+ fastjet_timing_plugins_LDADD += ../tools/libfastjettools.la
+ if BUILD_PLUGIN_SISCONE
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/SISCone -I$(srcdir)/../plugins/SISCone/siscone
+-fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la ../plugins/SISCone/siscone/siscone/libsiscone.la ../plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++fastjet_timing_plugins_LDADD += ../plugins/SISCone/libSISConePlugin.la
+ endif
+ if BUILD_PLUGIN_CDFCONES
+ fastjet_timing_plugins_CXXFLAGS += -I$(srcdir)/../plugins/CDFCones
+diff -Nur fastjet-3.4.0/plugins/SISCone/Makefile.am.orig fastjet-3.4.0/plugins/SISCone/Makefile.am
+--- fastjet-3.4.0/plugins/SISCone/Makefile.am.orig 2022-03-10 11:21:49.888900042 +0100
++++ fastjet-3.4.0/plugins/SISCone/Makefile.am 2022-03-10 11:23:07.790909024 +0100
+@@ -1,12 +1,22 @@
+-SUBDIRS = siscone fastjet .
++SUBDIRS = fastjet .
+
+ if MONOLITHIC_PLUGINS
+ noinst_LTLIBRARIES = libSISConePlugin.la
+ else
+ lib_LTLIBRARIES = libSISConePlugin.la
+ endif
+-libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/siscone -I$(srcdir)/../../include -I./siscone
++libSISConePlugin_la_CXXFLAGS = $(AM_CXXFLAGS) -I$(srcdir) -I$(srcdir)/../../include
++
++if BUNDLE_SISCONE
++SUBDIRS += siscone
++libSISConePlugin_la_CXXFLAGS += -I$(srcdir)/siscone
++libSISConePlugin_la_LIBADD = \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/libsiscone.la \
++ $(top_builddir)/plugins/SISCone/siscone/siscone/spherical/libsiscone_spherical.la
++else
++libSISConePlugin_la_LIBADD = -lsiscone -lsiscone_spherical
++endif
+ libSISConePlugin_la_SOURCES = SISConeBasePlugin.cc SISConePlugin.cc SISConeSphericalPlugin.cc
+-libSISConePlugin_la_LIBADD = ../../src/libfastjet.la siscone/siscone/libsiscone.la siscone/siscone/spherical/libsiscone_spherical.la
++
+
+ EXTRA_DIST = makefile.static