summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-09 03:38:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-09 04:10:22 +0200
commite59ffc992bd611f25ccb969bf8720d7516d4ec95 (patch)
tree1ae54e5d86ee27e36da4d6ce69e205349a977c82
parentdev-python/google-auth: Bump to 2.32.0 (diff)
downloadgentoo-e59ffc992bd611f25ccb969bf8720d7516d4ec95.tar.gz
gentoo-e59ffc992bd611f25ccb969bf8720d7516d4ec95.tar.bz2
gentoo-e59ffc992bd611f25ccb969bf8720d7516d4ec95.zip
dev-python/jsonschema: Bump to 4.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.23.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index be3aeb25184f..c2e9a5c8ec07 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1 +1,2 @@
DIST jsonschema-4.22.0.tar.gz 325490 BLAKE2B aa0fcd9cb35ffe93d9e7ae940f9fbfc6e20656b09bdec91163ee7120b3495210522c2354dd3e74b33274f61bd9364b6b33f9e6482bac58b2ee0c6dd4bba3658e SHA512 72c9ffd1edf8820696d831062cfae2d38729935b32d12b7fa5171fefa3d38d495b588152c07224a5c9d1f4b9f97bd9b2aa7919d3d4ecdae0ba396e60e954b1c5
+DIST jsonschema-4.23.0.tar.gz 325778 BLAKE2B ccfcfa2b8f27e1d1f3a7d282f4701b04e3711bb57853f5f252ea286bb240395814c33219fff1b2bea661f462d1fc20fcf7d919fe85593d2e1dd89ac289f18ced SHA512 3bc3f7c4bb22dc0233bf99ca5cb8e22002cc3b097c7ae8a78c83ae106e4791dcaca228a6830074b1c42312889374b66c1f5390932768110a1e453babd7302bf9
diff --git a/dev-python/jsonschema/jsonschema-4.23.0.ebuild b/dev-python/jsonschema/jsonschema-4.23.0.ebuild
new file mode 100644
index 000000000000..6c03f86de51f
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.23.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ !!dev-python/shiboken6
+ )
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri-template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-24.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)