summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-09-02 17:51:32 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-09-02 17:51:32 +0000
commite21a9ec7eb58517daa814a33428f014dbda6e7f3 (patch)
tree0cdfb10c260bfe5c802a75ff843a8ce48e01ca91
parent2021-09-02 17:36:36 UTC (diff)
parentdev-python/flufl-bounce: mark ALLARCHES (diff)
downloadgentoo-e21a9ec7eb58517daa814a33428f014dbda6e7f3.tar.gz
gentoo-e21a9ec7eb58517daa814a33428f014dbda6e7f3.tar.bz2
gentoo-e21a9ec7eb58517daa814a33428f014dbda6e7f3.zip
Merge updates from master
-rw-r--r--dev-python/flufl-bounce/Manifest1
-rw-r--r--dev-python/flufl-bounce/flufl-bounce-4.0.ebuild30
-rw-r--r--dev-python/flufl-bounce/metadata.xml2
-rw-r--r--dev-python/repoze-sphinx-autointerface/metadata.xml1
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild11
-rw-r--r--eclass/ant-tasks.eclass1
-rw-r--r--eclass/gnustep-2.eclass1
-rw-r--r--eclass/java-ant-2.eclass1
-rw-r--r--eclass/java-osgi.eclass1
-rw-r--r--eclass/java-pkg-2.eclass1
-rw-r--r--eclass/java-pkg-opt-2.eclass1
11 files changed, 43 insertions, 8 deletions
diff --git a/dev-python/flufl-bounce/Manifest b/dev-python/flufl-bounce/Manifest
index 4f526da0246f..2771fff8fa04 100644
--- a/dev-python/flufl-bounce/Manifest
+++ b/dev-python/flufl-bounce/Manifest
@@ -1 +1,2 @@
DIST flufl-bounce-3.0.1.tar.gz 100217 BLAKE2B d5620d73513a7e5bbfffb212f13bba34ce199a129a217873a8237d8456a7a1854d78cb9b06e4ee763d4dcfdcfdc185e0d67eb3be82ad829c054baced8acfc25c SHA512 9a8d0dec98f8699fd3dff62f5dd831ab5754f11d246b750cfed8ae7ebb771c3c7c1abd4fcceb0f8aa052653802c6e6e5a7bd4711e63b9095ede238817a3cd146
+DIST flufl.bounce-4.0.tar.gz 108623 BLAKE2B 00c9d69d0aab3a4ca6f781dbd32bcc00d33de59371a163589f8be1747144f6cb9f51da57152235cfbc08ded63894402669c0ba4745eeb3c7b60c95cccf6206c7 SHA512 c6dd8cf2f4f0ea7c8698054042dfc9da3bd1a2d9cae082e01a0be9c39018fefba07154e2c9c15b1a00c896e58bb0a6d2063a3c067bec6b464d201bb7b3220e9e
diff --git a/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild b/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
new file mode 100644
index 000000000000..fb2312fbbe76
--- /dev/null
+++ b/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Email bounce detectors."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.bounce"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/flufl-bounce/metadata.xml b/dev-python/flufl-bounce/metadata.xml
index dc01cb742b0d..ace3341bb63d 100644
--- a/dev-python/flufl-bounce/metadata.xml
+++ b/dev-python/flufl-bounce/metadata.xml
@@ -8,7 +8,9 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">flufl.bounce</remote-id>
+ <remote-id type="gitlab">warsaw/flufl.bounce</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/repoze-sphinx-autointerface/metadata.xml b/dev-python/repoze-sphinx-autointerface/metadata.xml
index b517394095ba..c1b6514bacd8 100644
--- a/dev-python/repoze-sphinx-autointerface/metadata.xml
+++ b/dev-python/repoze-sphinx-autointerface/metadata.xml
@@ -5,6 +5,7 @@
<email>dolsen@gentoo.org</email>
<name>Brian Dolbec</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">repoze.sphinx.autointerface</remote-id>
</upstream>
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
index a8135be13fff..519d2a62939c 100644
--- a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
+++ b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
MY_PN=${PN//-/.}
@@ -14,6 +13,7 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
HOMEPAGE="https://pypi.org/project/repoze.sphinx.autointerface/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="repoze"
SLOT="0"
@@ -24,11 +24,6 @@ RDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
"
-DEPEND="
- ${RDEPEND}
-"
-
-S=${WORKDIR}/${MY_P}
python_install() {
distutils-r1_python_install
diff --git a/eclass/ant-tasks.eclass b/eclass/ant-tasks.eclass
index ea347fd706af..71923261084c 100644
--- a/eclass/ant-tasks.eclass
+++ b/eclass/ant-tasks.eclass
@@ -7,6 +7,7 @@
# @AUTHOR:
# Vlastimil Babka <caster@gentoo.org>
# @SUPPORTED_EAPIS: 6 7
+# @PROVIDES: java-utils-2
# @BLURB: Eclass for building dev-java/ant-* packages
# @DESCRIPTION:
# This eclass provides functionality and default ebuild variables for building
diff --git a/eclass/gnustep-2.eclass b/eclass/gnustep-2.eclass
index 2d615db3a1f2..68c15bbc62e1 100644
--- a/eclass/gnustep-2.eclass
+++ b/eclass/gnustep-2.eclass
@@ -5,6 +5,7 @@
# @MAINTAINER:
# GNUstep Herd <gnustep@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7 8
+# @PROVIDES: gnustep-base
# @BLURB: eclass for GNUstep Apps, Frameworks, and Bundles build
# @DESCRIPTION:
# This eclass sets up GNUstep environment to properly install
diff --git a/eclass/java-ant-2.eclass b/eclass/java-ant-2.eclass
index 5592186936c0..501d17ef229e 100644
--- a/eclass/java-ant-2.eclass
+++ b/eclass/java-ant-2.eclass
@@ -8,6 +8,7 @@
# kiorky <kiorky@cryptelium.net>
# Petteri Räty <betelgeuse@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
+# @PROVIDES: java-utils-2
# @BLURB: eclass for ant based Java packages
# @DESCRIPTION:
# Eclass for Ant-based Java packages. Provides support for both automatic and
diff --git a/eclass/java-osgi.eclass b/eclass/java-osgi.eclass
index abbf73cdd3fa..74c7c1a07f5c 100644
--- a/eclass/java-osgi.eclass
+++ b/eclass/java-osgi.eclass
@@ -7,6 +7,7 @@
# @AUTHOR:
# Java maintainers <java@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
+# @PROVIDES: java-utils-2
# @BLURB: Java OSGi eclass
# @DESCRIPTION:
# This eclass provides functionality which is used by packages that need to be
diff --git a/eclass/java-pkg-2.eclass b/eclass/java-pkg-2.eclass
index 4d5cb7665728..96d33f9d1962 100644
--- a/eclass/java-pkg-2.eclass
+++ b/eclass/java-pkg-2.eclass
@@ -7,6 +7,7 @@
# @AUTHOR:
# Thomas Matthijs <axxo@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
+# @PROVIDES: java-utils-2
# @BLURB: Eclass for Java Packages
# @DESCRIPTION:
# This eclass should be inherited for pure Java packages, or by packages which
diff --git a/eclass/java-pkg-opt-2.eclass b/eclass/java-pkg-opt-2.eclass
index 7f1f5a2f8394..85783bae6e2d 100644
--- a/eclass/java-pkg-opt-2.eclass
+++ b/eclass/java-pkg-opt-2.eclass
@@ -7,6 +7,7 @@
# @AUTHOR:
# Thomas Matthijs <axxo@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
+# @PROVIDES: java-utils-2
# @BLURB: Eclass for package with optional Java support
# @DESCRIPTION:
# Inherit this eclass instead of java-pkg-2 if you only need optional Java