summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-20 19:37:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-20 20:17:04 +0100
commitd814040f8983438f025629eeae90ce13a78dd0c1 (patch)
treef7baa6fa0015c8fe17f2b21bade1fb5fdd44294a
parentdev-python/Faker: Bump to 20.1.0 (diff)
downloadgentoo-d814040f8983438f025629eeae90ce13a78dd0c1.tar.gz
gentoo-d814040f8983438f025629eeae90ce13a78dd0c1.tar.bz2
gentoo-d814040f8983438f025629eeae90ce13a78dd0c1.zip
dev-python/aioresponses: Bump to 0.7.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aioresponses/Manifest1
-rw-r--r--dev-python/aioresponses/aioresponses-0.7.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/aioresponses/Manifest b/dev-python/aioresponses/Manifest
index f2ca88e292df..2987e5f86499 100644
--- a/dev-python/aioresponses/Manifest
+++ b/dev-python/aioresponses/Manifest
@@ -1,2 +1,3 @@
DIST aioresponses-0.7.4.tar.gz 35248 BLAKE2B e3046de1db4911429ff2bb50b011c7cdb33ad8460771bbe7cce969e29a74f29e5fe86b1ed488cbd9462706ce31e84a3bef08aec0e83ac6175c803d2e81900fbc SHA512 00392f8481e600e2c18563193aaf5b75a324ea49e90606e43a28ea787f75c55712bc2caff0a70411f51a9615b01a252fca1ebb9efd2cc314f6358eeeef6d1e59
DIST aioresponses-0.7.5.tar.gz 35676 BLAKE2B 4d42137f67e27b0a91d3452630a7353db453c970a5689ab5f98aecfdf0877217b174d807f260c3d9736ceaadbab5fe84b7a025fc6233410029aeb5e5785925a1 SHA512 bae24aced48702f7971ba2ebb9268bbabf820270f321a87e840aa33421bdcf339d3c5375cc6df587889462f5d77276f8b1fd8e1f97da7f5d215247c0a58c85bb
+DIST aioresponses-0.7.6.tar.gz 35846 BLAKE2B f5cb820ee410e1203526ac6731c73f02993684679d788c8e3db830189d9874991b6fabf2e0738d14d3e54e2fa2b44af788f054137590ffea78df49056389673b SHA512 d02fa848a5d6588e32c203591f842cb212aae60d5e060a3fa13993bbb575922e516f04d47f9428c5f4b8103bc9990aa45cdde3c17bd2c47d8eff714f93976450
diff --git a/dev-python/aioresponses/aioresponses-0.7.6.ebuild b/dev-python/aioresponses/aioresponses-0.7.6.ebuild
new file mode 100644
index 000000000000..67587e7c3e2e
--- /dev/null
+++ b/dev-python/aioresponses/aioresponses-0.7.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Helper to mock/fake web requests in Python's aiohttp package"
+HOMEPAGE="
+ https://github.com/pnuckowski/aioresponses/
+ https://pypi.org/project/aioresponses/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These tests require Internet access
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_address_as_instance_of_url_combined_with_pass_through
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_pass_through_with_origin_params
+)