summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-28 04:12:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-28 04:24:43 +0100
commitd0b30f1a1d841b2b5d4261fdbda0eef86bfe8717 (patch)
treec88355db09b5552ffbdb81f8899da8d158f06246
parentdev-python/moto: Bump to 5.0.0 (diff)
downloadgentoo-d0b30f1a1d841b2b5d4261fdbda0eef86bfe8717.tar.gz
gentoo-d0b30f1a1d841b2b5d4261fdbda0eef86bfe8717.tar.bz2
gentoo-d0b30f1a1d841b2b5d4261fdbda0eef86bfe8717.zip
dev-python/apprise: Bump to 1.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.7.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index d9c7d847980e..8092fcc836aa 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,2 +1,3 @@
DIST apprise-1.6.0.tar.gz 1582966 BLAKE2B aec28c82a2e1b45341f1e67a0778be2a9149ff591172122abb7d30eeed27c7b49171556993c0f1c0d33fe12a5dcdeb4ad0ade8b9e68a8f9950a3f8b6f0638156 SHA512 572d0cb9e3464ea2bc65a101e520dd0b15ada08c158a21d1ac698adbcd454ecf5af7ad30dca6495b4d7e38b92128774c43864c011f1af26ad917699e1d50c59b
DIST apprise-1.7.1.tar.gz 1633347 BLAKE2B 4b51ffc45b61b4ff46cb3c0bd80c2f14a11d827ca350fe18fc6350934e3b93c09a98d03fd609d051311e46181778d433ae5813cb269623fed83ce47a7203eab3 SHA512 317e9fa057c7db28f73ea0888f378b036413a5a3186172206c3af57083a8d1965db178c89acfb2048bd82e5f530f65c05bfde3bb9c8aea7c9dd2f78e13e0a8b7
+DIST apprise-1.7.2.tar.gz 1638384 BLAKE2B 8fecb4d08e7e7c3aad24c1f8ac7aaec382aa934d46d5ab7cfd196949c9b7aa9ab2242a7626bddd336932ec12f17cdd966fde293f544e695468cfd810f5e6f5ba SHA512 897d4d253fcc2cfbb3fe2f1d0e9ecbe3a2a1bca65cb2c7d9595410e9c12adc6f5696216365fe583ebc457042db2d7e8a3c6153272865fc996e87342480536a0d
diff --git a/dev-python/apprise/apprise-1.7.2.ebuild b/dev-python/apprise/apprise-1.7.2.ebuild
new file mode 100644
index 000000000000..d13a9429e726
--- /dev/null
+++ b/dev-python/apprise/apprise-1.7.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest