summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-01-16 09:56:53 -0500
committerBrian Evans <grknight@gentoo.org>2019-01-16 09:56:53 -0500
commitca18a3ab3298533a4d2b035018f738f8cb4df5ad (patch)
tree92ea877fe24581838e995f622e9a3f11193346bf
parentsys-devel/clang-runtime: Add a live ebuild for 8.* branch (diff)
downloadgentoo-ca18a3ab3298533a4d2b035018f738f8cb4df5ad.tar.gz
gentoo-ca18a3ab3298533a4d2b035018f738f8cb4df5ad.tar.bz2
gentoo-ca18a3ab3298533a4d2b035018f738f8cb4df5ad.zip
dev-php/PEAR-Archive_Tar: Version bump for 1.4.5
Bug: https://bugs.gentoo.org/675576 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/PEAR-Archive_Tar/Manifest1
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/Manifest b/dev-php/PEAR-Archive_Tar/Manifest
index c8d3a0598439..706c905795ed 100644
--- a/dev-php/PEAR-Archive_Tar/Manifest
+++ b/dev-php/PEAR-Archive_Tar/Manifest
@@ -1 +1,2 @@
DIST Archive_Tar-1.4.3.tgz 20682 BLAKE2B a2e840087178fb55719634198852d191aef24139f819e3c478883fd007f6e72f523700617c7ff2c3d92a3ebe36a237b0eb7544dfe86dec394587ee0b3743520f SHA512 62e60d59266c5d19b131f769f4d71d4cee6bf8964b0c6610c4f1381500ced582865bff26c608479b2678dda1e7407ba39a7ec84b31fed13e3875f1947ce5bd6c
+DIST Archive_Tar-1.4.5.tgz 20919 BLAKE2B 506b2fae8f99634cf40ecff9c5ec695c101f4e14ae867795851a7e238a62c2611581aaab1cc0e9a9354184b20ba141f29ae3998881e7ebf777c596e5dc251577 SHA512 7a7e16e37b0c7112a77333ed2c4d0a0ae57cc1e971191c79b1858227b46f967aee915757a81bdfef3a9487a53b81a99bfbe84f78a346671fe44ac9f1f203a358
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.5.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.5.ebuild
new file mode 100644
index 000000000000..dd94437d9083
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Archive
+
+ dodoc docs/*
+}