summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-06 04:33:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-06 04:40:56 +0200
commitc2c3e0960feb3da7095350cf19a165512264deb3 (patch)
tree63116fbdaad9f9382ff4d5968842f6240822146e
parentdev-python/translate-toolkit: Bump to 3.10.1 (diff)
downloadgentoo-c2c3e0960feb3da7095350cf19a165512264deb3.tar.gz
gentoo-c2c3e0960feb3da7095350cf19a165512264deb3.tar.bz2
gentoo-c2c3e0960feb3da7095350cf19a165512264deb3.zip
dev-python/meson-python: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/meson-python-0.14.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 120dbde79529..d8a34123b38f 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1 +1,2 @@
DIST meson-python-0.13.2.gh.tar.gz 69575 BLAKE2B ddcab5530e7c235057752f1c355052120863167fc601b669e3add713079400cf95617be84989e06542125850559124d70a693a618cbec456c0e59e3f80d14c5f SHA512 b5518c5e9ccbec40747f2c08a83134f012557e0d9612b99999473d2ae7fdfdeae5b7552dc16cebb493133c3ed8c52153b3e3afd3cef32d0f3a65771ebbb5b3bb
+DIST meson-python-0.14.0.gh.tar.gz 72523 BLAKE2B d0fd66dee8a5efd73e617033aec3f14eb66affe72cd84c30a740820f5a0c34a4ae4ffd31e1df26312513b312940f62af436b9870216ee93d7543b4f02dec6637 SHA512 f40963a9c2bca8edf0f5651f9f4f1fab8df89cca715dd8dc0dec11ac53a591ee19d2d06edead917f15382410a51a37cd4efcee2c52696eb10a546b080bac2ad8
diff --git a/dev-python/meson-python/meson-python-0.14.0.ebuild b/dev-python/meson-python/meson-python-0.14.0.ebuild
new file mode 100644
index 000000000000..0ff76a5dc1a6
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.14.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.7.1[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ !kernel_Darwin? ( dev-util/patchelf )
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/cython-0.29.34[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ # requires git repo
+ # https://github.com/mesonbuild/meson-python/issues/397
+ tests/test_project.py::test_user_args
+ )
+ unset NINJA
+
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken venv usage that copies pypy3 executable, making it
+ # unable to find lib_pypy
+ tests/test_editable.py::test_editable_install
+ tests/test_editable.py::test_editble_reentrant
+ tests/test_examples.py::test_spam
+ tests/test_wheel.py::test_local_lib
+ )
+ fi
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}