summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:54:39 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-10 11:18:24 +0300
commitc039d2c859950b17b66b02a328047f7869d3dd28 (patch)
tree2b0423b834415b35ecb4db07d2740e33b56e7be2
parentdev-python/python-nbxmpp: add 3.2.4 (diff)
downloadgentoo-c039d2c859950b17b66b02a328047f7869d3dd28.tar.gz
gentoo-c039d2c859950b17b66b02a328047f7869d3dd28.tar.bz2
gentoo-c039d2c859950b17b66b02a328047f7869d3dd28.zip
dev-python/executing: add 1.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-1.1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 46624c250e00..59a6da2d2930 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,3 +1,4 @@
DIST executing-0.10.0.gh.tar.gz 507523 BLAKE2B 5ab17adb1d40b83b0cf294aba350faf124a810b4c95e408e9bd2ba80d918154cb41d8b4d4748cd7d897d47e085883a30f431dedd595b00506beb5038e084f473 SHA512 f1ee25679cd1f88f273ee68e8e926a6e98b749a50d063ea3aa73f35ac0d7ea65b13364269f01265f164dba1d775a742cd7cf3594558e06efb39fb1157b3b9f5c
DIST executing-1.0.0.gh.tar.gz 507720 BLAKE2B 601ddbd4c7dacd6b72317e9f07d8b8566d14b1c805bb7a2768449d51bf75818945f3b61b67dd0402d1d6171bd74165107ef98e835910529d82b8858bd016ac6d SHA512 912cea61ddb2ef12034432d68fa7239daad3c6365dbcbed72f08121b9fdc07e614b5c2233c53f5f7ee3472fca4f690af3db0944a0ed2c83623de8d682cff0a61
DIST executing-1.1.0.gh.tar.gz 782214 BLAKE2B 56c97b1c0b6617db90a90f562409b406d0838e187fed4e45642506df85ae5e54824a393eb38982902bdb1c67fda2299bac282a5b260f3537cd06145b1c5b992e SHA512 090705c90051fdbf53310293fbb2e06bd2c2144cf83d3d02528768303c70871bd8b3a3d236705e29f8a9fc3132ca94bcb3375fe8834529a684b10b7c879faff0
+DIST executing-1.1.1.gh.tar.gz 661228 BLAKE2B 66ba8509a82d7c7354d70747d08e160423314718a2c1844260104eff474d39a244f880984e2388997f5620905a2f3fd90fcfa393f48e98cd5990e01a053012d6 SHA512 2b2277aa68d1abf2f1bbbf9010f7a27652f74e892e564a3c6269ea1110208b4c2fbf6a002b90423f5e9aa718cf698f996d21930b431241cf88012f20d244eeae
diff --git a/dev-python/executing/executing-1.1.1.ebuild b/dev-python/executing/executing-1.1.1.ebuild
new file mode 100644
index 000000000000..26b7519766f7
--- /dev/null
+++ b/dev-python/executing/executing-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/
+"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}