summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-01-13 08:32:03 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-01-13 08:32:03 +0000
commitb63f57a75735287f19dd98ff2fd66c64bebb94b3 (patch)
tree34d9dfd9f25c6498b2b1a32b1be1b709fbbdf6ac
parent2023-01-13 08:17:08 UTC (diff)
parentsys-apps/ed: add 1.19, drop 1.19_rc1 (diff)
downloadgentoo-b63f57a75735287f19dd98ff2fd66c64bebb94b3.tar.gz
gentoo-b63f57a75735287f19dd98ff2fd66c64bebb94b3.tar.bz2
gentoo-b63f57a75735287f19dd98ff2fd66c64bebb94b3.zip
Merge updates from master
-rw-r--r--dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch2
-rw-r--r--dev-lang/swig/files/swig-4.1.1-ccache-configure-clang16.patch32
-rw-r--r--dev-lang/swig/swig-4.1.1-r1.ebuild60
-rw-r--r--dev-ruby/html2haml/Manifest1
-rw-r--r--dev-ruby/html2haml/html2haml-2.3.0.ebuild35
-rw-r--r--dev-ruby/io-event/Manifest1
-rw-r--r--dev-ruby/io-event/io-event-1.1.6.ebuild34
-rw-r--r--dev-ruby/mail/Manifest1
-rw-r--r--dev-ruby/mail/mail-2.8.0.1.ebuild39
-rw-r--r--dev-ruby/nokogiri/Manifest1
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.14.0.ebuild95
-rw-r--r--dev-ruby/oauth/Manifest1
-rw-r--r--dev-ruby/oauth/oauth-0.5.14.ebuild46
-rw-r--r--net-firewall/xtables-addons/xtables-addons-3.21.ebuild4
-rw-r--r--net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch24
-rw-r--r--net-mail/notmuch/notmuch-0.37-r1.ebuild303
-rw-r--r--sys-apps/ed/Manifest4
-rw-r--r--sys-apps/ed/ed-1.19.ebuild (renamed from sys-apps/ed/ed-1.19_rc1.ebuild)2
18 files changed, 680 insertions, 5 deletions
diff --git a/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch b/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch
index 5f5bb58db13e..e1a1235e8ae3 100644
--- a/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch
+++ b/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch
@@ -1,3 +1,5 @@
+https://sourceforge.net/p/byaccj/patches/5/
+
main.c: In function ‘done’:
main.c:88:43: error: implicit declaration of function -Werror=implicit-function-declaration
88 | if (action_file) { fclose(action_file); unlink(action_file_name); }
diff --git a/dev-lang/swig/files/swig-4.1.1-ccache-configure-clang16.patch b/dev-lang/swig/files/swig-4.1.1-ccache-configure-clang16.patch
new file mode 100644
index 000000000000..b2fefd1356fb
--- /dev/null
+++ b/dev-lang/swig/files/swig-4.1.1-ccache-configure-clang16.patch
@@ -0,0 +1,32 @@
+https://github.com/swig/swig/pull/2483
+
+From 784dfc917e99429bdbb70fb9dd80c16dfeb73659 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 12 Jan 2023 17:49:40 +0100
+Subject: [PATCH] CCache: Do not rely on C89-only features in configure.ac
+
+Add missing #include directives to obtain additional function
+prototypes. This avoids altering the result of this test with C99
+compilers which do not support implicit function declarations.
+--- a/CCache/configure.ac
++++ b/CCache/configure.ac
+@@ -63,6 +63,9 @@ AC_CACHE_CHECK([for C99 vsnprintf],ccache_cv_HAVE_C99_VSNPRINTF,[
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
+ #include <sys/types.h>
+ #include <stdarg.h>
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ void foo(const char *format, ...) {
+ va_list ap;
+ int len;
+@@ -77,7 +80,7 @@ void foo(const char *format, ...) {
+
+ exit(0);
+ }
+-main() { foo("hello"); }
++int main(void) { foo("hello"); }
+ ]])],[ccache_cv_HAVE_C99_VSNPRINTF=yes],[ccache_cv_HAVE_C99_VSNPRINTF=no],[ccache_cv_HAVE_C99_VSNPRINTF=cross])])
+ if test x"$ccache_cv_HAVE_C99_VSNPRINTF" = x"yes"; then
+ AC_DEFINE(HAVE_C99_VSNPRINTF, 1, [ ])
+
diff --git a/dev-lang/swig/swig-4.1.1-r1.ebuild b/dev-lang/swig/swig-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..f7080e5356c5
--- /dev/null
+++ b/dev-lang/swig/swig-4.1.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Simplified Wrapper and Interface Generator"
+HOMEPAGE="http://www.swig.org/ https://github.com/swig/swig"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ BSD BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ccache doc pcre test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre2 )
+ ccache? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/boost )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ANNOUNCE CHANGES CHANGES.current README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.1-ccache-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Only needed for Clang 16 patch
+ AT_M4DIR="Tools/config" eautoreconf
+}
+
+src_configure() {
+ econf \
+ PKGCONFIG="$(tc-getPKG_CONFIG)" \
+ $(use_enable ccache) \
+ $(use_with pcre)
+}
+
+src_test() {
+ # The tests won't get run w/o an explicit call, broken Makefiles?
+ emake check
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto html
+ dodoc -r Doc/{Devel,Manual}
+ fi
+}
diff --git a/dev-ruby/html2haml/Manifest b/dev-ruby/html2haml/Manifest
index 3a29cdfdf90b..ecc5f1af276d 100644
--- a/dev-ruby/html2haml/Manifest
+++ b/dev-ruby/html2haml/Manifest
@@ -1 +1,2 @@
DIST html2haml-2.2.0.gem 21504 BLAKE2B ead2c636baacb8dbba7bd650356da5e2ebfa8ab565edb38ab03df287d8d0709b9271ef3f46fae0f2d2b86d37dbf6a0212fbf6803aaf7757a9f2653b773e46482 SHA512 b6988182073f35d4d9b9f07f2cc2ba01c66679fa646fd2d1e3c8cf0643c88b04a2b1a36d584bdcca897f804e32486a618abc8fbd8db023ff9c22ee66d93ed9f0
+DIST html2haml-2.3.0.gem 21504 BLAKE2B 52bfdab16a78c44f7f3f5e4be6015f236fe53b15c9fe6e595223e76fdef544f06cb4abc8b3a2c3fd904c20a404e5bb10c44546494a93ff10690bd5a023afe555 SHA512 75b3453fe919c8914d53cb5492df2377756d89fa795d5ea29a64559e7f3e4ee91e61db706e7860e214a7e6d5160e0f209c65d68d8d3ac28ec5b51fefba6a9a94
diff --git a/dev-ruby/html2haml/html2haml-2.3.0.ebuild b/dev-ruby/html2haml/html2haml-2.3.0.ebuild
new file mode 100644
index 000000000000..0817065ce65c
--- /dev/null
+++ b/dev-ruby/html2haml/html2haml-2.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.markdown"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Convert HTML and HTML+Erb to Haml"
+HOMEPAGE="https://github.com/haml/html2haml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.6.0
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/ruby_parser-3.5
+ >=dev-ruby/haml-4.0"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/html2haml_test.rb || die
+ ${RUBY} -Ilib:test test/erb_test.rb || die
+}
diff --git a/dev-ruby/io-event/Manifest b/dev-ruby/io-event/Manifest
index d66a37177fce..d615db96544f 100644
--- a/dev-ruby/io-event/Manifest
+++ b/dev-ruby/io-event/Manifest
@@ -1,3 +1,4 @@
DIST io-event-1.1.2.tar.gz 34305 BLAKE2B 8e7814ada38c4a766f413373e0ef5b0c94a1b94342667a25c59bf8925fed791c3dc527bf63f02a9e40297abcdde730047a3a80104ac9d9f12ea648e5842ea851 SHA512 68a9c01f8075117767cdcacb095f9587118f86cc536d94a990b55e63e7f5213c350556486c45e2687db2ac810d48dc1d9aa28e994ef6ae0229f7b258d0b92aa2
DIST io-event-1.1.3.tar.gz 34336 BLAKE2B bf0143c73e8d3f2929d3d86a740bb4c846558e3e605414087a5bb16b6e8d1c0b35494b9c761de8d57004b4b540b72d16916ec602a04f204f32fa5ba074a465a3 SHA512 9da7405e6d0d0b7aed30718bd52c15bd05061f73c4a1ed481bbfa037a11d75a034876e7470ad29523e8e16c5a3b69eaf8716d81b8e840fb01c6248ecab633495
DIST io-event-1.1.4.tar.gz 34425 BLAKE2B 80af7c6234e44197c79c2b893aae02a05399c28a02daca900526e25bf3d0703d085b94dc231cf485028e8ce529b54a5a85b5adb6a720be87222be8d84302354a SHA512 8c8ae307879511099cbd5ceec775d408a5de28887e466a1fc62f4c1551c8e757875fcc7f12646c8d73f0fd9018a28cb8d6d0da1e4e6f0a0238812fe2674d1520
+DIST io-event-1.1.6.tar.gz 34530 BLAKE2B 3b0e6e5ca781b61467daeb885ea22de639c2f3c68f96657c99e8257f0cb0028f8997e6aa0ab5c53b56e53a944c40944e701d57160faeb4273a5bc77ceb4c2dfc SHA512 65cc9a9de7037059a119f1ca6569414baacab234ac4e6ee91ac5c780ed789510d8691111890dbe19082867c5adbd50cc9a86e28b37460b8fb01ff53abde8d417
diff --git a/dev-ruby/io-event/io-event-1.1.6.ebuild b/dev-ruby/io-event/io-event-1.1.6.ebuild
new file mode 100644
index 000000000000..1a7f76b6f182
--- /dev/null
+++ b/dev-ruby/io-event/io-event-1.1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An event loop"
+HOMEPAGE="https://github.com/socketry/io-event"
+SRC_URI="https://github.com/socketry/io-event/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/sus-0.6:0 )"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on unpackaged covered package
+ rm -f config/sus.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S sus-parallel || die
+}
diff --git a/dev-ruby/mail/Manifest b/dev-ruby/mail/Manifest
index 6b88534462a9..1caa5bd5c175 100644
--- a/dev-ruby/mail/Manifest
+++ b/dev-ruby/mail/Manifest
@@ -1,2 +1,3 @@
DIST mail-2.7.1-git.tar.gz 625251 BLAKE2B c1efbb259042155e983c1971fe9821eb0dd850089bd04cb0c74513f6f17dabf8ecc3155d9e5846ae657383f522872323f8fba37d51fba4318ac682d18a6d4c50 SHA512 17c601c86715135331f750048339a11a67a17f34486dbafa3ba7e9af9970d60927a2fa95c72a398418548df1fdf5addb2ed3afe9da7dff1f0bd949438726be1b
DIST mail-2.8.0-git.tar.gz 620136 BLAKE2B 4c115ddf92ef18c7889d391d264bf4c0be37be4849accf6e4778cc50317a4c0cd5f042c465f4f7862ca33e1de166b35bcb6d6e08e3fe44cce6aecbf1c1f9380e SHA512 ac60d72d16dd75fb5e8474900e069d5f711ce66340582a96d1f79ba582841cb82b212637053f45d1014997776ff411cbc8f9c19e06f024f6aa59b09c50c02583
+DIST mail-2.8.0.1-git.tar.gz 620162 BLAKE2B 92a183df4cec63c194debb5fd1c5194f2fe8d909094f9b79c157c3c004574c78e8b2567c44a7f62f3a91af4689e7e2ca023768f005ff62998d0999a0d46e4bf3 SHA512 d2c84ffec336bb1967107641b741eef06238e37d68704024d3f037893e95fcf9501ffdb34f3f820e1f8df63b4057e0d329d09cd6a96281801ece6fb3d26f1a4d
diff --git a/dev-ruby/mail/mail-2.8.0.1.ebuild b/dev-ruby/mail/mail-2.8.0.1.ebuild
new file mode 100644
index 000000000000..0dce16387ebe
--- /dev/null
+++ b/dev-ruby/mail/mail-2.8.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
+
+inherit ruby-fakegem
+
+GITHUB_USER="mikel"
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="https://github.com/mikel/mail"
+SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/mini_mime-0.1.1
+ dev-ruby/net-imap
+ dev-ruby/net-pop
+ dev-ruby/net-smtp
+"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
+
+ sed -i -e '/benchmark/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/nokogiri/Manifest b/dev-ruby/nokogiri/Manifest
index 02e3da7b91fb..3543c1716f59 100644
--- a/dev-ruby/nokogiri/Manifest
+++ b/dev-ruby/nokogiri/Manifest
@@ -1,2 +1,3 @@
DIST nokogiri-1.13.10-git.tgz 6236674 BLAKE2B 043a08ab969aac1f1fada730b8df11c295b28c9b9c41bd311cedc1d20064c61b2838489c67b8513c98736377defe33cd171b9ff3846f56af450caee4327e7727 SHA512 c9a4b14cb92c4920872048991c958036d5f09b8e231a6f6408e5d3c5df78b70e206cc12b8ed8aaae012e51f6f87adcbe46273cd1feca082ec17f42114f5a1172
DIST nokogiri-1.13.6-git.tgz 6249974 BLAKE2B db6a7fd70cd88fa784e70fd33102ad2a0d65a848a713bd93907d3c77b7ecc101a4f0a38febf3265b25967e045bf9091e46cf319702c08319e32f94d57a946985 SHA512 96f4e52332052bfae0d88d8c93cf334f8484b51290cafe8c1d43c820ba6ac5aa74b187c37e7177e62435d6101d859c16555b715fa88fcb06da742c84fd0e7486
+DIST nokogiri-1.14.0-git.tgz 10445399 BLAKE2B c8119709232979d86d017b7f97a5ceff8f756daa85a2b51dc4d0973419a01d7ef862aeab9bbdb4000ab4bda1335e09afc24049fa34a33bd69fd8b7297bf43474 SHA512 9da9c3bafc7a0d9dd0218855d67ca2d024024e3778e9f2784a0a018f5add7ba92ddcbb5568017617b0270091f738e9edadbaeaaa26112cf43b64bd46210567d2
diff --git a/dev-ruby/nokogiri/nokogiri-1.14.0.ebuild b/dev-ruby/nokogiri/nokogiri-1.14.0.ebuild
new file mode 100644
index 000000000000..c6bb2c38bb01
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.14.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md ROADMAP.md SECURITY.md"
+
+RUBY_FAKEGEM_GEMSPEC="nokogiri.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/nokogiri/extconf.rb)
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser"
+HOMEPAGE="https://www.nokogiri.org/"
+LICENSE="MIT"
+SRC_URI="https://github.com/sparklemotion/nokogiri/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ >=dev-libs/libxml2-2.10.3:=
+ >=dev-libs/libxslt-1.1.37
+ sys-libs/zlib
+ virtual/libiconv"
+DEPEND="${DEPEND}
+ >=dev-libs/libxml2-2.10.3
+ >=dev-libs/libxslt-1.1.37
+ >=sys-libs/zlib-1.2.13
+ virtual/libiconv"
+
+ruby_add_rdepend ">=dev-ruby/racc-1.4:0"
+
+ruby_add_bdepend "
+ dev-ruby/mini_portile2:2.8
+ >=dev-ruby/rexical-1.0.7
+ dev-ruby/rdoc
+ test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ -e '/license/ s:^:#:' \
+ Rakefile || die
+ # Remove the cross compilation options since they interfere with
+ # native building.
+ sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
+ sed -i -e '/cross_config_options/d' Rakefile || die
+
+ sed -e '/simplecov/,/^end/ s:^:#:' \
+ -e '/reporters/I s:^:#:' \
+ -i test/helper.rb || die
+
+ # There is no need for mini_portile2 to be a runtime dependency on Gentoo
+ sed -i -e '/mini_portile2/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ NOKOGIRI_USE_SYSTEM_LIBRARIES=true \
+ ${RUBY} -Cext/${PN} extconf.rb \
+ --with-zlib-include="${EPREFIX}"/usr/include \
+ --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
+ --with-iconv-include="${EPREFIX}"/usr/include \
+ --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
+ --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
+ --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
+ --with-xslt-dir="${EPREFIX}"/usr \
+ --with-iconvlib=iconv \
+ || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
+ fi
+
+ if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
+ fi
+
+ emake -Cext/${PN} \
+ V=1 \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each {|f| require f}' || die
+}
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
index 85f3d66865d4..9e0f781b453a 100644
--- a/dev-ruby/oauth/Manifest
+++ b/dev-ruby/oauth/Manifest
@@ -1,2 +1,3 @@
DIST oauth-0.5.10.tar.gz 67073 BLAKE2B 30d5823151412f53af41f28f7d5831bcfa7e7cf0b86d3a122b825fd086c00dab7fca7a4838b7ed5ebb269725af7c2a64cf771fc598bd6a97b9968e480ce78b4c SHA512 0ff5cd07052e210b1948496844166e1095b09d9c39592b6b11fa3aa4909fd8debec55237493d292dc60f4fe513ddf1a8f58cdb0215949241cf753d4e53aa107e
+DIST oauth-0.5.14.tar.gz 68764 BLAKE2B 19c7f463d5fcba62a609355834ba93adf1efa05b2ce25fc5d9d3623da15d35a7cb54eff9201bb4f373a66629781f5937326430a7a1c9c615929bcc5bae099a67 SHA512 646ed55a602e9e7b8e8d59532c89929305abeeda6b38fc38bdf1d5e400deec7f5884d988bcbb9e3537eb3a0921dacb73cb5238af27e9885aff95b67196f62c99
DIST oauth-0.5.8.tar.gz 67852 BLAKE2B 7dc19a2f84f585fd517d677bf441c5964b45566ffea3cbd7612061db115a5570cf8315b4cbdd8788f9b0ff336b6eea91922f17c0ce17a4c626731282bd8203ca SHA512 3bf8298ea5bcffe1fe61ba894a5cfcb04a5814348154749e056ea18d975b00b10db7ed226f2187ffb9f414b755022bf32ff4bb2c02f1f429f6a9a7062032d82e
diff --git a/dev-ruby/oauth/oauth-0.5.14.ebuild b/dev-ruby/oauth/oauth-0.5.14.ebuild
new file mode 100644
index 000000000000..2092a7815cc8
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.5.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP="oauth"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md TODO"
+
+RUBY_FAKEGEM_GEMSPEC="oauth.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
+HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
+SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-ruby-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:1.0
+ dev-ruby/webmock
+ dev-ruby/rack
+ dev-ruby/actionpack:6.1
+ dev-ruby/railties:6.1
+)"
+
+all_ruby_prepare() {
+ # Require a compatible version of mocha
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.1.0" ; gem "actionpack", "~>6.1.0"; require "action_dispatch"' \
+ -e '/mocha/ s/mini_test/minitest/' \
+ -e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+
+ # Avoid test tripped up by kwargs confusion
+ sed -i -e '/test_authorize/askip "kwargs confusion"' test/units/test_cli.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/*test*.rb"].each {|f| require f}' || die
+}
diff --git a/net-firewall/xtables-addons/xtables-addons-3.21.ebuild b/net-firewall/xtables-addons/xtables-addons-3.21.ebuild
index fa8dcbc44e15..36cb5cb044db 100644
--- a/net-firewall/xtables-addons/xtables-addons-3.21.ebuild
+++ b/net-firewall/xtables-addons/xtables-addons-3.21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ SRC_URI="https://inai.de/files/xtables-addons/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
MODULES="quota2 psd pknock lscan length2 ipv4options ipp2p iface gradm geoip fuzzy condition tarpit sysrq proto logmark ipmark echo dnetmap dhcpmac delude chaos account"
diff --git a/net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch b/net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch
new file mode 100644
index 000000000000..42c108337771
--- /dev/null
+++ b/net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/879739
+https://nmbug.notmuchmail.org/nmweb/show/20221202191908.848227-1-qsx%40chaotikum.eu
+
+Probe for strcasestr using the C++ compiler
+
+The C++ compiler may define _GNU_SOURCE, causing <string.h> to
+declare strcasestr, while the C compiler does not. As a result,
+the probe may fail, resulting in an incompatible declaration
+of strcasestr in compat/compat.h.
+
+Upstream discussion:
+
+ [PATCH] compat/strcasestr: Include correct header file
+ <https://nmbug.notmuchmail.org/nmweb/show/20221202191908.848227-1-qsx%40chaotikum.eu>
+
+--- a/compat/have_strcasestr.c
++++ b/compat/have_strcasestr.c
+@@ -1,4 +1,5 @@
+ #define _GNU_SOURCE
++#include <string.h>
+ #include <strings.h>
+
+ int
+
diff --git a/net-mail/notmuch/notmuch-0.37-r1.ebuild b/net-mail/notmuch/notmuch-0.37-r1.ebuild
new file mode 100644
index 000000000000..e28a9d0aa38e
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.37-r1.ebuild
@@ -0,0 +1,303 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_OPTIONAL=1
+NEED_EMACS="24.1"
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit bash-completion-r1 desktop distutils-r1 elisp-common flag-o-matic pax-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="https://notmuchmail.org/releases/${P}.tar.xz
+ test? ( https://notmuchmail.org/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+REQUIRED_USE="
+ apidoc? ( doc )
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+"
+IUSE="apidoc crypt doc emacs mutt nmbug python test valgrind"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/xz-utils[extra-filters(-)]
+ virtual/pkgconfig
+ apidoc? (
+ app-doc/doxygen
+ dev-lang/perl
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ sys-apps/texinfo
+ )
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ )
+ test? (
+ app-shells/bash
+ sys-process/parallel
+ )
+"
+
+COMMON_DEPEND="
+ dev-libs/glib
+ dev-libs/gmime:3.0[crypt]
+ >=dev-libs/xapian-1.4.0:=
+ sys-libs/talloc
+ sys-libs/zlib:=
+ emacs? ( >=app-editors/emacs-${NEED_EMACS}:* )
+ python? (
+ ${PYTHON_DEPS}
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="${COMMON_DEPEND}
+ test? (
+ >=app-editors/emacs-${NEED_EMACS}:*[libxml2]
+ app-misc/dtach
+ sys-devel/gdb[python]
+ crypt? (
+ app-crypt/gnupg
+ dev-libs/openssl
+ )
+ )
+ valgrind? ( dev-util/valgrind )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/gnupg )
+ mutt? (
+ dev-perl/File-Which
+ dev-perl/Mail-Box
+ dev-perl/MailTools
+ dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ dev-perl/Pod-Parser
+ )
+ nmbug? ( dev-vcs/git )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.37-configure-clang16.patch
+)
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_unpack() {
+ unpack "${P}".tar.xz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ use python && distutils-r1_src_prepare
+
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # Override 'install' target, we want to install manpages with doman, but let it install texinfo files.
+ sed -i "s/all install-man install-info/all $(usex doc install-info '')/" "Makefile.local" || die
+
+ use test && append-flags '-g'
+
+ # Non-autoconf configure
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags '-lnsl' '-lsocket'
+
+ # sphinx-4 broke everything. https://bugs.gentoo.org/789492
+ echo 'man_make_section_directory = False' >> doc/conf.py || die
+}
+
+src_configure() {
+ python_setup # For sphinx
+
+ tc-export CC CXX
+
+ local myconf=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with apidoc api-docs)
+ $(use_with doc docs)
+ $(use_with emacs)
+ )
+
+ # FIXME:
+ # Checking for GMime session key extraction support... * ACCESS DENIED: open_wr: /dev/bus/usb/001/011
+ # notmuch configure compiles a program _check_session_keys.c, inline in ./configure script
+ # gmime/gpg/scdaemon tries to open usb devices in GMime test
+ # we pretend to allow it, without actually allowing it to read or write.
+ # https://bugs.gentoo.org/821328
+ addpredict /dev/bus/usb
+
+ econf "${myconf[@]}"
+}
+
+python_compile() {
+ pushd bindings/python-cffi > /dev/null || die
+ distutils-r1_python_compile
+ # copy stuff just in case
+ if use test; then
+ mkdir -p build/stage/tests || die
+ cp -v tests/*.py build/stage/tests || die
+ fi
+ popd > /dev/null || die
+
+ # TODO: we want to drop those, research revdeps
+ pushd bindings/python > /dev/null || die
+ distutils-r1_python_compile
+ popd > /dev/null || die
+}
+
+python_compile_all() {
+ use doc && emake -C bindings/python/docs html
+}
+
+src_compile() {
+ python_setup # For sphinx
+
+ # prevent race in emacs doc generation
+ # FileNotFoundError: [Errno 2] No such file or directory: '..work/notmuch-0.31/emacs/notmuch.rsti'
+ if use emacs; then
+ use doc && emake -j1 -C emacs docstring.stamp V=1 #nowarn
+ fi
+
+ emake V=1
+
+ use python && distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt > /dev/null || die
+ emake notmuch-mutt.1
+ popd > /dev/null || die
+ fi
+}
+
+python_test() {
+ # we only have tests for cffi bindings
+ pushd bindings/python-cffi > /dev/null || die
+ rm -f tox.ini || die
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+src_test() {
+ local test_failures=()
+ pax-mark -m notmuch
+
+ # we run pytest via eclass phasefunc, so delete upstream launcher
+ use python && { rm -v test/T391-python-cffi.sh || die ; }
+
+ LD_LIBRARY_PATH="${S}/lib" \
+ nonfatal emake test V=1 OPTIONS="--verbose --tee" || test_failures+=( "'emake tests'" )
+ pax-mark -ze notmuch
+
+ # both lib and bin needed for testsuite.
+ if use python; then
+ LD_LIBRARY_PATH="${S}/lib" \
+ PATH="${S}:${PATH}" \
+ nonfatal distutils-r1_src_test || test_failures+=( "'python tests'" )
+ fi
+
+ [[ ${test_failures} ]] && die "Tests failed: ${test_failures[@]}"
+}
+
+python_install() {
+ pushd bindings/python-cffi > /dev/null || die
+ distutils-r1_python_install
+ popd > /dev/null || die
+
+ pushd bindings/python > /dev/null || die
+ distutils-r1_python_install
+ popd > /dev/null || die
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ if use apidoc; then
+ # rename overly generic manpage to avoid clashes
+ mv doc/_build/man/man3/deprecated.3 \
+ doc/_build/man/man3/notmuch-deprecated.3 || die
+ fi
+ doman doc/_build/man/man?/*.?
+ fi
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ domenu emacs/notmuch-emacs-mua.desktop
+ fi
+
+ if use nmbug; then
+ # TODO: those guys need proper deps
+ python_fix_shebang devel/nmbug/notmuch-report
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt > /dev/null || die
+ dobin notmuch-mutt
+ # this manpage is built by pod2man
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd > /dev/null || die
+ fi
+
+ local DOCS=( README{,.rst} INSTALL NEWS )
+ einstalldocs
+
+ if use python; then
+ use doc && local HTML_DOCS=( bindings/python/docs/html/. )
+ distutils-r1_src_install
+ fi
+}
+
+pkg_preinst() {
+ local _rcfile="/etc/mutt/notmuch-mutt.rc"
+ if use mutt && ! [[ -e "${EROOT}"${_rcfile} ]]; then
+ elog "To enable notmuch support in mutt, add the following line"
+ elog "to your mutt config file:"
+ elog ""
+ elog " source ${_rcfile}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use emacs; then
+ elisp-site-regen
+ xdg_desktop_database_update
+ fi
+}
diff --git a/sys-apps/ed/Manifest b/sys-apps/ed/Manifest
index 680ecad7ab17..f558c6c5f2b3 100644
--- a/sys-apps/ed/Manifest
+++ b/sys-apps/ed/Manifest
@@ -1,4 +1,4 @@
DIST ed-1.18.tar.lz 66019 BLAKE2B 9f2b6f00e65dc8a13dd9eba4dfae5ad1e6e3c3ffe623c8b2cc2db78e221ba140595658fd710e4651165a2475a9ed673c9f230fab64f22a7a9488973b5e227198 SHA512 e5dac94697d63fb90cc17e3e653fa56309e9652cc25b2e98a0e21f1ed41e38c48bc33b5fc746275a59e702d1644d3af88f3d82598b482f7309f4e68aab783286
DIST ed-1.18.tar.lz.sig 72 BLAKE2B 9b498f1604d625c6b32ded636e0841ef384bf59c10ff00722e03dcd890c5c1d1ccc5d99545a6c132a9ccc61b9f8da8f70a94f514db4a417d8c52128be720481a SHA512 f3df77755ac2b47825102b7c6d1774c8aee3f93e0824cebb6d7ea6cda50c1233673ed4c56c4ed135438e993399685cf45616c1fbeb85b2a8501059abe818908d
-DIST ed-1.19-rc1.tar.lz 66524 BLAKE2B a1cca3e2f2e492a265b7b7b70aeb63094e2f8a3c7f2d81ff7a6fe93c5e0c54a9a5cf89b0139c82c0d1c8cd838353ca6b6b1403dd42a62b44540442a1914e7189 SHA512 07eb0800bce873a045ed8b275bbf5669d1e0fb271414bc75a9c167a22a826c5286918df8f806fa4130e851847e4097a6957a8f3783badca72c7e8f69f4b2f5c4
-DIST ed-1.19-rc1.tar.lz.sig 72 BLAKE2B f49dc11364d6c0c8eb0265c48104149d501da67e6b4d3ebe98d3456bb9a107b694672a1270129961488575a30f29858cb4fbdc0dfe65a10f8d6f414f3df49dad SHA512 3538e5ce797eca530fab783c3dfa99efe95f84225b0309febed55d042e40dd36555e4ec0ea7427efe939af990bca032d5b5e6c9fd988743a76f174b3d37d9d2f
+DIST ed-1.19.tar.lz 66448 BLAKE2B 139305a1d64e96f7eadcb462325918e5eee18de229ec8e1b3fac29dc9b8ef58ceea4cd7ffdbd3674fd7f421d90bc0c9e3557318eb57830d7cd46e579828fa95d SHA512 594d5cf895931783110ee1956078f6a77aee022fb67730cbc6f1d30521c120b97820a5eb349278575f85c4c1e17fea0e16a3bc22592edae53c6fd27941ee3d7e
+DIST ed-1.19.tar.lz.sig 72 BLAKE2B ada611148a6347d8953c65669b61f69eb0ed8d48f6dc4ffaab8975dd7e28f1d87e434493a77e817ca05874f741e243309529e60e95f2a7636148fa71c711f5e3 SHA512 03ff7cf2f337fdc94efaa1374ce95d37c29c556b2a9a13f7216e05e8e9e9efc95bcbb554bd05000b5283d5f20884f3f50b16f220fba8e6ff318b1b975c6a44c9
diff --git a/sys-apps/ed/ed-1.19_rc1.ebuild b/sys-apps/ed/ed-1.19.ebuild
index 15554d4d2cd3..65951958803d 100644
--- a/sys-apps/ed/ed-1.19_rc1.ebuild
+++ b/sys-apps/ed/ed-1.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8