summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-06-15 18:16:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-06-15 18:16:52 +0000
commitb31e728c67d5561e69319fae93ef78a7bc39af8b (patch)
tree467a0fd130eab9f2e438c454093e1b75e6653516
parent2023-06-15 17:03:47 UTC (diff)
parentsci-libs/transformers: 4.30.2 (diff)
downloadgentoo-b31e728c67d5561e69319fae93ef78a7bc39af8b.tar.gz
gentoo-b31e728c67d5561e69319fae93ef78a7bc39af8b.tar.bz2
gentoo-b31e728c67d5561e69319fae93ef78a7bc39af8b.zip
Merge updates from master
-rw-r--r--sci-libs/huggingface_hub/Manifest1
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild31
-rw-r--r--sci-libs/transformers/Manifest1
-rw-r--r--sci-libs/transformers/transformers-4.30.2.ebuild35
4 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/Manifest b/sci-libs/huggingface_hub/Manifest
index 1caa5dc407e5..a90258dbb40b 100644
--- a/sci-libs/huggingface_hub/Manifest
+++ b/sci-libs/huggingface_hub/Manifest
@@ -1,2 +1,3 @@
DIST huggingface_hub-0.13.4.gh.tar.gz 325227 BLAKE2B 56ad70072ddd7f9878de4db45fffeb200032d71ba36fa2dc0e81d50a079a5ffa9ad80b3a71773a5fe466ac4522db7061fc7974149092d212278b8159d30e212b SHA512 6c07c1dc1a0c327ca463b7f366c265dfc7e55ed69592df5ad10f6d77956ac1dfe3e1f827a2df200f943da2f34a96ba4de1c395944b542e3d7142d925f60ad274
DIST huggingface_hub-0.14.1.gh.tar.gz 359222 BLAKE2B 379cc49230f2e8f5f57d0dac5cfab60f9d0a7d04bab36af8ba0a77846fdf6eea412f9d473bd2f554a912a862747156fe29d36913691b6df8c3cf769389d86b3f SHA512 8d1e9c3e77a8ddb4a6b1827751fad95baad7504a1ad2cdf443f1cf64cff10e1cea9148f2076e0fd462c7f1ce860230e919059e61807260368727a6bd5e9efeb3
+DIST huggingface_hub-0.15.1.gh.tar.gz 1222091 BLAKE2B f9b452f7ffe54d6edfe87e288cd52ee2ec35450ffe052d59442859918b4e1baf93d2d807dc54799ea3346bf00f52ad75bbb9dab69f36771ba8bf8702d54bbe7e SHA512 70d3a47383aa6a0c3cc1b13f1bf3e69326c3432eca8e68ea08f991aa2c5a212f1e4fe262840129bb64dc9ccb3f958371ea7a38ff5246f14585783bafa3d81585
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild
new file mode 100644
index 000000000000..7c519b339f79
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/sci-libs/transformers/Manifest b/sci-libs/transformers/Manifest
index b563df71ecac..4456ae0bf472 100644
--- a/sci-libs/transformers/Manifest
+++ b/sci-libs/transformers/Manifest
@@ -1,2 +1,3 @@
DIST transformers-4.27.4.gh.tar.gz 13210647 BLAKE2B acf5c81ceaaa2f156fc90b2284a6e2d4369742705c14d777c12e94a23961f3ed7cdc8e3cf8a4b962600b59f529862e6546f3d212e1ae1c44b7f76d8a10cbea75 SHA512 8b84a74c473c514314c3c4a422f8c03118575add3499ca280b7259bad72f8f8a6a7a51dc12162963c033b6a65c8914cca011b7bf6343781c5ed35154ea7adaf4
DIST transformers-4.29.2.gh.tar.gz 13775570 BLAKE2B 01d64001e0ca8c06247f35391fe79edd59b3c02e1ec5fe0cac6ca3a4028633f6deba7f50762b2b688acc524658e25b8ecf4b6618ab6ff12d5737fd7c1864ada8 SHA512 2526f9d2de12e3f73899fb6ab5390884f9884a05ba492235bc95897f99bb45616ed737c87b9b8ac83550dd90b68025adf63a1f95c22a2e708528889215c8299c
+DIST transformers-4.30.2.gh.tar.gz 13946731 BLAKE2B 2831f413fb06e4210f59c8b56779a35ba5236ab8934bc955c5997bc45671ca12dbf9fff5997850056876027fa5d542550f8bc00ef86dbd3bc81f65ae0ce964a2 SHA512 dc5d325643a81c275470c15edf98f5863d3ecff3696a376dd369d4f4e9a70ec7d06f23ae8b47354373a8a2f9301543214888cf35b66c9931ac350ab7892ae4c1
diff --git a/sci-libs/transformers/transformers-4.30.2.ebuild b/sci-libs/transformers/transformers-4.30.2.ebuild
new file mode 100644
index 000000000000..944e547fdfbd
--- /dev/null
+++ b/sci-libs/transformers/transformers-4.30.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow"
+HOMEPAGE="
+ https://pypi.org/project/transformers/
+ https://huggingface.co/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Need some modules, not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ sci-libs/huggingface_hub[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sci-libs/tokenizers[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest