summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-28 17:25:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-28 17:27:15 +0200
commitaf771f43d2e029fffa7da5e42931e74b4a6ed8a2 (patch)
tree55abfd84d0743d7eb284e8bbf30069e0a35f68c1
parentapp-admin/cdist: Enable py3.12 (diff)
downloadgentoo-af771f43d2e029fffa7da5e42931e74b4a6ed8a2.tar.gz
gentoo-af771f43d2e029fffa7da5e42931e74b4a6ed8a2.tar.bz2
gentoo-af771f43d2e029fffa7da5e42931e74b4a6ed8a2.zip
app-admin/cdist: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/cdist/Manifest1
-rw-r--r--app-admin/cdist/cdist-6.9.8.ebuild29
-rw-r--r--app-admin/cdist/files/test.patch47
3 files changed, 0 insertions, 77 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index 7359503f6415..e7be92aa74f9 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1,2 +1 @@
-DIST cdist-6.9.8.tar.gz 1385902 BLAKE2B 6190f09d527a562e490669335d604d3173209bb950448855588a78d48428b8522c8f39327d6455d30242d97bb48d810c319f650a1c0c2fba203a348637dc87c1 SHA512 3c78dd5332a5957750948c52c4b27269ada21b07a2fce0d84019b4fcd3b7ddc6221f0179690d1b3af7e685ffafd739e604f50195fbc36a5494a102b2fa1b732b
DIST cdist-7.0.0.tar.gz 1395298 BLAKE2B 0dc11302b4a63e24f31d598df63dc5da784cb01d57ade9b67da277b7c27f66b4c31891ce710c3acdc100e92500b0e80e22cf01882b1669fa714d70c44879f7f0 SHA512 bd87b52603443bc9ffd81785a73bc07387e0555da34b04f97619beb39a1bfcf488b84a6a37fac4fe49b9b002080c5f20a50b3f08ac3665c6c2143a4aa4ee47b7
diff --git a/app-admin/cdist/cdist-6.9.8.ebuild b/app-admin/cdist/cdist-6.9.8.ebuild
deleted file mode 100644
index 4e75b661c296..000000000000
--- a/app-admin/cdist/cdist-6.9.8.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-DESCRIPTION="A usable configuration management system"
-HOMEPAGE="https://www.cdi.st/ https://code.ungleich.ch/ungleich-public/cdist"
-SRC_URI="https://code.ungleich.ch/ungleich-public/cdist/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=( "${FILESDIR}"/test.patch )
-
-distutils_enable_sphinx docs/src dev-python/sphinx-rtd-theme
-distutils_enable_tests unittest
-
-python_prepare_all() {
- echo "VERSION='${PV}'" > cdist/version.py || die "Failed to set version"
- distutils-r1_python_prepare_all
-}
diff --git a/app-admin/cdist/files/test.patch b/app-admin/cdist/files/test.patch
deleted file mode 100644
index ebc9d944ba57..000000000000
--- a/app-admin/cdist/files/test.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-https://code.ungleich.ch/ungleich-public/cdist/commit/3a321469a8ba5aea55220bd70bd4900de732e917
-https://bugs.gentoo.org/831362
-From 3a321469a8ba5aea55220bd70bd4900de732e917 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timoth=C3=A9e=20Floure?= <timothee.floure@posteo.net>
-Date: Tue, 16 Nov 2021 11:11:45 +0100
-Subject: [PATCH] Python 3.10: collections.X -> collections.abc.X
-
----
- cdist/integration.py | 2 +-
- cdist/util/fsproperty.py | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/cdist/integration.py b/cdist/integration.py
-index 17b65f09..04470ea7 100644
---- a/cdist/integration.py
-+++ b/cdist/integration.py
-@@ -84,7 +84,7 @@ def _process_hosts_simple(action, host, manifest, verbose,
- """
- if isinstance(host, str):
- hosts = [host, ]
-- elif isinstance(host, collections.Iterable):
-+ elif isinstance(host, collections.abc.Iterable):
- hosts = host
- else:
- raise cdist.Error('Invalid host argument: {}'.format(host))
-diff --git a/cdist/util/fsproperty.py b/cdist/util/fsproperty.py
-index 09e9cc19..6bf935e8 100644
---- a/cdist/util/fsproperty.py
-+++ b/cdist/util/fsproperty.py
-@@ -33,7 +33,7 @@ class AbsolutePathRequiredError(cdist.Error):
- return 'Absolute path required, got: {}'.format(self.path)
-
-
--class FileList(collections.MutableSequence):
-+class FileList(collections.abc.MutableSequence):
- """A list that stores it's state in a file.
-
- """
-@@ -102,7 +102,7 @@ class FileList(collections.MutableSequence):
- self.__write(lines)
-
-
--class DirectoryDict(collections.MutableMapping):
-+class DirectoryDict(collections.abc.MutableMapping):
- """A dict that stores it's items as files in a directory.
-
- """