summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-11-05 22:48:15 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-11-05 22:48:15 +0000
commitad71b98bb8561f3d023cded8211e388608bb859a (patch)
tree6f525750d898334a9579c4487c06edf36e187895
parent2016-11-05 22:22:18 UTC (diff)
parentdev-python/graph-tool: clean up old. (diff)
downloadgentoo-ad71b98bb8561f3d023cded8211e388608bb859a.tar.gz
gentoo-ad71b98bb8561f3d023cded8211e388608bb859a.tar.bz2
gentoo-ad71b98bb8561f3d023cded8211e388608bb859a.zip
Merge updates from master
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild7
-rw-r--r--app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch18
-rw-r--r--dev-python/graph-tool/Manifest1
-rw-r--r--dev-python/graph-tool/graph-tool-2.16.ebuild90
-rw-r--r--eclass/python-r1.eclass2
-rw-r--r--eclass/python-single-r1.eclass2
6 files changed, 26 insertions, 94 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
index d6693d283176..8a0011cbc409 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils flag-o-matic pax-utils toolchain-funcs
+inherit autotools eutils flag-o-matic pax-utils toolchain-funcs
P_FD="dosemu-freedos-1.0-bin"
COMMIT="15cfb41ff20a052769d753c3262c57ecb050ad71"
@@ -46,6 +46,9 @@ S="${WORKDIR}/${PN}-code-${COMMIT}"
src_prepare() {
epatch "${FILESDIR}"/${P}-fortify.patch
epatch "${FILESDIR}"/${PN}-1.4.1_pre20091009-dash.patch
+ epatch "${FILESDIR}"/${P}-no-glibc.patch
+
+ epatch_user
# Has problems with -O3 on some systems
replace-flags -O[3-9] -O2
@@ -53,6 +56,8 @@ src_prepare() {
# This one is from media-sound/fluid-soundfont (bug #479534)
sed "s,/usr/share/soundfonts/default.sf2,${EPREFIX}/usr/share/sounds/sf2/FluidR3_GM.sf2,"\
-i src/plugin/fluidsynth/mid_o_flus.c || die
+
+ eautoreconf
}
src_configure() {
diff --git a/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch b/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch
new file mode 100644
index 000000000000..7c5b8a50a094
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch
@@ -0,0 +1,18 @@
+The check has no AC_MGS_RESULT finish helper
+and gets called as
+ set ``
+on gcc-6 which clutters ./configure output.
+
+One of fallouts of https://bugs.gentoo.org/598798
+diff --git a/configure.ac b/configure.ac
+index 34a7f71..0f06f57 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -574,7 +574,2 @@ if test "$GCC" = "yes" ; then
+
+- AC_MSG_CHECKING(for glibc...)
+- set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2}'`
+- if test "$1" = "__GLIBC__"; then
+- AC_MSG_ERROR([Sorry, you need glibc.])
+- fi
+ fi
diff --git a/dev-python/graph-tool/Manifest b/dev-python/graph-tool/Manifest
index a2e253e0e879..97d3610f5169 100644
--- a/dev-python/graph-tool/Manifest
+++ b/dev-python/graph-tool/Manifest
@@ -1,2 +1 @@
-DIST graph-tool-2.16.tar.bz2 15116613 SHA256 3784d4a15b6b5d0e6dab5e3941d24c1e3fee509f7abf9008f64fef2760bd610d SHA512 336dddcd7a3faf56eff06a902f4cf5ac462bc4fd807566c473675eed665dba720e0b275b9233f73e657976e7ebdda75804eaa81ebf617dcde1beb299f45138e2 WHIRLPOOL 74b0ebc84c9a16b61182f296f93e366d09708fe0746c35a961173cfda259083ade97da2ecedbef4b9c19494aab621597c1f7863501d6a0e59c026aa197d39cb1
DIST graph-tool-2.2.44.tar.bz2 15044171 SHA256 42b97c24c155ddd95c79a16b4e3cb034cb3139e912c37aed66e6493e4ff20566 SHA512 312f3baf80a3c66d75f1ad458a2eb4b51300925beeac494e724e73589c06e93ce467a64da0cb26809b706cf69b398ab8ad1750d5e2b952f92b3bc00bd2e42467 WHIRLPOOL 79e04d4b4efb28bd99f45b64eb4297c408e35f1bdf78f6d756d52f44895cc9ae35f3c9c4450ca2a6f9232ebc0c4f57bc261495db7ec4ae2b542424a15777284d
diff --git a/dev-python/graph-tool/graph-tool-2.16.ebuild b/dev-python/graph-tool/graph-tool-2.16.ebuild
deleted file mode 100644
index cee02ef0ac9e..000000000000
--- a/dev-python/graph-tool/graph-tool-2.16.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit check-reqs toolchain-funcs python-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/count0/graph-tool.git"
- inherit autotools git-r3
-else
- SRC_URI="http://downloads.skewed.de/${PN}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
-HOMEPAGE="http://graph-tool.skewed.de/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+cairo openmp"
-
-# Bug #536734; configure sets boostlib 1.53.0 but 1.54.0 is required
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/boost-1.54.0[python,${PYTHON_USEDEP}]
- dev-libs/expat
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- >=sci-mathematics/cgal-3.5
- cairo? (
- dev-cpp/cairomm
- dev-python/pycairo[${PYTHON_USEDEP}]
- )
- dev-python/matplotlib[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-cpp/sparsehash
- virtual/pkgconfig"
-
-# most machines don't have enough ram for parallel builds
-MAKEOPTS="${MAKEOPTS} -j1"
-
-# bug 453544
-CHECKREQS_DISK_BUILD="6G"
-
-pkg_pretend() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
- check-reqs_pkg_pretend
-}
-
-src_prepare() {
- default
- [[ ${PV} == "9999" ]] && eautoreconf
- >py-compile
- python_copy_sources
-}
-
-src_configure() {
- local threads
- has_version dev-libs/boost[threads] && threads="-mt"
-
- configure() {
- econf \
- --disable-static \
- --disable-optimization \
- $(use_enable openmp) \
- $(use_enable cairo) \
- --with-boost-python="${EPYTHON: -3}${threads}"
- }
- python_foreach_impl run_in_build_dir configure
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- python_foreach_impl run_in_build_dir default
- prune_libtool_files --modules
-}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null
- "$@"
- popd > /dev/null
-}
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index 610657776d20..a117a5a82ff2 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -75,7 +75,7 @@ inherit multibuild python-utils-r1
#
# Example:
# @CODE
-# PYTHON_COMPAT=( python2_7 python3_3 python3_4} )
+# PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
# @CODE
#
# Please note that you can also use bash brace expansion if you like:
diff --git a/eclass/python-single-r1.eclass b/eclass/python-single-r1.eclass
index 9e80866bfb51..16102816f148 100644
--- a/eclass/python-single-r1.eclass
+++ b/eclass/python-single-r1.eclass
@@ -88,7 +88,7 @@ if [[ ! ${_PYTHON_SINGLE_R1} ]]; then
#
# Example:
# @CODE
-# PYTHON_COMPAT=( python2_7 python3_3 python3_4} )
+# PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
# @CODE
#
# Please note that you can also use bash brace expansion if you like: