summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-04-21 14:38:45 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-04-21 14:38:45 +0000
commita0985cc518d41d79ba927bbf92eeee747728fbe1 (patch)
treef9ddcfb3965a647fb36624bb42063b31184f2943
parent2022-04-21 14:23:55 UTC (diff)
parentdev-python/backports-entry_points_selectable: Bump to 1.1.1 (diff)
downloadgentoo-a0985cc518d41d79ba927bbf92eeee747728fbe1.tar.gz
gentoo-a0985cc518d41d79ba927bbf92eeee747728fbe1.tar.bz2
gentoo-a0985cc518d41d79ba927bbf92eeee747728fbe1.zip
Merge updates from master
-rw-r--r--dev-python/atpublic/Manifest1
-rw-r--r--dev-python/atpublic/atpublic-3.0.1.ebuild33
-rw-r--r--dev-python/backoff/Manifest1
-rw-r--r--dev-python/backoff/backoff-1.11.1.ebuild33
-rw-r--r--dev-python/backports-entry_points_selectable/Manifest1
-rw-r--r--dev-python/backports-entry_points_selectable/backports-entry_points_selectable-1.1.1.ebuild29
6 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/atpublic/Manifest b/dev-python/atpublic/Manifest
index bcc1aa4fd210..e8623fef8ca3 100644
--- a/dev-python/atpublic/Manifest
+++ b/dev-python/atpublic/Manifest
@@ -1 +1,2 @@
DIST atpublic-2.3.tar.gz 16746 BLAKE2B 60d12db8c56f3e3ce45c2e300759334b662369980b3dc36bff1edbac2d4a13dcf1bd390725eac488969d5a80e5ee5bb598c80e31ed3667c2e7d4f1f88fd00f7c SHA512 88c140c7ca0cfe3db791fd43a97f9fc63de979191a026df4d9f7a34a347b657d7d7b6fb7e31a231ac3adbc5e5d014b8e3c3606b93515a6ad42ea3d101b480329
+DIST atpublic-3.0.1.tar.gz 14131 BLAKE2B 3912c23c5ee575d7bdec1b598f1f360c54296211600115a413d97c73751b5301b2f3d22152aa62d4d7ac6da9a6cf4202a2deba1de374407ede4358620ee97391 SHA512 02c4af8aa02040bba2f09b852e17a0a90c0a6dce8fdabc8362a67c2f326b68369bf5f12f91291f9ff3395685530592561b132f09f9869867516592bd092e0e38
diff --git a/dev-python/atpublic/atpublic-3.0.1.ebuild b/dev-python/atpublic/atpublic-3.0.1.ebuild
new file mode 100644
index 000000000000..3985ada854dc
--- /dev/null
+++ b/dev-python/atpublic/atpublic-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A decorator to populate __all__ and the module globals"
+HOMEPAGE="
+ https://gitlab.com/warsaw/public/
+ https://pypi.org/project/atpublic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/sybil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/backoff/Manifest b/dev-python/backoff/Manifest
index ad9ddf8baa5a..3ed6164fd3ba 100644
--- a/dev-python/backoff/Manifest
+++ b/dev-python/backoff/Manifest
@@ -1 +1,2 @@
DIST backoff-1.11.0.gh.tar.gz 17566 BLAKE2B 4afed5284eb3cbedf54e06fcd89861701613357c672ebabe2611a4bc28c3a6e4539e206cee24bb6a646f7c16c033f16ef56be3b21867aad760b71410749383b7 SHA512 0f5e176bf9d093a72068cf6e55ada8da3e8ec67b85b4fba2d697117dcb3c563a429ff53c5fe17b4a20a8b5ee0420930b789478bd89de5949b628158263413a60
+DIST backoff-1.11.1.gh.tar.gz 17581 BLAKE2B ca940270859ad78cd29d33cfd3c17605f5b42c2c745b7e7a41d53b2d6ef4bee78dd9e8f15c80387da31679aac6d30404c0988013a890ff34bd55e91716c0eff8 SHA512 7ba0e579d2a4a4bb5046ddc0d1f4b5b58ae2969a10a10a3c657e7dd9b8fd0cd6bc56fec18c28c8fb49101521b3840fe31c65e103977ea5f52f3671a07def97d4
diff --git a/dev-python/backoff/backoff-1.11.1.ebuild b/dev-python/backoff/backoff-1.11.1.ebuild
new file mode 100644
index 000000000000..30c7e50a72c6
--- /dev/null
+++ b/dev-python/backoff/backoff-1.11.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Function decoration for backoff and retry"
+HOMEPAGE="
+ https://github.com/litl/backoff/
+ https://pypi.org/project/backoff/
+"
+SRC_URI="
+ https://github.com/litl/backoff/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.rst )
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/backports-entry_points_selectable/Manifest b/dev-python/backports-entry_points_selectable/Manifest
index 4338b348b763..0280dea045b6 100644
--- a/dev-python/backports-entry_points_selectable/Manifest
+++ b/dev-python/backports-entry_points_selectable/Manifest
@@ -1 +1,2 @@
DIST backports.entry_points_selectable-1.1.0.gh.tar.gz 7689 BLAKE2B e7fb4372838b47e65e50d91acb034afaf326947bd76bbdf14b57834b94c72fb62afa6526931a96cc1e10b43eca9d95dce7fde431c24a4e15a4b2569ddf42faeb SHA512 abf8f5d228b52281160cedfd017f1a4273b8fce01ed29e9f0417f750125abacaf97a3cc6f363849702d1dc6f3c40602461f79bfcc2a36a3dfb962af1112046d2
+DIST backports.entry_points_selectable-1.1.1.gh.tar.gz 7688 BLAKE2B d142a4c608b05c708b01487bf2810324fe2e5229de0d57844949a4596f710f736252a3111d67a602a84a70eb32b53752a3483edf39454272bb483c8555a46cbb SHA512 b811a473e13ebb3dafe94d726bfe98d7569a9d9a98ab77f1ed975b17deecf84e93e04a4ee263c3721b4e9fbbfae2f307b8c88a83441f792dd88511bb99f19c1d
diff --git a/dev-python/backports-entry_points_selectable/backports-entry_points_selectable-1.1.1.ebuild b/dev-python/backports-entry_points_selectable/backports-entry_points_selectable-1.1.1.ebuild
new file mode 100644
index 000000000000..5cf1f1d5f6a8
--- /dev/null
+++ b/dev-python/backports-entry_points_selectable/backports-entry_points_selectable-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Compatibility shim providing selectable entry points"
+HOMEPAGE="
+ https://github.com/jaraco/backports.entry_points_selectable/
+ https://pypi.org/project/backports.entry-points-selectable/
+"
+SRC_URI="
+ https://github.com/jaraco/backports.entry_points_selectable/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}