summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 06:28:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:15 -0400
commit9ad9a90a22515deca0a04f3df582d3c1950dd0fa (patch)
treef06cdfb7568174f39dc8988864fe718abcad8b2c
parentx11-wm/lwm: force gcc -E for imake's generation (diff)
downloadgentoo-9ad9a90a22515deca0a04f3df582d3c1950dd0fa.tar.gz
gentoo-9ad9a90a22515deca0a04f3df582d3c1950dd0fa.tar.bz2
gentoo-9ad9a90a22515deca0a04f3df582d3c1950dd0fa.zip
x11-wm/vtwm: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Closes: https://bugs.gentoo.org/870925 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-wm/vtwm/vtwm-5.4.7-r2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild b/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild
index 67ac8de4a833..4f976b42e894 100644
--- a/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild
+++ b/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,12 +20,13 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
rplay? ( media-sound/rplay )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-text/rman
sys-devel/bison
sys-devel/flex
- x11-base/xorg-proto
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
src_prepare() {
@@ -47,7 +48,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die "xmkmf failed"
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die "xmkmf failed"
}
src_compile() {