summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 06:59:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 08:26:52 +0100
commit934e970b96d65c6d644f00d6ebb95a66cb3e4680 (patch)
tree2508851bf9d1f0eea793a91a874d9ea825ef5d8c
parentapp-admin/awscli: Bump to 1.27.9 (diff)
downloadgentoo-934e970b96d65c6d644f00d6ebb95a66cb3e4680.tar.gz
gentoo-934e970b96d65c6d644f00d6ebb95a66cb3e4680.tar.bz2
gentoo-934e970b96d65c6d644f00d6ebb95a66cb3e4680.zip
dev-python/simplejson: Bump to 3.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.18.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index c5dda2b98763..f7ee6c0ff08b 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1 +1,2 @@
DIST simplejson-3.17.6.tar.gz 83134 BLAKE2B 5aa9275673a0c8feab2a86f1bc85864791a847a7eda77ea6f3e4f8d8677ff88d2277ff659285d183d2d439c58e78b25846badb3a2fddbc959d40eb23273dfa2b SHA512 4a25032fcc78025d82db571716deef8769f036a330560f92e14563687db4a42dbe60866b8afb57baf24104ef94fcbe938cdbddfc169542664957eef2d00d04e3
+DIST simplejson-3.18.0.tar.gz 83533 BLAKE2B 83c6f7f3734507f5a96b51d52dd39b0bd8ff772d51ce1f12ff2ee68f83747f519f418f78247727af7c408da4e7818d1b0d1f7b54b7780e3bc427add1eeaebb06 SHA512 952177fc707e5b1fb6450093876f9a7af1026271cb792bb8dc0418b83906ae32e7f2251b96f531101197d0b3204a97124bff02f7abc4cf700da4edf1320b6b08
diff --git a/dev-python/simplejson/simplejson-3.18.0.ebuild b/dev-python/simplejson/simplejson-3.18.0.ebuild
new file mode 100644
index 000000000000..84d4dee1f814
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.18.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest