summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-10-23 08:46:49 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-10-23 08:46:49 +0000
commit8bd2d935e7618182bb68a6e4d49c3984581c9559 (patch)
treeb4a1eb0109a5ec23f5038ec2d3f3aaf9512730c5
parent2023-10-23 08:31:51 UTC (diff)
parentmedia-sound/spotify-tray: treeclean (diff)
downloadgentoo-8bd2d935e7618182bb68a6e4d49c3984581c9559.tar.gz
gentoo-8bd2d935e7618182bb68a6e4d49c3984581c9559.tar.bz2
gentoo-8bd2d935e7618182bb68a6e4d49c3984581c9559.zip
Merge updates from master
-rw-r--r--dev-python/moddb/Manifest1
-rw-r--r--dev-python/moddb/moddb-0.10.0.ebuild54
-rw-r--r--eclass/ghc-package.eclass4
-rw-r--r--media-sound/spotify-tray/Manifest1
-rw-r--r--media-sound/spotify-tray/metadata.xml12
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild41
-rw-r--r--profiles/package.mask6
7 files changed, 57 insertions, 62 deletions
diff --git a/dev-python/moddb/Manifest b/dev-python/moddb/Manifest
index 05be09239507..d3a5849cfc5f 100644
--- a/dev-python/moddb/Manifest
+++ b/dev-python/moddb/Manifest
@@ -1,2 +1,3 @@
+DIST moddb-0.10.0.gh.tar.gz 14174575 BLAKE2B cffcdb27d3bd43da412d9ce689ba06d59ee013d4b78b75fddc8749243aaa6abb50c576811ef8e8e88c66ff41b578a79daec4ce0dbe56f444c94eeabedb0fef89 SHA512 5b21aea8a76c2b28579dbb3587956042126b65248684c2c6caef43793b8e7dd1d318434783c252ef191ee7832ea9fe1a434797797a9a76804133a53ede7674f9
DIST moddb-0.8.1.gh.tar.gz 68417 BLAKE2B e013c6a2c315eb3f36ace6f37eadacd50a5854726cb6cbcbc6d16170bc1af06bf973d9874909ecb6e70c5a3cb896ef559eb6e915eed41217069fc3c7f468e57e SHA512 3557881f9bc33c911ba2e3d845a8294116c5ea394de4f24ab05a0d0af07ae000e972db9077fad8a1a30941a66b7f560cfce0616df93f1bae835efb51ee6035e2
DIST moddb-0.9.0.gh.tar.gz 70547 BLAKE2B 34382e117d6dc184fb63626062b4b2cb11bb155a74069bc69688ad4696f8646fc5e214e0aeea64093ebedad0c032d263174692278d149468fffb44aabeec32dd SHA512 2735e0f34cb9efa74debf9be5aaad63911b0a2aaab38bca223598e29a560d2480fc03b56e8847a9fb14e80462b824054c58475e733a2ebc63ab2ec0eaa753c9f
diff --git a/dev-python/moddb/moddb-0.10.0.ebuild b/dev-python/moddb/moddb-0.10.0.ebuild
new file mode 100644
index 000000000000..588d82aa4a6c
--- /dev/null
+++ b/dev-python/moddb/moddb-0.10.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scrapper to access ModDB mods, games and more as objects"
+HOMEPAGE="https://github.com/ClementJ18/moddb"
+SRC_URI="https://github.com/ClementJ18/moddb/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Connects to moddb.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ <dev-python/pyrate-limiter-3.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests require valid moddb.com login information
+ "tests/test_base.py::TestLogin::test_login"
+ "tests/test_client.py::TestClient::test_get_watched"
+ "tests/test_client.py::TestClient::test_get_updates"
+ "tests/test_client.py::TestClient::test_posts"
+ "tests/test_client.py::TestClient::test_friends"
+ "tests/test_client.py::TestClient::test_messages"
+)
+
+distutils_enable_sphinx docs/source dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+python_test() {
+ # Dummy moddb.com login information
+ export USERNAME="portage"
+ export SENDER_USERNAME="portage"
+ export PASSWORD="testing"
+ export SENDER_PASSWORD="testing"
+ epytest
+}
diff --git a/eclass/ghc-package.eclass b/eclass/ghc-package.eclass
index 5bd51c0f41ac..66a14ca971ba 100644
--- a/eclass/ghc-package.eclass
+++ b/eclass/ghc-package.eclass
@@ -1,12 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: ghc-package.eclass
# @MAINTAINER:
# "Gentoo's Haskell Language team" <haskell@gentoo.org>
-# @SUPPORTED_EAPIS: 6 7 8
# @AUTHOR:
# Original Author: Andres Loeh <kosmikus@gentoo.org>
+# @SUPPORTED_EAPIS: 6 7 8
# @BLURB: This eclass helps with the Glasgow Haskell Compiler's package configuration utility.
# @DESCRIPTION:
# Helper eclass to handle ghc installation/upgrade/deinstallation process.
diff --git a/media-sound/spotify-tray/Manifest b/media-sound/spotify-tray/Manifest
deleted file mode 100644
index 601df41d9063..000000000000
--- a/media-sound/spotify-tray/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST spotify-tray-1.3.2.tar.gz 22298 BLAKE2B da1399db3d42d969d983b9bae695ff55dbdff47ef49ac79e10e2681df45489505028901a0946dd70495a6a74b9eef979f9ef07a722a08cb93a2ba6749c106f4a SHA512 74ae5ebaa61497a0274646dad04d408bb4176bbbacbb0e80211bec9218d09e293c8abf4c9424de8123ba4440d63adb58c5b68ca53690d2e348d52efbbc3f88c1
diff --git a/media-sound/spotify-tray/metadata.xml b/media-sound/spotify-tray/metadata.xml
deleted file mode 100644
index 1748f0786b3b..000000000000
--- a/media-sound/spotify-tray/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>andrewammerlaan@gentoo.org</email>
- <name>Andrew Ammerlaan</name>
- </maintainer>
- <upstream>
- <remote-id type="github">tsmetana/spotify-tray</remote-id>
- <bugs-to>https://github.com/tsmetana/spotify-tray/issues</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
deleted file mode 100644
index 6630dbac467e..000000000000
--- a/media-sound/spotify-tray/spotify-tray-1.3.2-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools xdg
-
-DESCRIPTION="Wrapper around the Spotify client that adds a tray icon"
-HOMEPAGE="https://github.com/tsmetana/spotify-tray"
-SRC_URI="https://github.com/tsmetana/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-LICENSE="GPL-3"
-SLOT="0"
-
-DEPEND="
- x11-libs/gtk+:3[X]
-"
-RDEPEND="${DEPEND}
- media-sound/spotify
-"
-
-src_prepare() {
- default
- # Fix error: AM_INIT_AUTOMAKE expanded multiple times
- sed -i -e '/^AM_INIT_AUTOMAKE$/d' configure.ac || die
-
- # Fix the name of the icon
- sed -i -e 's/Icon=spotify/Icon=spotify-client/g' spotify-tray.desktop.in || die
- eautoreconf
-}
-
-src_install() {
- default
- # remove desktop file, launching is handled in spotify ebuild
- rm "${ED}/usr/share/applications/spotify-tray.desktop" || die
-
- # move executable outside of PATH to avoid accidentally launching it in a loop
- mkdir -p "${ED}/opt/spotify/spotify-client" || die
- mv "${ED}/usr/bin/spotify-tray" "${ED}/opt/spotify/spotify-client/spotify-tray" || die
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index ab306c44e5db..86473916f811 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -201,12 +201,6 @@ dev-python/memory-profiler
# Removal on 2023-10-29. Bug #894592.
dev-python/django-mptt
-# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2023-09-23)
-# >=media-sound/spotify-1.2.20 now has its own tray icon.
-# Therefore the use case for this package is gone.
-# Removal on 2023-10-23
-media-sound/spotify-tray
-
# Hans de Graaff <graaff@gentoo.org> (2023-09-23)
# ruby31-only package. No reverse dependencies. Archived by
# upstream. Last release in 2012. Removal on 2023-10-23.