summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 10:49:06 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 10:49:06 +0000
commit8727de93c52fb5e13f96c35208fbd69137db4247 (patch)
tree752bb2bb41303a22b553b2c91025f892be71625c
parent2024-07-15 10:34:11 UTC (diff)
parentdev-ml/opam: add 2.1.5 (diff)
downloadgentoo-8727de93c52fb5e13f96c35208fbd69137db4247.tar.gz
gentoo-8727de93c52fb5e13f96c35208fbd69137db4247.tar.bz2
gentoo-8727de93c52fb5e13f96c35208fbd69137db4247.zip
Merge updates from master
-rw-r--r--dev-ml/opam-client/Manifest1
-rw-r--r--dev-ml/opam-client/opam-client-2.1.5.ebuild43
-rw-r--r--dev-ml/opam-solver/Manifest1
-rw-r--r--dev-ml/opam-solver/opam-solver-2.1.5.ebuild43
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/opam-2.1.5.ebuild44
-rw-r--r--sys-kernel/vanilla-sources/Manifest1
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-6.10.0.ebuild16
8 files changed, 150 insertions, 0 deletions
diff --git a/dev-ml/opam-client/Manifest b/dev-ml/opam-client/Manifest
index 13cb1b80d395..d1d1ef4c062e 100644
--- a/dev-ml/opam-client/Manifest
+++ b/dev-ml/opam-client/Manifest
@@ -3,3 +3,4 @@ DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e5137
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
DIST opam-2.1.3.tar.gz 832450 BLAKE2B c5e50c0a41b7197bc7645eaef0d8cba79c978b4432fc824aa6a4280df65ec7d59df52a22b76877da4949c8562a5fecb8da2a179ca67bd312bf9a514961bf4444 SHA512 040e4f58f93e962ff422617ce0d35ed45dd86921a9aac3505914c33dd942d0e5e5771e7e1774046504f9aa84f32bc4fbd6ac7720fbea862d48bf1ca29e02cefc
+DIST opam-2.1.5.tar.gz 837005 BLAKE2B f2e58784959f0e47fbe5ae65112a030d8350b061d7b0d2676f40e22ec5bf62c136bc37fd3078403dab807705ce8a1c8b6bb0ecf00b68fdfbb5f3d5a9acb88c77 SHA512 4395defe7df1d03ca889718b8eafd8161ff009710475f62673f19f012e0bde8ad2a919bd9d02d7f96b4c5a9bbf38e0ba9a256531c24de15cafabd4ef11f7c8e8
diff --git a/dev-ml/opam-client/opam-client-2.1.5.ebuild b/dev-ml/opam-client/opam-client-2.1.5.ebuild
new file mode 100644
index 000000000000..19e091b78f8d
--- /dev/null
+++ b/dev-ml/opam-client/opam-client-2.1.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="opam client libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ ~dev-ml/opam-repository-${PV}:=[ocamlopt?]
+ ~dev-ml/opam-state-${PV}:=[ocamlopt?]
+ ~dev-ml/opam-solver-${PV}:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( sys-apps/bubblewrap )"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}
+
+src_compile() {
+ dune-compile ${PN}
+}
diff --git a/dev-ml/opam-solver/Manifest b/dev-ml/opam-solver/Manifest
index 13cb1b80d395..d1d1ef4c062e 100644
--- a/dev-ml/opam-solver/Manifest
+++ b/dev-ml/opam-solver/Manifest
@@ -3,3 +3,4 @@ DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e5137
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
DIST opam-2.1.3.tar.gz 832450 BLAKE2B c5e50c0a41b7197bc7645eaef0d8cba79c978b4432fc824aa6a4280df65ec7d59df52a22b76877da4949c8562a5fecb8da2a179ca67bd312bf9a514961bf4444 SHA512 040e4f58f93e962ff422617ce0d35ed45dd86921a9aac3505914c33dd942d0e5e5771e7e1774046504f9aa84f32bc4fbd6ac7720fbea862d48bf1ca29e02cefc
+DIST opam-2.1.5.tar.gz 837005 BLAKE2B f2e58784959f0e47fbe5ae65112a030d8350b061d7b0d2676f40e22ec5bf62c136bc37fd3078403dab807705ce8a1c8b6bb0ecf00b68fdfbb5f3d5a9acb88c77 SHA512 4395defe7df1d03ca889718b8eafd8161ff009710475f62673f19f012e0bde8ad2a919bd9d02d7f96b4c5a9bbf38e0ba9a256531c24de15cafabd4ef11f7c8e8
diff --git a/dev-ml/opam-solver/opam-solver-2.1.5.ebuild b/dev-ml/opam-solver/opam-solver-2.1.5.ebuild
new file mode 100644
index 000000000000..f1356ca7d7cf
--- /dev/null
+++ b/dev-ml/opam-solver/opam-solver-2.1.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="opam solver"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/mccs:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+ dev-ml/cudf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/opam-client )"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}
+
+src_compile() {
+ dune-compile ${PN}
+}
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 13cb1b80d395..d1d1ef4c062e 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -3,3 +3,4 @@ DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e5137
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
DIST opam-2.1.3.tar.gz 832450 BLAKE2B c5e50c0a41b7197bc7645eaef0d8cba79c978b4432fc824aa6a4280df65ec7d59df52a22b76877da4949c8562a5fecb8da2a179ca67bd312bf9a514961bf4444 SHA512 040e4f58f93e962ff422617ce0d35ed45dd86921a9aac3505914c33dd942d0e5e5771e7e1774046504f9aa84f32bc4fbd6ac7720fbea862d48bf1ca29e02cefc
+DIST opam-2.1.5.tar.gz 837005 BLAKE2B f2e58784959f0e47fbe5ae65112a030d8350b061d7b0d2676f40e22ec5bf62c136bc37fd3078403dab807705ce8a1c8b6bb0ecf00b68fdfbb5f3d5a9acb88c77 SHA512 4395defe7df1d03ca889718b8eafd8161ff009710475f62673f19f012e0bde8ad2a919bd9d02d7f96b4c5a9bbf38e0ba9a256531c24de15cafabd4ef11f7c8e8
diff --git a/dev-ml/opam/opam-2.1.5.ebuild b/dev-ml/opam/opam-2.1.5.ebuild
new file mode 100644
index 000000000000..58c912386ed2
--- /dev/null
+++ b/dev-ml/opam/opam-2.1.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" #see bugs 838658
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/cudf:=[ocamlopt?]
+ dev-ml/dose3:=[ocamlopt?]
+ dev-ml/extlib:=[ocamlopt?]
+ ~dev-ml/opam-client-${PV}:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ sys-apps/bubblewrap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}
+
+src_compile() {
+ dune-compile ${PN}
+}
diff --git a/sys-kernel/vanilla-sources/Manifest b/sys-kernel/vanilla-sources/Manifest
index 6c5f822b7a41..548062f4dc9b 100644
--- a/sys-kernel/vanilla-sources/Manifest
+++ b/sys-kernel/vanilla-sources/Manifest
@@ -3,6 +3,7 @@ DIST linux-5.10.tar.xz 116606704 BLAKE2B b923d7b66309224f42f35f8a5fa219421b0a936
DIST linux-5.15.tar.xz 121913744 BLAKE2B 3921274b23f7938abdf3ed9334534b4581e13d7484303d3a5280eddb038999aaa8b836666a487472d9c4a219af0f06b9fecccaf348fb5510ab8762f4ef4b7e83 SHA512 d25ad40b5bcd6a4c6042fd0fd84e196e7a58024734c3e9a484fd0d5d54a0c1d87db8a3c784eff55e43b6f021709dc685eb0efa18d2aec327e4f88a79f405705a
DIST linux-5.4.tar.xz 109441440 BLAKE2B 193bc4a3147e147d5529956164ec4912fad5d5c6fb07f909ff1056e57235834173194afc686993ccd785c1ff15804de0961b625f3008cca0e27493efc8f27b13 SHA512 9f60f77e8ab972b9438ac648bed17551c8491d6585a5e85f694b2eaa4c623fbc61eb18419b2656b6795eac5deec0edaa04547fc6723fbda52256bd7f3486898f
DIST linux-6.1.tar.xz 134728520 BLAKE2B ae60257860b2bd1bd708d183f0443afc60ebbd2b3d535c45e44c2e541bd0928530a3b62de6385dd4e4726ebbedcc0a871d4f3ffb4105b9f1f6d8ed7467f5688e SHA512 6ed2a73c2699d0810e54753715635736fc370288ad5ce95c594f2379959b0e418665cd71bc512a0273fe226fe90074d8b10d14c209080a6466498417a4fdda68
+DIST linux-6.10.tar.xz 145142812 BLAKE2B bb243ea7493b9d63aa2df2050a3f1ae2b89ee84a20015239cf157e3f4f51c7ac5efedc8a51132b2d7482f9276ac418de6624831c8a3b806130d9c2d2124c539b SHA512 baa2487954044f991d2ae254d77d14a1f0185dd62c9f0fcaff69f586c9f906823017b8db1c4588f27b076dfa3ebb606929fec859f60ea419e7974330b9289cc2
DIST linux-6.6.tar.xz 140064536 BLAKE2B 5f02fd8696d42f7ec8c5fbadec8e7270bdcfcb1f9844a6c4db3e1fd461c93ce1ccda650ca72dceb4890ebcbbf768ba8fba0bce91efc49fbd2c307b04e95665f2 SHA512 458b2c34d46206f9b4ccbac54cc57aeca1eaecaf831bc441e59701bac6eadffc17f6ce24af6eadd0454964e843186539ac0d63295ad2cc32d112b60360c39a35
DIST linux-6.9.tar.xz 144034416 BLAKE2B 4cf86c3cfe6e6534745d42dfaeca59b17ea1168c4e8b615c80e6d8aac735f11283cd85fa992b440b5d4452917e94b9f08397a64af0be5894e3df23c68892377e SHA512 fed3b4cd1fbfb4d94618587c1934273d2ecc8b6e42a3d586ff8a5f24980be930f2ef803aa2923ca3bfa5e4e619f967f3af315368f24fa76f610b10443624a579
DIST patch-4.19.317.xz 6077612 BLAKE2B 5ac41af9e2840120c3518350ed70445241fabecc9645f0141fde402cad35d323377e96c0ad2e8e052b6789e0978528f900cf7c81cb5186c0934fa3299bbacb07 SHA512 a4019005ac7141bb82d058d00e318b1de177b4f5d7a6ab0b0140f3e1eef7dff2f4bdc7352c673aa1cfdad970b7405753edefaa8db0d060628f9e7c1e5dc25aad
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-6.10.0.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-6.10.0.ebuild
new file mode 100644
index 000000000000..b8791038d227
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-6.10.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa -ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"