summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-08-27 15:07:13 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-08-27 15:07:13 +0000
commit85d82e192aa71077f0907bcde47a777fb30b2e1c (patch)
tree85d944c0d4577af886b89530e40d0a25c2986e33
parent2017-08-27 14:24:08 UTC (diff)
parentsec-policy/selinux-base-policy: drop insecure git:// path in favour of https:// (diff)
downloadgentoo-85d82e192aa71077f0907bcde47a777fb30b2e1c.tar.gz
gentoo-85d82e192aa71077f0907bcde47a777fb30b2e1c.tar.bz2
gentoo-85d82e192aa71077f0907bcde47a777fb30b2e1c.zip
Merge updates from master
-rw-r--r--dev-python/futures/futures-3.1.1.ebuild2
-rw-r--r--eclass/selinux-policy-2.eclass2
-rw-r--r--media-libs/libao/libao-1.2.2.ebuild2
-rwxr-xr-xnet-misc/kafka-bin/files/kafka.init.d.222
-rw-r--r--net-misc/kafka-bin/kafka-bin-0.10.2.1-r1.ebuild62
-rw-r--r--net-misc/kafka-bin/kafka-bin-0.11.0.0-r1.ebuild62
-rw-r--r--net-misc/youtube-dl/Manifest2
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild (renamed from net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild)6
-rw-r--r--profiles/package.mask4
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild2
-rw-r--r--sec-policy/selinux-base/selinux-base-9999.ebuild2
-rw-r--r--x11-libs/gtk+/gtk+-3.22.17.ebuild2
-rw-r--r--x11-libs/gtk+/gtk+-3.22.19.ebuild2
13 files changed, 161 insertions, 11 deletions
diff --git a/dev-python/futures/futures-3.1.1.ebuild b/dev-python/futures/futures-3.1.1.ebuild
index 5b7d538b9f23..733503a35a45 100644
--- a/dev-python/futures/futures-3.1.1.ebuild
+++ b/dev-python/futures/futures-3.1.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ppc ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="doc"
DEPEND="
diff --git a/eclass/selinux-policy-2.eclass b/eclass/selinux-policy-2.eclass
index 34f4bf54eee8..fb205c1bfefd 100644
--- a/eclass/selinux-policy-2.eclass
+++ b/eclass/selinux-policy-2.eclass
@@ -62,7 +62,7 @@
# using a single variable, rather than having to set the packagename_LIVE_REPO
# variable for each and every SELinux policy module package they want to install.
# The default value is Gentoo's hardened-refpolicy repository.
-: ${SELINUX_GIT_REPO:="git://anongit.gentoo.org/proj/hardened-refpolicy.git https://anongit.gentoo.org/git/proj/hardened-refpolicy.git"};
+: ${SELINUX_GIT_REPO:="https://anongit.gentoo.org/git/proj/hardened-refpolicy.git"};
# @ECLASS-VARIABLE: SELINUX_GIT_BRANCH
# @DESCRIPTION:
diff --git a/media-libs/libao/libao-1.2.2.ebuild b/media-libs/libao/libao-1.2.2.ebuild
index 9eade5107fd5..a995e21fe30e 100644
--- a/media-libs/libao/libao-1.2.2.ebuild
+++ b/media-libs/libao/libao-1.2.2.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/xiph/libao/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="alsa nas mmap pulseaudio static-libs"
RDEPEND="
diff --git a/net-misc/kafka-bin/files/kafka.init.d.2 b/net-misc/kafka-bin/files/kafka.init.d.2
new file mode 100755
index 000000000000..87b4b47a4469
--- /dev/null
+++ b/net-misc/kafka-bin/files/kafka.init.d.2
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Kafka distributed messaging system"
+
+logfile="/var/log/kafka/kafka.log"
+
+command="/opt/kafka/bin/kafka-server-start.sh"
+command_args="/etc/kafka/server.properties"
+
+command_background=yes
+pidfile=/run/kafka.pid
+
+start() {
+ start-stop-daemon --start --background --user kafka --chdir /opt/kafka --stdout $logfile --stderr $logfile \
+ --env KAFKA_HEAP_OPTS="${KAFKA_HEAP_OPTS}" \
+ --pidfile $pidfile --exec /opt/kafka/bin/kafka-server-start.sh -- /etc/kafka/server.properties
+}
+depend() {
+ after zookeeper kafka-zookeeper
+}
diff --git a/net-misc/kafka-bin/kafka-bin-0.10.2.1-r1.ebuild b/net-misc/kafka-bin/kafka-bin-0.10.2.1-r1.ebuild
new file mode 100644
index 000000000000..36e9ed9e938d
--- /dev/null
+++ b/net-misc/kafka-bin/kafka-bin-0.10.2.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="A high-throughput distributed messaging system"
+HOMEPAGE="http://kafka.apache.org/"
+
+# pick recommended scala version
+SCALA_VERSION=2.12
+MY_PN="kafka"
+MY_P="${MY_PN}_${SCALA_VERSION}-${PV}"
+SRC_URI="mirror://apache/kafka/${PV}/${MY_P}.tgz"
+
+RESTRICT="mirror"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="internal-zookeeper"
+
+RDEPEND="
+ || ( virtual/jre:1.8 virtual/jre:1.7 )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR="/opt/${MY_PN}"
+
+pkg_setup() {
+ enewgroup kafka
+ enewuser kafka -1 /bin/sh /var/lib/kafka kafka
+}
+
+src_prepare() {
+ sed -i -e 's:/tmp/zookeeper:/var/lib/kafka/zookeeper:' "config/zookeeper.properties" || die
+ sed -i -e 's:/tmp/kafka-logs:/var/lib/kafka/logs:' "config/server.properties" || die
+}
+
+src_install() {
+ insinto /etc/kafka
+ doins config/zookeeper.properties config/server.properties
+ if use "internal-zookeeper"; then
+ keepdir /var/lib/kafka/zookeeper
+ newinitd "${FILESDIR}/${MY_PN}-zookeeper.init.d" "${MY_PN}-zookeeper"
+ fi
+
+ keepdir /var/lib/kafka
+ fowners -R kafka:kafka /var/lib/kafka
+
+ keepdir /var/log/kafka
+ fowners -R kafka:kafka /var/log/kafka
+
+ newinitd "${FILESDIR}/${MY_PN}.init.d.2" "${MY_PN}"
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP bin config libs "${ED}/${INSTALL_DIR}" || die
+ keepdir "${INSTALL_DIR}/logs"
+ fowners -R kafka:kafka "${INSTALL_DIR}"
+}
diff --git a/net-misc/kafka-bin/kafka-bin-0.11.0.0-r1.ebuild b/net-misc/kafka-bin/kafka-bin-0.11.0.0-r1.ebuild
new file mode 100644
index 000000000000..36e9ed9e938d
--- /dev/null
+++ b/net-misc/kafka-bin/kafka-bin-0.11.0.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="A high-throughput distributed messaging system"
+HOMEPAGE="http://kafka.apache.org/"
+
+# pick recommended scala version
+SCALA_VERSION=2.12
+MY_PN="kafka"
+MY_P="${MY_PN}_${SCALA_VERSION}-${PV}"
+SRC_URI="mirror://apache/kafka/${PV}/${MY_P}.tgz"
+
+RESTRICT="mirror"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="internal-zookeeper"
+
+RDEPEND="
+ || ( virtual/jre:1.8 virtual/jre:1.7 )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR="/opt/${MY_PN}"
+
+pkg_setup() {
+ enewgroup kafka
+ enewuser kafka -1 /bin/sh /var/lib/kafka kafka
+}
+
+src_prepare() {
+ sed -i -e 's:/tmp/zookeeper:/var/lib/kafka/zookeeper:' "config/zookeeper.properties" || die
+ sed -i -e 's:/tmp/kafka-logs:/var/lib/kafka/logs:' "config/server.properties" || die
+}
+
+src_install() {
+ insinto /etc/kafka
+ doins config/zookeeper.properties config/server.properties
+ if use "internal-zookeeper"; then
+ keepdir /var/lib/kafka/zookeeper
+ newinitd "${FILESDIR}/${MY_PN}-zookeeper.init.d" "${MY_PN}-zookeeper"
+ fi
+
+ keepdir /var/lib/kafka
+ fowners -R kafka:kafka /var/lib/kafka
+
+ keepdir /var/log/kafka
+ fowners -R kafka:kafka /var/log/kafka
+
+ newinitd "${FILESDIR}/${MY_PN}.init.d.2" "${MY_PN}"
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP bin config libs "${ED}/${INSTALL_DIR}" || die
+ keepdir "${INSTALL_DIR}/logs"
+ fowners -R kafka:kafka "${INSTALL_DIR}"
+}
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 61b07ffdd333..5a2240602644 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,3 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
-DIST youtube-dl-2017.08.18.tar.gz 2779312 SHA256 a7f4279b7b8b54f44025fccc22f3e511cae77314f7d37b73334c981946e4c3d6 SHA512 bf403e2f4b7024346219ce01b229ab18329e3faf7aadbd0706e7783072815eaf588812ccbed876212d57192533c09ec8aaceb4a497a411672533b436a9f215f5 WHIRLPOOL a262d999ef27f44b4daeda207b35d2f4952aa04f5b965ada8d47a9b2f64d0f887a5d2276a13db297e9d40957c266556db551ed326beddd5239951cd0262dfc12
DIST youtube-dl-2017.08.23.tar.gz 2783237 SHA256 90c56ce90cd99cefb83607c37b0b641c7e4e1ef37040ad4187425aebcfc800ef SHA512 d4e1407558ed7dc7369ada2eabbd64f0e74b718abc67f7f4aa1eef8f522880a63b943b70b6af4b18df176db72c9e9552f1e36727312944b62b6d3aae3bc11b4e WHIRLPOOL 32620396ae7e7b620e956539a5afd98223dff176ad6306fc291bc4f4bdace5a309b9b5f7afc1ee5c982d5e62c7d93886073d3c5c29629673f0336c8378216fba
+DIST youtube-dl-2017.08.27.1.tar.gz 2784682 SHA256 32d823b8aa1714c40e20f920e481be48d7458d657e66d118a0467a351d680aac SHA512 4cbe2c2b917b59ccb5a171a171c69d5bdd915a56a4ca2d4bf67a04c7425b2d4849403a78d954cd0aa8401f8f4b61e4ebe96160aba2a9d2f3da1eae026739e9ba WHIRLPOOL c99cde85126741845a1e45873f8d79362775b4066a9736b563d15993d88c5b9201c9cb2239b8db85a8e18a91f7118906bd0ad5cd93e98a8538d7f796df0fb675
diff --git a/net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild b/net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild
index 57b578450c4e..fa2e8cbf808f 100644
--- a/net-misc/youtube-dl/youtube-dl-2017.08.18.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 eutils
+inherit bash-completion-r1 distutils-r1
DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
@@ -67,7 +67,7 @@ python_prepare_all() {
|| die
fi
- epatch_user
+ eapply_user
distutils-r1_python_prepare_all
}
diff --git a/profiles/package.mask b/profiles/package.mask
index 78fe2af87f3c..bc38d2e074bd 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -29,6 +29,10 @@
#--- END OF EXAMPLES ---
+# Anthony G. Basile <blueness@gentoo.org> (27 Aug 2017)
+# Upstream is no longer providing public patches
+sys-kernel/hardened-sources
+
# Andreas Sturmlechner <asturm@gentoo.org> (27 Aug 2017)
# Requires deprecated libkcddb:4, upstream is not going to port.
# See also: https://github.com/dfaust/soundkonverter/issues/23
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
index 24ff4807a9d4..7aa38de444d9 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="${SELINUX_GIT_REPO:-git://anongit.gentoo.org/proj/hardened-refpolicy.git https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
+ EGIT_REPO_URI="${SELINUX_GIT_REPO:-https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
EGIT_BRANCH="${SELINUX_GIT_BRANCH:-master}"
EGIT_CHECKOUT_DIR="${WORKDIR}/refpolicy"
diff --git a/sec-policy/selinux-base/selinux-base-9999.ebuild b/sec-policy/selinux-base/selinux-base-9999.ebuild
index 29b2fee3bf1c..9ad7a4351bdd 100644
--- a/sec-policy/selinux-base/selinux-base-9999.ebuild
+++ b/sec-policy/selinux-base/selinux-base-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="${SELINUX_GIT_REPO:-git://anongit.gentoo.org/proj/hardened-refpolicy.git https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
+ EGIT_REPO_URI="${SELINUX_GIT_REPO:-https://anongit.gentoo.org/git/proj/hardened-refpolicy.git}"
EGIT_BRANCH="${SELINUX_GIT_BRANCH:-master}"
EGIT_CHECKOUT_DIR="${WORKDIR}/refpolicy"
diff --git a/x11-libs/gtk+/gtk+-3.22.17.ebuild b/x11-libs/gtk+/gtk+-3.22.17.ebuild
index fca246b46e85..2034f00888c9 100644
--- a/x11-libs/gtk+/gtk+-3.22.17.ebuild
+++ b/x11-libs/gtk+/gtk+-3.22.17.ebuild
@@ -86,10 +86,10 @@ RDEPEND="${COMMON_DEPEND}
>=dev-util/gtk-update-icon-cache-3
!<gnome-base/gail-1000
!<x11-libs/vte-0.31.0:2.90
- >=x11-themes/adwaita-icon-theme-3.14
"
# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
PDEPEND="
+ >=x11-themes/adwaita-icon-theme-3.14
gnome-base/librsvg[${MULTILIB_USEDEP}]
vim-syntax? ( app-vim/gtk-syntax )
"
diff --git a/x11-libs/gtk+/gtk+-3.22.19.ebuild b/x11-libs/gtk+/gtk+-3.22.19.ebuild
index 36e3f2c0152a..8ea8f71c60eb 100644
--- a/x11-libs/gtk+/gtk+-3.22.19.ebuild
+++ b/x11-libs/gtk+/gtk+-3.22.19.ebuild
@@ -86,11 +86,11 @@ RDEPEND="${COMMON_DEPEND}
>=dev-util/gtk-update-icon-cache-3
!<gnome-base/gail-1000
!<x11-libs/vte-0.31.0:2.90
- >=x11-themes/adwaita-icon-theme-3.14
"
# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
PDEPEND="
gnome-base/librsvg[${MULTILIB_USEDEP}]
+ >=x11-themes/adwaita-icon-theme-3.14
vim-syntax? ( app-vim/gtk-syntax )
"