summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 14:45:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-06 09:26:46 +0200
commit7ec978e7f9bb50d0353c0bdacc8d278339f51805 (patch)
treee75ca8b1f4dba4a62b76ceb6ddb2ce93606b2467
parentkde-apps/kio-extras: Fix build with USE -X (diff)
downloadgentoo-7ec978e7f9bb50d0353c0bdacc8d278339f51805.tar.gz
gentoo-7ec978e7f9bb50d0353c0bdacc8d278339f51805.tar.bz2
gentoo-7ec978e7f9bb50d0353c0bdacc8d278339f51805.zip
kde-apps/konsole: Fix build with USE -X
Upstream commit 0aa39e22a2bb1bbcb8a02dfd6635ffe4d8a0bbb1 Bug: https://bugs.gentoo.org/813450 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/konsole/files/konsole-22.04.3-without_x11.patch46
-rw-r--r--kde-apps/konsole/konsole-22.04.3.ebuild5
2 files changed, 49 insertions, 2 deletions
diff --git a/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch b/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch
new file mode 100644
index 000000000000..ed396fcf20ab
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-22.04.3-without_x11.patch
@@ -0,0 +1,46 @@
+From 0aa39e22a2bb1bbcb8a02dfd6635ffe4d8a0bbb1 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 14:43:18 +0100
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+HAVE_X11 already exists and is set automagically so far, but using
+-DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
+as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 61ed70cd7..565682848 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -103,10 +103,13 @@ set_package_properties(KF5DocTools PROPERTIES DESCRIPTION
+ )
+
+ if(NOT APPLE)
+- find_package(X11)
+- set_package_properties(X11 PROPERTIES TYPE OPTIONAL)
++ option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
++ if (NOT WITHOUT_X11)
++ find_package(X11)
++ set_package_properties(X11 PROPERTIES TYPE OPTIONAL)
++ set(HAVE_X11 ${X11_FOUND})
++ endif()
+ endif()
+-set(HAVE_X11 ${X11_FOUND})
+
+ # Check for function GETPWUID
+ check_symbol_exists(getpwuid "pwd.h" HAVE_GETPWUID)
+--
+GitLab
+
diff --git a/kde-apps/konsole/konsole-22.04.3.ebuild b/kde-apps/konsole/konsole-22.04.3.ebuild
index cce03a53b3c6..d02a5534dca2 100644
--- a/kde-apps/konsole/konsole-22.04.3.ebuild
+++ b/kde-apps/konsole/konsole-22.04.3.ebuild
@@ -50,11 +50,12 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
- $(cmake_use_find_package X X11)
+ -DWITHOUT_X11=$(usex !X)
)
-
ecm_src_configure
}