summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-03-08 00:29:38 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-03-08 00:29:38 +0000
commit787368233fc9fac55095c5dc22fef47ff3c6f9ed (patch)
treebbc732d9858192ddff8a001d64ad88b3ce81a507
parent2024-03-07 23:34:09 UTC (diff)
parentgnome-extra/gucharmap: filter LTO (diff)
downloadgentoo-787368233fc9fac55095c5dc22fef47ff3c6f9ed.tar.gz
gentoo-787368233fc9fac55095c5dc22fef47ff3c6f9ed.tar.bz2
gentoo-787368233fc9fac55095c5dc22fef47ff3c6f9ed.zip
Merge updates from master
-rw-r--r--dev-libs/crossguid/Manifest1
-rw-r--r--dev-libs/crossguid/crossguid-0_pre20150817.ebuild47
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.0.4.ebuild7
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.1.1.ebuild7
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.1.2.ebuild7
-rw-r--r--gui-libs/vte-common/vte-common-0.74.2.ebuild5
-rw-r--r--gui-libs/vte/vte-0.74.2.ebuild5
-rw-r--r--x11-libs/vte/vte-0.68.0.ebuild7
-rw-r--r--x11-libs/vte/vte-0.74.2.ebuild5
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.44.1.ebuild7
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.50.1.ebuild5
11 files changed, 89 insertions, 14 deletions
diff --git a/dev-libs/crossguid/Manifest b/dev-libs/crossguid/Manifest
index 8c7c4899206d..cbf759e557c4 100644
--- a/dev-libs/crossguid/Manifest
+++ b/dev-libs/crossguid/Manifest
@@ -1 +1,2 @@
DIST crossguid-0.2.2_p20190529.tar.gz 141660 BLAKE2B 0f78a8ab5a420297f666b3b8156d499a9141ec25c049d4d2bb2ba594dc585abe211a149b83c605cce4f5530207231a065d5f3a87a0c969781de8c6381afa2527 SHA512 f0a80d8e99b10473bcfdfde3d1c5fd7b766959819f0d1c0595ac84ce46db9007a5fbfde9a55aca60530c46cb7f8ef4c7e472c6191559ded92f868589c141ccaf
+DIST crossguid-0_pre20150817.tar.gz 46569 BLAKE2B 3384b6c507c4713f5ea0d6012138f3543445a42c7353e934e267b91275f7cf75720a446f5fe24f334b1022946f856a65f5c158d0036c999c761e626c1e30062a SHA512 823ca301f1d3b78a778649cd9169194d98dd33c65cadd5bfb9f86429e82049c99c17e09f093b92675981d2aac2aac25b60cbb157fad57a3e1bada826edd8ba0a
diff --git a/dev-libs/crossguid/crossguid-0_pre20150817.ebuild b/dev-libs/crossguid/crossguid-0_pre20150817.ebuild
new file mode 100644
index 000000000000..9c61857673ce
--- /dev/null
+++ b/dev-libs/crossguid/crossguid-0_pre20150817.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/graeme-hill/crossguid.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="8f399e8bd4252be9952f3dfa8199924cc8487ca4"
+ SRC_URI="https://github.com/graeme-hill/crossguid/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+fi
+
+DESCRIPTION="Lightweight cross platform C++ GUID/UUID library"
+HOMEPAGE="https://github.com/graeme-hill/crossguid"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+# We use libuuid from util-linux.
+DEPEND="sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" #575544
+
+e() { echo "$@"; "$@"; }
+
+src_compile() {
+ e $(tc-getCXX) \
+ ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} \
+ -std=c++11 \
+ -c guid.cpp -o guid.o \
+ -DGUID_LIBUUID \
+ || die
+
+ e $(tc-getAR) rs libcrossguid.a guid.o || die
+}
+
+src_install() {
+ insinto /usr/include
+ doins guid.h
+ dolib.a libcrossguid.a
+}
diff --git a/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild b/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
index d5cda00d943f..b788ccd08f8a 100644
--- a/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit gnome2-utils meson python-any-r1 vala xdg
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
@@ -50,6 +50,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
diff --git a/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild b/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild
index 5eaba63f4112..74d609904765 100644
--- a/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-15.1.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome2-utils meson python-any-r1 vala xdg
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
@@ -52,6 +52,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
diff --git a/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild b/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
index 5eaba63f4112..74d609904765 100644
--- a/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-15.1.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome2-utils meson python-any-r1 vala xdg
+inherit flag-o-matic gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
@@ -52,6 +52,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926250)
+ filter-lto
+
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
diff --git a/gui-libs/vte-common/vte-common-0.74.2.ebuild b/gui-libs/vte-common/vte-common-0.74.2.ebuild
index d37ba2204f0f..bd3329c693d8 100644
--- a/gui-libs/vte-common/vte-common-0.74.2.ebuild
+++ b/gui-libs/vte-common/vte-common-0.74.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome.org meson python-any-r1
+inherit flag-o-matic gnome.org meson python-any-r1
DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
@@ -48,6 +48,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
local emesonargs=(
-Da11y=false
-Ddebugg=false
diff --git a/gui-libs/vte/vte-0.74.2.ebuild b/gui-libs/vte/vte-0.74.2.ebuild
index 1a44c617716e..403cbcb761c3 100644
--- a/gui-libs/vte/vte-0.74.2.ebuild
+++ b/gui-libs/vte/vte-0.74.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome.org meson python-any-r1 vala xdg
+inherit flag-o-matic gnome.org meson python-any-r1 vala xdg
DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
@@ -69,6 +69,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
local emesonargs=(
-Da11y=true
$(meson_use debug debugg)
diff --git a/x11-libs/vte/vte-0.68.0.ebuild b/x11-libs/vte/vte-0.68.0.ebuild
index 1fec0100cb79..31a008153e99 100644
--- a/x11-libs/vte/vte-0.68.0.ebuild
+++ b/x11-libs/vte/vte-0.68.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
-inherit gnome.org meson python-any-r1 vala xdg
+inherit flag-o-matic gnome.org meson python-any-r1 vala xdg
DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE https://gitlab.gnome.org/GNOME/vte"
@@ -69,6 +69,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
local emesonargs=(
-Da11y=true
$(meson_use debug debugg)
diff --git a/x11-libs/vte/vte-0.74.2.ebuild b/x11-libs/vte/vte-0.74.2.ebuild
index 30b7a48f852b..65965005d79e 100644
--- a/x11-libs/vte/vte-0.74.2.ebuild
+++ b/x11-libs/vte/vte-0.74.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome.org meson python-any-r1 vala xdg
+inherit flag-o-matic gnome.org meson python-any-r1 vala xdg
DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
@@ -69,6 +69,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
local emesonargs=(
-Da11y=true
$(meson_use debug debugg)
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.44.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.44.1.ebuild
index 702b8c3b97ff..d5716be44a7c 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-3.44.1.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.44.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+inherit flag-o-matic gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
DESCRIPTION="A terminal emulator for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/ https://gitlab.gnome.org/GNOME/gnome-terminal"
@@ -63,6 +63,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
local emesonargs=(
$(meson_use debug dbg)
-Ddocs=false
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.50.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.50.1.ebuild
index 54fcb6ddfd23..5f0fcaa45256 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-3.50.1.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.50.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+inherit flag-o-matic gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
DESCRIPTION="A terminal emulator for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal"
@@ -66,6 +66,9 @@ src_prepare() {
}
src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
local emesonargs=(
$(meson_use debug dbg)
-Ddocs=false