summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-21 06:20:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-21 06:32:27 +0200
commit77bdf33136dc7d9a6f75cb2afc19300fb366b774 (patch)
tree5e5a4c0b7f412bfeadf2ba03a595b1497a176082
parentdev-python/apispec: Bump to 6.7.0 (diff)
downloadgentoo-77bdf33136dc7d9a6f75cb2afc19300fb366b774.tar.gz
gentoo-77bdf33136dc7d9a6f75cb2afc19300fb366b774.tar.bz2
gentoo-77bdf33136dc7d9a6f75cb2afc19300fb366b774.zip
dev-python/mando: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mando/Manifest1
-rw-r--r--dev-python/mando/mando-0.8.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/mando/Manifest b/dev-python/mando/Manifest
index ffafc5ced1ea..f20c151f7952 100644
--- a/dev-python/mando/Manifest
+++ b/dev-python/mando/Manifest
@@ -1 +1,2 @@
DIST mando-0.7.1.gh.tar.gz 37802 BLAKE2B 1caf437248f1b1397888674fff0171680fd1d2cffd1d3394869edce4fef0d214fb52fc0eb7435ef162722f128f129f8d19385e65661914c51f78108b64f8db38 SHA512 a25dfd57e833416cbd64933ca3970712d28c2e2ed172091a0d0c082f486c707d0061afb071e3973e7e42b654d1a6e70f4909b1254fdef493471dc0ae9d3eb62b
+DIST mando-0.8.2.gh.tar.gz 37606 BLAKE2B 0f9ac55167a94df20f562ede072cebfd8db1a105409cf8aeb7b882e2239c47f50119dc3b3fd3fffeca48bc1e56377b91f7fbd52fe18b6ba2e5bc9da1bee8eebd SHA512 e389fe1935c7e7e6812e98b874c5760a5fb1178fcacefdbecd47b3a2fd41457647da424baaf0065367e3c63903116ac7ad2e6dd20fc428d2831290eafe3486d4
diff --git a/dev-python/mando/mando-0.8.2.ebuild b/dev-python/mando/mando-0.8.2.ebuild
new file mode 100644
index 000000000000..17b6b28f6ba4
--- /dev/null
+++ b/dev-python/mando/mando-0.8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create Python CLI apps with little to no effort at all!"
+HOMEPAGE="
+ https://mando.readthedocs.io/
+ https://github.com/rubik/mando/
+ https://pypi.org/project/mando/
+"
+SRC_URI="
+ https://github.com/rubik/mando/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}