summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-06-07 05:16:51 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-06-07 05:16:51 +0000
commit75b51541bc82b4679ed76e0c6adc909cd6036c8e (patch)
tree196e62c72ea95d7df6e14dc8910e235c12b026a0
parent2023-06-07 05:02:00 UTC (diff)
parentdev-python/sexpdata: Enable py3.12 (diff)
downloadgentoo-75b51541bc82b4679ed76e0c6adc909cd6036c8e.tar.gz
gentoo-75b51541bc82b4679ed76e0c6adc909cd6036c8e.tar.bz2
gentoo-75b51541bc82b4679ed76e0c6adc909cd6036c8e.zip
Merge updates from master
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.6.1.ebuild54
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.15.1.ebuild65
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.14.1.ebuild78
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-5.2.0.ebuild31
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.1.1.ebuild49
-rw-r--r--dev-python/sexpdata/Manifest1
-rw-r--r--dev-python/sexpdata/sexpdata-1.0.1.ebuild25
12 files changed, 308 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 1627093f0b16..a7e9f702a214 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -2,4 +2,5 @@ DIST Nuitka-1.5.5.tar.gz 4172962 BLAKE2B 403ea94d2e2311c036359e80a9923f80bdaec91
DIST Nuitka-1.5.6.tar.gz 4172386 BLAKE2B 62909f36529ecb487c0f5010e19c1dd7b2033b6b7a00bed5ad5efe26b500eccf27f76f526caefdfd59bf2a796c82770310b0b5cc90a7d2d7b2aff24b285f2885 SHA512 dccf931acbdf18d905d3e9299dcbf47f50f8780e9beabc9d6266bc0b8ed174c8e5cb762257477742f3745284b84495ec6ea77f3e9f4e280113dade4ec8e11c6e
DIST Nuitka-1.5.7.tar.gz 4179130 BLAKE2B 1918f0263edf89884658f49d0241f9993c6da8e0965f1a599ffed66cb635cea2729329183b1227a0b0e81f6d4e78c5ef1c1ca92c5148b635864e4caa536d0ab6 SHA512 aee0ec2d0a80b78262f3e4c972d1b156d41bea5323d3a12ed5afa47b41d6e372eb773968135217588a70f6b9ead2d215651999eb0e2f02d82e5996f89a9ea5e6
DIST Nuitka-1.5.8.tar.gz 4172897 BLAKE2B 1b4a50c6aacb6c41b4e068bc369a1c43839c8bca15c2786f3a37e8a3c6f2250e31c66192fd8ec79eb154e18e2f574819d27bc8ff3d80a97a248401966084d827 SHA512 963daea25553dc945e3f15020c7fcdabe6847ffd45167c84d68905dfe00630c132994587d1c9fc2076f19f29a46feab6b35ff15b9734d717ce50646192fa3039
+DIST Nuitka-1.6.1.tar.gz 4251346 BLAKE2B e35fd67cf6d5e30ad2f9c9271fbb3309e5520af77dc6c62f407378e68785f2dcaae92d1723d797178a5171407daec3eda64c00d80845d83ea8e3f49bd14c31cf SHA512 6f47cec56eefd14dd6902fbb59aebf5a46513b45cf774ddce9e5b71ce374befae17c4c86cccb92c70c8f18a2e8595e5e9a1e78fa7bb5a5008cd86289185f3f4f
DIST Nuitka-1.6.tar.gz 4222249 BLAKE2B c4451092bfeee7b632e5ebb7162ba46f9fad29d9837f4913948aafb84b4fc6e69845fe52886962c053b419ad3307e5929fa201a4aad5c7e80dd388e41f1504d6 SHA512 3951e354acc76b63c9d61267d4f14ee75d97bc3ec838326b33d59d2ad1809a7a33605e1a6544f6c5d23a57b97fe067b9ca154744ee90d5bc77c53b90b128ecbc
diff --git a/dev-python/Nuitka/Nuitka-1.6.1.ebuild b/dev-python/Nuitka/Nuitka-1.6.1.ebuild
new file mode 100644
index 000000000000..f1bec277226a
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.6.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index a30dab99c55c..77c0f944e482 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -2,3 +2,4 @@ DIST cx_Freeze-6.13.1.gh.tar.gz 1486207 BLAKE2B aa0151fed482714e41a859059f967295
DIST cx_Freeze-6.14.5.gh.tar.gz 1648095 BLAKE2B 81707d17c2118a8db4d768b2fbe83278c6b01509a5a1d3e7f3a41efaa29607fc4b254e9d545a4697b77d4932100f344a8013ac59084bb74d97d1b12cb927ec6e SHA512 52233a138da3250e97668a5c225e78b864bebaa43ea2b30de01af2de7739f48a25030e10d36ccec609240822de308ad030eaa26c2ede8b29318d2b30647cf1c8
DIST cx_Freeze-6.14.9.gh.tar.gz 1649748 BLAKE2B 08fefea6ed9610b672ca8a4a6e480cedf8fd75c967880e74f94c12368ec1ff71a9d34baae02342f7c4484e65beda5dc71dd39e13b8c340c5b7dd2e89b38ba0f1 SHA512 bfe3e5d3dcf96cff448b034a779b93c37dacda489ee4eabd92e8f4708c6d7a9fe2430bc512f40c6af8c6f851fff24a3626b80f10295af1357e4a58563474e8eb
DIST cx_Freeze-6.15.0.gh.tar.gz 1650636 BLAKE2B 9d99a78bc4d6b6498e10c54352a6fbfce3f2ee9bba9cc5b7fa752eba465d29355c6e4222e4f3c3012793820f435591f2e3e634e512765720d0c96a7799ab5998 SHA512 90fc3fba50ab7a9a263371fc9e57df768792b78175cd7ed39f2308b2a5e6bf0eb992616d29ff0d34c8bf040d167bac1882e0e1d2425d2f248e4de2e755c72503
+DIST cx_Freeze-6.15.1.gh.tar.gz 1651345 BLAKE2B 9c0c29f19e09184ad7b0a6954649c30fa1c941ff822b1c5ec745b1a6c7dd58fc77b06c070641a9200fc4910bdfc49937841ba2b547b16ec48f9fd30dfee6cd03 SHA512 d6540736d437242fd89fc34f0ff81691eebb455c0ddca8b90ee6ec436105d908e9fed580a08e23999f70b5e3aa2f2e66ee35eec092eecab0501e9b3117af23b3
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.15.1.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.15.1.ebuild
new file mode 100644
index 000000000000..e169791b001a
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.15.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="
+ https://cx-freeze.readthedocs.io/
+ https://github.com/marcelotduarte/cx_Freeze/
+ https://pypi.org/project/cx-Freeze/
+"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ ' 3.9)
+ dev-util/patchelf
+ virtual/libcrypt:=
+"
+BDEPEND="
+ test? (
+ app-arch/rpm
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pythonic dep on patchelf exec
+ sed -i -e '/patchelf/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # rpm test expects .pyc
+ local -x PYTHONDONTWRITEBYTECODE=
+ rm -rf cx_Freeze || die
+ epytest
+}
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 8326485c9a44..b403bc1cd86b 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1,4 @@
DIST fakeredis-2.12.1.tar.gz 97486 BLAKE2B 5207d9b946eb5720083b045e29b960cc2eb3ab5ed7b633f00106d0777186cfb02ecc10607d24a67d7b2eded35915e6710a4880f560e49fbca470c487ec0a2b87 SHA512 99e4e0bf7a4be9cc9dc96eecfe2fd1f106664bab2eff4f575468933809cf306c36237ebc9d86efdd9c0823e05a08d466f35a7e43359602b47c582ab16d7bb7ef
DIST fakeredis-2.13.0.tar.gz 98084 BLAKE2B c147332f2575be7f63aef48199920480d550efbadeee9de255b17cb9c7d6791a059ee3d4bdc500ecf44dcc22de6fdd11d170daf3e19de8e910833b1de12232c6 SHA512 30335e456f7ac2498fc175f9fd154a766064a05e6eb996df9d533412525a3d4279c9359ac5e43a2b9ec9bb1d653639aa10d4e1765a4e4c1bc84f764fa1efdb42
DIST fakeredis-2.14.0.tar.gz 101919 BLAKE2B 7582b3986bc7102a02a69a321e539dc15d425d918397e896eed9d544816697c55e938511ae69201eae3a5c1e814afe7f0c472d48a249be976178a7c0279472ae SHA512 a63b46420d9ca2348b0ed0f4ef2c0227a4dbc46efef2fae5beae2513cc77732be830669910f14d59ecb2f1fa3b698e29855658239fea4ff458c4ba62fd9fa4cb
+DIST fakeredis-2.14.1.tar.gz 101789 BLAKE2B 2e38319aa8bb23c9cd2196d8dbcf489fead785bffa3b464b7e420f28b247c911ea9f3775328f8fec7c26b1a77e32d6a21acf627fe7b603f311b0f3820fa06b54 SHA512 71b7f034ad5ccdd569052a82d2e15ec21db4b5a26bc5c660f76bb88c0b7aaa252234e899644dfd63086aaf8a9400ea13acc6439fdca08f84c8392949815f33d2
diff --git a/dev-python/fakeredis/fakeredis-2.14.1.ebuild b/dev-python/fakeredis/fakeredis-2.14.1.ebuild
new file mode 100644
index 000000000000..10e805e1986c
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.14.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index bafc1a429dbb..58c1c5ba4fa2 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-5.1.0.gh.tar.gz 40178 BLAKE2B f290afa72d71cb2f88793aaa31aa059a603375e91b310c3ca9180ed5626c589f3d91ae1961db15e256b01bd019b8e59dd48be45ff96683707c05ee9170dfed84 SHA512 64c71f5365638f3bdb435ac2d7405bd1e7a3ebe95fee97469c64bee63ad9850d45781756ebd59942c70780830fbb0519874908d2894e227acadedb5120c3b9ab
+DIST pylast-5.2.0.tar.gz 41137 BLAKE2B a7742bd2a23e281ab1a12d0198c74f1b5d8302700cb58490a5b3bff693098c8c3bf548ed52ca7f8cefecbcc10972c57da9ca04fe1d791141aacbb84ead9592ed SHA512 1ae76ff4ec6f009388abfcf8525f1c19e47cbabaace1f5e8c518819d0856168d855b789e3c08a9699dd7ab88ebfc7c3ab81c2d74a0fa1fd210450741b99da8c6
diff --git a/dev-python/pylast/pylast-5.2.0.ebuild b/dev-python/pylast/pylast-5.2.0.ebuild
new file mode 100644
index 000000000000..51e6b2a6ab46
--- /dev/null
+++ b/dev-python/pylast/pylast-5.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 7028ef15de82..0e591174a695 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,2 +1,3 @@
DIST rapidfuzz-3.0.0.tar.gz 1230857 BLAKE2B b15bcca17288cc428b485b0c6e1d322027eee5c8c0261b7f0240e4f5908ff2d53e05124855213a1923d96ec7537b75263c17f220bfaf792ab92f2f455d761027 SHA512 bafdb6045baa78154026dc0eb2498eb0031f03c36e8b17a9219d6e0c55041a9b6c164f4fcc0523480903fece0ab4e2e50a8f969a52b6934fcfbad80d8eadba25
DIST rapidfuzz-3.1.0.tar.gz 1251075 BLAKE2B 3a9e3dd4105910ad393efe795c4b7fe603f77ba922a6fa30a7b31f2f14a708651490c1afccbc9a5f217a348a8c20f779172a600331be51298ef746b0ade819ea SHA512 ff583a7b87d64b3b00d785533af3ba76d1ffa5dbc65111f4b72c2e7d84a43fe149e2f5546c6af130617e58e35556a7b2143ff6ed24dcf199d24b81ff7b46abc0
+DIST rapidfuzz-3.1.1.tar.gz 1279245 BLAKE2B bd3fa008a29fa9d7c2af8708d498e1b6f4497bf23c42d3692a9d5e61ab605b4511fe26213f405cd6b1a9531f106664577fb741eac1da0a8b70c5ef7b2879b3f8 SHA512 d83e07fd3a0b3085e6b93ddf53207110ae329241c23091c561f07fbcabf630a291c4fda3c5bd2baf91d80f5426ac0cdaeda92e87b617214594bfb67b787b85db
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.1.1.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.1.1.ebuild
new file mode 100644
index 000000000000..865d71a0d742
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-3.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/maxbachmann/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-2.0.0
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/rapidfuzz_capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+ # remove bundled libraries
+ rm -r extern || die
+
+ distutils-r1_src_prepare
+
+ export RAPIDFUZZ_BUILD_EXTENSION=1
+}
diff --git a/dev-python/sexpdata/Manifest b/dev-python/sexpdata/Manifest
index f073d38fc5bb..3b9a667c8a58 100644
--- a/dev-python/sexpdata/Manifest
+++ b/dev-python/sexpdata/Manifest
@@ -1 +1,2 @@
DIST sexpdata-1.0.0.gh.tar.gz 16540 BLAKE2B 6babe7b098d9e66bc9cbd6c8a8e91b8d9743ee93ca6745f626421ecab498fc70a02e16e5e3973b97b886feaf4042489f6903736c43f4264252122e1f190b9fc4 SHA512 1ef72d6441907ea3eae00b6d89344281930ac3ad82aee429fa45d2f876aef890019b0bae0241d1670d8f9842dd47a1be76d33dd510b38b09b904334a3924bb56
+DIST sexpdata-1.0.1.gh.tar.gz 17298 BLAKE2B 41132d8d2af06efdae024cbb8e05e9fa4fcb03ffb0af5f1b04df2fae8ed3a5bd8a45f93951cf575edf3facb0f9867a6e78d82ab166f0ec89df4a13b0827d7213 SHA512 e945eeec3743d92a76748c6fe22ca510ec5df6a3f2249a0d8020ae84854c50940add39437c680d3e44aafee7d9bb442db875b46afd290bfb6e8d31e16c6da9da
diff --git a/dev-python/sexpdata/sexpdata-1.0.1.ebuild b/dev-python/sexpdata/sexpdata-1.0.1.ebuild
new file mode 100644
index 000000000000..dd901557ed02
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="
+ https://github.com/jd-boyd/sexpdata/
+ https://pypi.org/project/sexpdata/
+"
+SRC_URI="
+ https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+distutils_enable_tests pytest