summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-03-14 23:48:24 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-03-14 23:48:24 +0000
commit738a7a9cc9904880b28565f5d115b4461a4a1949 (patch)
treed66ee1af28dda56dcc76b95c3595092afbd55bca
parent2020-03-14 23:08:53 UTC (diff)
parentflag-o-matic.eclass: add assertions around argument counts (diff)
downloadgentoo-738a7a9cc9904880b28565f5d115b4461a4a1949.tar.gz
gentoo-738a7a9cc9904880b28565f5d115b4461a4a1949.tar.bz2
gentoo-738a7a9cc9904880b28565f5d115b4461a4a1949.zip
Merge updates from master
-rw-r--r--eclass/flag-o-matic.eclass25
-rw-r--r--net-im/pidgin/pidgin-2.13.0-r8.ebuild21
2 files changed, 31 insertions, 15 deletions
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 5cc58f9e9392..39dae290af02 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -392,6 +392,7 @@ filter-mfpmath() {
# Strip *FLAGS of everything except known good/safe flags. This runs over all
# flags returned by all_flag_vars().
strip-flags() {
+ [[ $# -ne 0 ]] && die "strip-flags takes no arguments"
local x y var
local ALLOWED_FLAGS
@@ -446,30 +447,30 @@ test-flag-PROG() {
case "${lang}" in
# compiler/assembler only
c)
- in_ext='.c'
+ in_ext='c'
in_src='int main(void) { return 0; }'
cmdline_extra+=(-xc -c)
;;
c++)
- in_ext='.cc'
+ in_ext='cc'
in_src='int main(void) { return 0; }'
cmdline_extra+=(-xc++ -c)
;;
f77)
- in_ext='.f'
+ in_ext='f'
# fixed source form
in_src=' end'
cmdline_extra+=(-xf77 -c)
;;
f95)
- in_ext='.f90'
+ in_ext='f90'
in_src='end'
cmdline_extra+=(-xf95 -c)
;;
# C compiler/assembler/linker
c+ld)
- in_ext='.c'
+ in_ext='c'
in_src='int main(void) { return 0; }'
cmdline_extra+=(-xc)
;;
@@ -477,7 +478,7 @@ test-flag-PROG() {
local test_in=${T}/test-flag.${in_ext}
local test_out=${T}/test-flag.exe
- printf "%s\n" "${in_src}" > "${test_in}" || return 1
+ printf "%s\n" "${in_src}" > "${test_in}" || die "Failed to create '${test_in}'"
local cmdline=(
"${comp[@]}"
@@ -618,6 +619,7 @@ test_version_info() {
# @DESCRIPTION:
# Strip {C,CXX,F,FC}FLAGS of any flags not supported by the active toolchain.
strip-unsupported-flags() {
+ [[ $# -ne 0 ]] && die "strip-unsupported-flags takes no arguments"
export CFLAGS=$(test-flags-CC ${CFLAGS})
export CXXFLAGS=$(test-flags-CXX ${CXXFLAGS})
export FFLAGS=$(test-flags-F77 ${FFLAGS})
@@ -630,6 +632,7 @@ strip-unsupported-flags() {
# @DESCRIPTION:
# Find and echo the value for a particular flag. Accepts shell globs.
get-flag() {
+ [[ $# -ne 1 ]] && die "usage: <flag>"
local f var findflag="$1"
# this code looks a little flaky but seems to work for
@@ -648,18 +651,11 @@ get-flag() {
return 1
}
-has_m64() {
- die "${FUNCNAME}: don't use this anymore"
-}
-
-has_m32() {
- die "${FUNCNAME}: don't use this anymore"
-}
-
# @FUNCTION: replace-sparc64-flags
# @DESCRIPTION:
# Sets mcpu to v8 and uses the original value as mtune if none specified.
replace-sparc64-flags() {
+ [[ $# -ne 0 ]] && die "replace-sparc64-flags takes no arguments"
local SPARC64_CPUS="ultrasparc3 ultrasparc v9"
if [ "${CFLAGS/mtune}" != "${CFLAGS}" ]; then
@@ -743,6 +739,7 @@ raw-ldflags() {
# @FUNCTION: no-as-needed
# @RETURN: Flag to disable asneeded behavior for use with append-ldflags.
no-as-needed() {
+ [[ $# -ne 0 ]] && die "no-as-needed takes no arguments"
case $($(tc-getLD) -v 2>&1 </dev/null) in
*GNU*) # GNU ld
echo "-Wl,--no-as-needed" ;;
diff --git a/net-im/pidgin/pidgin-2.13.0-r8.ebuild b/net-im/pidgin/pidgin-2.13.0-r8.ebuild
index c29e0e696739..2f3544b9a15a 100644
--- a/net-im/pidgin/pidgin-2.13.0-r8.ebuild
+++ b/net-im/pidgin/pidgin-2.13.0-r8.ebuild
@@ -6,7 +6,7 @@ EAPI=7
GENTOO_DEPEND_ON_PERL=no
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit autotools flag-o-matic toolchain-funcs multilib perl-module python-single-r1 xdg
+inherit autotools gnome2-utils flag-o-matic toolchain-funcs multilib perl-module python-single-r1 xdg
DESCRIPTION="GTK Instant Messenger client"
HOMEPAGE="http://pidgin.im/"
@@ -246,6 +246,8 @@ src_configure() {
}
src_install() {
+ # setting this here because gnome2.eclass is not EAPI-7 ready
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
default
if use gtk ; then
@@ -279,3 +281,20 @@ src_test() {
# make default build logs slightly more useful
emake check VERBOSE=1
}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}