summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-10-01 05:16:43 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-10-01 05:16:43 +0000
commit72957825a88b10ab83dfa670b0184431fd49c25e (patch)
tree0ffe1786c048096aeaeadc7cab4cb496224f95d2
parent2022-10-01 05:01:59 UTC (diff)
parentperl-module.eclass: fix src_test docs (diff)
downloadgentoo-72957825a88b10ab83dfa670b0184431fd49c25e.tar.gz
gentoo-72957825a88b10ab83dfa670b0184431fd49c25e.tar.bz2
gentoo-72957825a88b10ab83dfa670b0184431fd49c25e.zip
Merge updates from master
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-3.2.0-r4.ebuild2
-rw-r--r--dev-libs/unibilium/unibilium-2.1.1-r1.ebuild2
-rw-r--r--dev-util/bats/Manifest1
-rw-r--r--dev-util/bats/bats-1.8.0.ebuild43
-rw-r--r--eclass/perl-module.eclass2
5 files changed, 47 insertions, 3 deletions
diff --git a/app-crypt/tpm2-tss/tpm2-tss-3.2.0-r4.ebuild b/app-crypt/tpm2-tss/tpm2-tss-3.2.0-r4.ebuild
index 1e76e7ee9d5f..4c742553423a 100644
--- a/app-crypt/tpm2-tss/tpm2-tss-3.2.0-r4.ebuild
+++ b/app-crypt/tpm2-tss/tpm2-tss-3.2.0-r4.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar
LICENSE="BSD-2"
SLOT="0/3"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+KEYWORDS="~amd64 arm ~arm64 ~ppc64 ~riscv ~x86"
IUSE="doc +fapi +openssl mbedtls static-libs test"
RESTRICT="!test? ( test )"
diff --git a/dev-libs/unibilium/unibilium-2.1.1-r1.ebuild b/dev-libs/unibilium/unibilium-2.1.1-r1.ebuild
index faef5821c970..defba3269a51 100644
--- a/dev-libs/unibilium/unibilium-2.1.1-r1.ebuild
+++ b/dev-libs/unibilium/unibilium-2.1.1-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/neovim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3+ MIT"
SLOT="0/4"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~x64-macos"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~x64-macos"
BDEPEND="dev-lang/perl"
diff --git a/dev-util/bats/Manifest b/dev-util/bats/Manifest
index 7a53136f8e17..45327d4db02a 100644
--- a/dev-util/bats/Manifest
+++ b/dev-util/bats/Manifest
@@ -1,2 +1,3 @@
DIST bats-1.5.0.tar.gz 108052 BLAKE2B 68bba9d263e4206ead7039da2b09c5211c834445efdf429dca6c53acc5409de1052ce7ffa9143e732d3aeaeb6ea6dcaf9b419adc02776e601545557dea776e36 SHA512 e0386fb32214db67ae001a2040c44277988af7fa909a820843237c7d47eedfa4e370238d5b2d06a4667b874cad4b00f2cd14624b1bc45628192e5d693bd5073a
DIST bats-1.7.0.tar.gz 124590 BLAKE2B eab244f018ec568c280d20540013eaa9e5a8d84ead8e23b9db2f8d18bbd7ebd43c60ab38cee008e0d016a219f16aa6f52733d5f891ffb8733ca8576a5738dd22 SHA512 22ca033e004087cabf645417ea184d2e1a0704575f702a94de5b63b3af6d1fd4caaecad86a5cb49687c606728d875dd13b4d5de66599b83324980fdc71cb92e2
+DIST bats-1.8.0.tar.gz 144262 BLAKE2B 4f12d4c5211535f11a3cbc856233a59e0c3bcd892c6f021055458960b450f908f3b865cee38ad2c2569be41ab81e2fdb973003be85890f70f8894c8a17812b42 SHA512 e51ea85bf2f455881a90220d783b4a261bd91331326a7184eb31ea9adf31c18a79a062fd77af12d082ccef953d992382ec19ca9a27395b2a03c4a9a120bdda76
diff --git a/dev-util/bats/bats-1.8.0.ebuild b/dev-util/bats/bats-1.8.0.ebuild
new file mode 100644
index 000000000000..d42eecab71cd
--- /dev/null
+++ b/dev-util/bats/bats-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing optfeature
+
+MY_PN="bats-core"
+DESCRIPTION="Bats-core: Bash Automated Testing System"
+HOMEPAGE="https://github.com/bats-core/bats-core/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="app-shells/bash:*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_test() {
+ local my_jobs=$(makeopts_jobs)
+ if ! command -v parallel >/dev/null; then
+ my_jobs=1
+ fi
+ bin/bats --tap --jobs "${my_jobs}" test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/${MY_PN}
+ doexe libexec/${MY_PN}/*
+ exeinto /usr/lib/${MY_PN}
+ doexe lib/${MY_PN}/*
+ dobin bin/${PN}
+
+ dodoc README.md
+ doman man/${PN}.1 man/${PN}.7
+}
+
+pkg_postinst() {
+ optfeature "Parallel Execution" sys-process/parallel
+}
diff --git a/eclass/perl-module.eclass b/eclass/perl-module.eclass
index 25490c25058a..d4f6bdc5191e 100644
--- a/eclass/perl-module.eclass
+++ b/eclass/perl-module.eclass
@@ -320,7 +320,7 @@ perl-module_src_compile() {
# accepts the same values as DIST_TEST. If set, it overrides DIST_TEST
# completely. DO NOT USE THIS IN EBUILDS!
-# @FUNCTION: perl-module_src-test
+# @FUNCTION: perl-module_src_test
# @DESCRIPTION:
# This code attempts to work out your threadingness and runs tests
# according to the settings of DIST_TEST using Test::Harness.