summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-09-30 13:58:20 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-30 22:13:35 +0200
commit61f3f3ab751702016207e82b20b5be7df878e1ad (patch)
tree88efecd11dd848d965a7ecafe025fde70b480011
parentx11-wm/mutter: Fix non-wayland build (#667244 by Denis Descheneaux) (diff)
downloadgentoo-61f3f3ab751702016207e82b20b5be7df878e1ad.tar.gz
gentoo-61f3f3ab751702016207e82b20b5be7df878e1ad.tar.bz2
gentoo-61f3f3ab751702016207e82b20b5be7df878e1ad.zip
app-benchmarks/stress: bump to EAPI=7
Closes: https://bugs.gentoo.org/667192 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9999
-rw-r--r--app-benchmarks/stress/metadata.xml13
-rw-r--r--app-benchmarks/stress/stress-1.0.4-r2.ebuild21
2 files changed, 33 insertions, 1 deletions
diff --git a/app-benchmarks/stress/metadata.xml b/app-benchmarks/stress/metadata.xml
index 6f49eba8f496..486cfdbaa8af 100644
--- a/app-benchmarks/stress/metadata.xml
+++ b/app-benchmarks/stress/metadata.xml
@@ -1,5 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Stress is a deliberately simple workload generator for POSIX systems.
+ It imposes a configurable amount of CPU, memory, I/O, and disk stress on the system.
+ </longdescription>
</pkgmetadata>
diff --git a/app-benchmarks/stress/stress-1.0.4-r2.ebuild b/app-benchmarks/stress/stress-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..41adb494631e
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.4-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="A deliberately simple workload generator for POSIX systems"
+HOMEPAGE="https://people.seas.harvard.edu/~apw/stress"
+SRC_URI="https://people.seas.harvard.edu/~apw/${PN}/${P}.tar.gz -> ${P}-r1.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}