summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:09:03 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:08 +0300
commit58296888491e6c6bc8b1f79c45150888d6d722c4 (patch)
tree0ff42b4c2fbe086b6cecf0c95b4a6a67acb2629a
parentmate-base/mate-panel: drop 1.27.2, 1.27.3 (diff)
downloadgentoo-58296888491e6c6bc8b1f79c45150888d6d722c4.tar.gz
gentoo-58296888491e6c6bc8b1f79c45150888d6d722c4.tar.bz2
gentoo-58296888491e6c6bc8b1f79c45150888d6d722c4.zip
mate-base/mate-panel: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.28.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index b5b49a453e65..8a932592abbe 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.26.4.tar.xz 3262004 BLAKE2B 6561bdfe79f8b9f92db7fac1b3857bd0fb49b5220910f0aebc6eff443233c8cf2bdee8d21ffbdf88869ef1a99b3ffb96e0e22027099ef59d595ff596d79efdc3 SHA512 90db23f46dab88cb242aafb32737519d16e035843c2ca81da131ff3134a61b08772f19aa9900dbfbd00dcf4579cee3970765aa3fb461664abd1dd3babb8f6ea2
+DIST mate-panel-1.28.0.tar.xz 3282036 BLAKE2B 141dd58441b4dadd78e10a27e682b2a306e408151db50f9a57d2d480f74ab84f68efee16ead018c4185723d1af5b1abdf030a7841c0c522a7ae4e5b8377b4d8e SHA512 ef68fed6c9c60f7da11b5606e0b2669015f7f823ba392393c6e5d0705fe14ee21ffd13194879628cafacd319b83009d45db5949d2a42b9f5b07e10aeb6f8b308
diff --git a/mate-base/mate-panel/mate-panel-1.28.0.ebuild b/mate-base/mate-panel/mate-panel-1.28.0.ebuild
new file mode 100644
index 000000000000..52a917988a26
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.28.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/dconf-editor-43.0
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.26.0:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir="${EPREFIX}"/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}