summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2018-01-20 18:09:46 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2018-01-20 18:09:46 +0000
commit53deb260ec4a767185d02085c65efb0f4f3c2cde (patch)
treed763ba42b75dc8da17b9feddc64d5617f7d77190
parent2018-01-20 17:38:30 UTC (diff)
parentsys-libs/glibc: Test for IA32 emulation before building amd64 multilib glibc,... (diff)
downloadgentoo-53deb260ec4a767185d02085c65efb0f4f3c2cde.tar.gz
gentoo-53deb260ec4a767185d02085c65efb0f4f3c2cde.tar.bz2
gentoo-53deb260ec4a767185d02085c65efb0f4f3c2cde.zip
Merge updates from master
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild4
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild17
2 files changed, 18 insertions, 3 deletions
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index 8ed5edc7bbf4..788cb937f34c 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -35,9 +35,7 @@ src_prepare() {
src_configure() {
econf \
- --bindir="${EPREFIX}"/sbin \
--with-statedir="${EPREFIX}"/run/${PN} \
- --with-rpcuser=root \
--with-systemdsystemunitdir=$(usex systemd "$(systemd_get_unitdir)" "no") \
$(use_enable tcpd libwrap) \
$(use_enable debug) \
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 522a3674fe0c..81dadb177948 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -701,6 +701,23 @@ pkg_pretend() {
fi
done
fi
+
+ # ABI-specific checks follow here. Hey, we have a lot more specific conditions that
+ # we test for...
+ if ! is_crosscompile ; then
+
+ if use amd64 && use multilib ; then
+ ebegin "Checking that IA32 emulation is enabled in the running kernel"
+ echo 'int main(){return 0;}' > "${T}/check-ia32-emulation.c"
+ "${CC-${CHOST}-gcc}" ${CFLAGS_x86} "${T}/check-ia32-emulation.c" -o "${T}/check-ia32-emulation.elf32"
+ "${T}/check-ia32-emulation.elf32"
+ local STAT=$?
+ rm -f "${T}/check-ia32-emulation.elf32"
+ eend $STAT
+ [ $STAT -eq 0 ] || die "CONFIG_IA32_EMULATION must be enabled in the kernel to compile a multilib glibc."
+ fi
+
+ fi
}
# todo: shouldn't most of these checks be called also in src_configure again?
# (since consistency is not guaranteed between pkg_ and src_)