summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-19 08:05:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-19 08:57:16 +0200
commit3e51fc8dcc6eca46bfa25c8f0ba8ecca398a08ee (patch)
tree61a9fbc4eb95f2aa72fc28f61d30bea48be98356
parentdev-python/click: Bump to 8.1.6 (diff)
downloadgentoo-3e51fc8dcc6eca46bfa25c8f0ba8ecca398a08ee.tar.gz
gentoo-3e51fc8dcc6eca46bfa25c8f0ba8ecca398a08ee.tar.bz2
gentoo-3e51fc8dcc6eca46bfa25c8f0ba8ecca398a08ee.zip
dev-python/pyjwt: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 6085b7ff4646..dae0e7dbe709 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1 +1,2 @@
DIST PyJWT-2.7.0.tar.gz 77902 BLAKE2B ff1e1c5dfd301a86a42eb6b4b2d6d900b15acdf60875bac49aee980b75b724292ff48b169cd2b9708388860ea93fd94f3cbf891f4606bfeb544e07a14c328bb8 SHA512 0aa886dfdc3c668b45e1c649cc3fbe3c2dec7476f46bd361ff74f6e9c7ea0ad40306a8a8ae84bfd63fe1c1364302b8aa69943013c951b32c9f24e4782b94ca8d
+DIST PyJWT-2.8.0.tar.gz 78313 BLAKE2B b5031ec0ea672ef2dffc077aba6c781a20a7497257a16241841c0e0158017370581e3c9785d930772290c25fc9029e71a5d8744d999b135b29715a4f35720508 SHA512 74e74cf8c78494a9e51a2a186347361388031d5c0d0864df2a5d051621d9d31dff617ab1d7ebb4a829cc7d409d196e1bdb3b361ec888b6c14f1abea77544475e
diff --git a/dev-python/pyjwt/pyjwt-2.8.0.ebuild b/dev-python/pyjwt/pyjwt-2.8.0.ebuild
new file mode 100644
index 000000000000..612aa0783eac
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="PyJWT"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="
+ https://github.com/jpadilla/pyjwt/
+ https://pypi.org/project/PyJWT/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !dev-python/python-jwt
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_jwks_client.py::TestPyJWKClient::test_get_jwt_set_sslcontext_default
+)
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}