summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-26 15:14:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-26 15:16:45 +0200
commit3e21439d4aabcc18687e5ee0a04ae29be8e59423 (patch)
tree82368ee0a49547e0dde2f552250dd57890c52d26
parentxfce-base/xfdesktop: Remove old (diff)
downloadgentoo-3e21439d4aabcc18687e5ee0a04ae29be8e59423.tar.gz
gentoo-3e21439d4aabcc18687e5ee0a04ae29be8e59423.tar.bz2
gentoo-3e21439d4aabcc18687e5ee0a04ae29be8e59423.zip
xfce-base/xfdesktop: Backport the settings problem patch
Closes: https://bugs.gentoo.org/904468 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch25
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.19.2-r1.ebuild (renamed from xfce-base/xfdesktop/xfdesktop-4.19.2.ebuild)5
2 files changed, 30 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch b/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch
new file mode 100644
index 000000000000..e384ef578a1d
--- /dev/null
+++ b/xfce-base/xfdesktop/files/xfdesktop-4.19.2-settings.patch
@@ -0,0 +1,25 @@
+From 439bf8a8cd36796c33ae0b413641338417c9a911 Mon Sep 17 00:00:00 2001
+From: "Brian J. Tarricone" <brian@tarricone.org>
+Date: Thu, 25 Apr 2024 23:28:24 -0700
+Subject: [PATCH] Fix some default settings not being applied on startup
+
+Closes #242.
+---
+ src/xfce-desktop.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/xfce-desktop.c b/src/xfce-desktop.c
+index e79e83305..b4f837ef5 100644
+--- a/src/xfce-desktop.c
++++ b/src/xfce-desktop.c
+@@ -731,6 +731,7 @@ xfce_desktop_class_init(XfceDesktopClass *klass)
+ widget_class->style_updated = xfce_desktop_style_updated;
+
+ #define XFDESKTOP_PARAM_FLAGS (G_PARAM_READWRITE \
++ | G_PARAM_CONSTRUCT \
+ | G_PARAM_STATIC_NAME \
+ | G_PARAM_STATIC_NICK \
+ | G_PARAM_STATIC_BLURB)
+--
+GitLab
+
diff --git a/xfce-base/xfdesktop/xfdesktop-4.19.2.ebuild b/xfce-base/xfdesktop/xfdesktop-4.19.2-r1.ebuild
index eba432b23304..c5ec981ee642 100644
--- a/xfce-base/xfdesktop/xfdesktop-4.19.2.ebuild
+++ b/xfce-base/xfdesktop/xfdesktop-4.19.2-r1.ebuild
@@ -44,6 +44,11 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ # https://gitlab.xfce.org/xfce/xfdesktop/-/issues/242
+ "${FILESDIR}/${P}-settings.patch"
+)
+
src_configure() {
local myconf=(
$(use_enable wayland)