summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-07 14:11:47 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-07 14:12:21 -0700
commit3cfff63ff50bc1493bd14a905a1b383f194b62ab (patch)
tree9756180a372a6ca5be4677aa4a9dceb9e1ea8dd2
parentx11-apps/xclock: Version bump to 1.1.1 (diff)
downloadgentoo-3cfff63ff50bc1493bd14a905a1b383f194b62ab.tar.gz
gentoo-3cfff63ff50bc1493bd14a905a1b383f194b62ab.tar.bz2
gentoo-3cfff63ff50bc1493bd14a905a1b383f194b62ab.zip
x11-apps/xdpyinfo: Version bump to 1.3.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-apps/xdpyinfo/Manifest1
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-apps/xdpyinfo/Manifest b/x11-apps/xdpyinfo/Manifest
index 1a78785a3fa4..c2f08be00f63 100644
--- a/x11-apps/xdpyinfo/Manifest
+++ b/x11-apps/xdpyinfo/Manifest
@@ -1 +1,2 @@
DIST xdpyinfo-1.3.2.tar.bz2 141351 BLAKE2B b2dee4f424dee902c31430b8843c14d6836508ee0125db7de41f5e9faef1732dea571e90b37638cc90dabd3995a0ceb5e4094707138b7e066ee1ae856258503c SHA512 2c9097c13778c7a7fe5a9b3ee04b28512ff6028231eca91ecdf6104c742be470678920d37a4f540fece7e39dccbea34802271f359ab80618027b2856c8912e7d
+DIST xdpyinfo-1.3.3.tar.xz 137088 BLAKE2B 8fdf49e65ac05ab27672ef2044044353f8bbfe0c8bf6135e71b9fbd45b3cb643f5794977802cbb7a44cfe9d20905b5e74b0cc41829c9fef837f32c81bb05ea2f SHA512 47fe0821bc64145876853712ebd7c0af80111c243813615b892429021cc9a53abd38c4684551ae300cb5a4eacdd3d26e2c93e789ed91a948b20e2c37cd2d2442
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
new file mode 100644
index 000000000000..1be291758419
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xf86misc
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+ xorg-3_src_configure
+}