summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-06 19:48:31 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-09 21:48:19 +0100
commit31acade3cc7dccf6a2563975591897853d50910d (patch)
tree806eb5706e1e9260530b0476510e0aa6d745c94c
parentnet-misc/wicd: Bump to 1.7.4 (diff)
downloadgentoo-31acade3cc7dccf6a2563975591897853d50910d.tar.gz
gentoo-31acade3cc7dccf6a2563975591897853d50910d.tar.bz2
gentoo-31acade3cc7dccf6a2563975591897853d50910d.zip
dev-perl/LWP-Online: Added to tree at version 1.80.0-r2
Was previously maintained in perl-experimental by Torsten Veller and Kent Fredric since Sept 2009. - Updated for EAPI6 - Patched for NO_NETWORK_TESTING mechanics - Patch includes runtime NO_NETWORK_TESTING mechanics as per https://rt.cpan.org/Public/Bug/Display.html?id=112728 as this specific path is utilized in other CPAN Modules for their network-testing code. - Added as -r2 to be newer than overlay Package-Manager: portage-2.2.27
-rw-r--r--dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild25
-rw-r--r--dev-perl/LWP-Online/Manifest1
-rw-r--r--dev-perl/LWP-Online/files/1.08-no-network.patch30
-rw-r--r--dev-perl/LWP-Online/metadata.xml13
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild b/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
new file mode 100644
index 000000000000..9b37fda32c6f
--- /dev/null
+++ b/dev-perl/LWP-Online/LWP-Online-1.80.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Does your process have access to the web"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# https://rt.cpan.org/Public/Bug/Display.html?id=112728
+PATCHES=("${FILESDIR}/${DIST_VERSION}-no-network.patch")
+# LWP::Simple -> libwww-perl
+RDEPEND="
+ >=dev-perl/libwww-perl-5.805.0
+ >=dev-perl/URI-1.350.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.420.0 )
+"
diff --git a/dev-perl/LWP-Online/Manifest b/dev-perl/LWP-Online/Manifest
new file mode 100644
index 000000000000..71901e4f45d5
--- /dev/null
+++ b/dev-perl/LWP-Online/Manifest
@@ -0,0 +1 @@
+DIST LWP-Online-1.08.tar.gz 32250 SHA256 e26f91b7781f2a6d3b8c364961d5e74fae660d202dc97e3c88288030d736ce9c SHA512 2b255f60ee6521757ce3d49cc0720e3985ff17e3db7b7868ced6a9e1c5444dc067c80b7d34dbe7be9679c134f3de1dbe0e9421a1a20ff388c812aacd1d964497 WHIRLPOOL 68a2635d8086357c5d4564b5846ffffb0ac8337145d405f12d3e6b5a09dd0fec0948d654714f291bf3fc822289ba8c6839f644b08d48757746a88d8e27bed128
diff --git a/dev-perl/LWP-Online/files/1.08-no-network.patch b/dev-perl/LWP-Online/files/1.08-no-network.patch
new file mode 100644
index 000000000000..e6b0419eef09
--- /dev/null
+++ b/dev-perl/LWP-Online/files/1.08-no-network.patch
@@ -0,0 +1,30 @@
+diff -Naur LWP-Online-1.08/lib/LWP/Online.pm LWP-Online-1.08b/lib/LWP/Online.pm
+--- LWP-Online-1.08/lib/LWP/Online.pm 2011-07-08 07:02:25.000000000 +0000
++++ LWP-Online-1.08b/lib/LWP/Online.pm 2016-03-06 06:20:12.351333667 +0000
+@@ -167,6 +167,9 @@
+ my @functions = grep { $_ ne ':skip_all' } @_;
+ if ( @functions != @_ ) {
+ require Test::More;
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ Test::More->import( skip_all => 'NO_NETWORK_TESTING set' );
++ }
+ unless ( online() ) {
+ Test::More->import( skip_all => 'Test requires a working internet connection' );
+ }
+diff -Naur LWP-Online-1.08/t/02_main.t LWP-Online-1.08b/t/02_main.t
+--- LWP-Online-1.08/t/02_main.t 2011-07-08 07:02:25.000000000 +0000
++++ LWP-Online-1.08b/t/02_main.t 2016-03-06 06:14:41.521243616 +0000
+@@ -7,7 +7,12 @@
+ $| = 1;
+ $^W = 1;
+ }
+-
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ require Test::More;
++ Test::More->import('skip_all', "NO_NETWORK_TESTING set");
++ }
++}
+ use Test::More tests => 6;
+ use LWP::Online 'online', 'offline';
+
diff --git a/dev-perl/LWP-Online/metadata.xml b/dev-perl/LWP-Online/metadata.xml
new file mode 100644
index 000000000000..d26c68e43613
--- /dev/null
+++ b/dev-perl/LWP-Online/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>LWP::Online is a Perl Module for testing the state of internet accessibility</longdescription>
+ <upstream>
+ <remote-id type="cpan">LWP-Online</remote-id>
+ <remote-id type="cpan-module">LWP::Online</remote-id>
+ </upstream>
+</pkgmetadata>