summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-06-29 10:33:54 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-06-29 10:33:54 +0000
commit2619ca1b23b0af646736ba9592169a4dbb6987db (patch)
tree3edfde09b6517e931cbbe9229bfb1f4ec8cf94c2
parent2024-06-29 10:04:14 UTC (diff)
parentdev-ml/ocaml-ctypes: add 0.22.0 (diff)
downloadgentoo-2619ca1b23b0af646736ba9592169a4dbb6987db.tar.gz
gentoo-2619ca1b23b0af646736ba9592169a4dbb6987db.tar.bz2
gentoo-2619ca1b23b0af646736ba9592169a4dbb6987db.zip
Merge updates from master
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild32
-rw-r--r--media-sound/gstreamripper/files/gstreamripper-0.2-C99-fixes.patch85
-rw-r--r--media-sound/gstreamripper/gstreamripper-0.2-r1.ebuild (renamed from media-sound/gstreamripper/gstreamripper-0.2.ebuild)6
4 files changed, 123 insertions, 1 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 61634628689c..4031632b920e 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -2,3 +2,4 @@ DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa
DIST ocaml-ctypes-0.20.0.tar.gz 206559 BLAKE2B d9bf1c3f5ae7544e3950766f7eb9bac2c9dbf84130f69b2b8807e55c6a7d659c46d9ba2227d53d578e4e49283730932213eea4c7487beffe4540432b3e700c81 SHA512 605ae95b0233f1157749475526ef00ade2f97649d06a782e8fcf97b604cb86a0dcc8f27c4ac6baec11a41b9ef5becb0e5ae55e30f1ee61b30d4ae17a0d1545c2
DIST ocaml-ctypes-0.20.1.tar.gz 206863 BLAKE2B a101872991d4bd83464d26e79fa5052c9dadbd10da1ae734fda8976199640091939777a1ba391d2aab84d7e14fafec6f713681e2ea52f6717f5f36d26e8aa225 SHA512 f95e65ce5003a07634afcbee431cb23c54c8335f926074615fc8d76ab777b9d2fce8f75bb25bbb6ed9550a7d6237fb377aa9ad65a426d2d7e387f86c1158fe4a
DIST ocaml-ctypes-0.21.1.tar.gz 200264 BLAKE2B c4539c8856c1919194f11ecaeb1b0649dc701a6c0dda62c4bb750cd64a9145f2e4a9e77392385e4e398e8e89d5ae91b7c5f68b6242f826563f0f32b78497dfe1 SHA512 3a64b29746360e7dda7725ce7af23ca64cd6a3fa585aa70188cdd143aace744f44c1bd13cdda5c9733ca53d4b874ed42749ca21aaff4f4d53636a390a2c7f94f
+DIST ocaml-ctypes-0.22.0.tar.gz 200377 BLAKE2B f9a27434a564d619d45bc4bd74fa0e045b21cf62e7b83203f25757e093e0ebff6b259b871eec57e404a3b043e4bbfc433a664d78e64b4b357730e09371a0d220 SHA512 98925bddfba81fd91383c5ee87a47f8f3424958e0affc299585b83029ce3cc52ac4c059f94d548cb15f37379ba3a8742a04b94f76787177b26c233b7037faa09
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
new file mode 100644
index 000000000000..fbec82b5da87
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.22.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ctypes
+inherit dune
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/yallop/ocaml-ctypes/"
+SRC_URI="https://github.com/yallop/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.03:=
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+REQUIRED_USE="ocamlopt"
+
+src_install() {
+ dune-install ctypes ctypes-foreign
+}
diff --git a/media-sound/gstreamripper/files/gstreamripper-0.2-C99-fixes.patch b/media-sound/gstreamripper/files/gstreamripper-0.2-C99-fixes.patch
new file mode 100644
index 000000000000..915e7a201451
--- /dev/null
+++ b/media-sound/gstreamripper/files/gstreamripper-0.2-C99-fixes.patch
@@ -0,0 +1,85 @@
+https://bugs.gentoo.org/885531
+--- a/src/callbacks.c 2024-04-03 16:35:36.682662231 +0000
++++ b/src/callbacks.c 2024-04-03 16:44:09.332605097 +0000
+@@ -410,7 +410,7 @@
+
+
+ gboolean
+-on_window1_delete_event(GtkWidget * widget,
++on_window1_delete_event(GtkButton * widget,
+ GdkEvent * event, gpointer user_data)
+ {
+ on_quit_button_clicked((widget), user_data);
+--- a/src/callbacks.h 2024-04-03 16:35:36.682662231 +0000
++++ b/src/callbacks.h 2024-04-03 16:46:35.340734393 +0000
+@@ -36,7 +36,7 @@
+
+ void on_locateButton_clicked();
+
+-gboolean on_window1_delete_event(GtkWidget * widget,GdkEvent * event,
++gboolean on_window1_delete_event(GtkButton * button,GdkEvent * event,
+ gpointer user_data);
+
+ void loadPrefs();
+--- a/src/interface.c 2024-04-03 16:35:36.682662231 +0000
++++ b/src/interface.c 2024-04-03 16:53:11.479371945 +0000
+@@ -76,7 +76,7 @@
+ gtk_box_pack_start(GTK_BOX(hbox2), button1, FALSE, FALSE, 5);
+
+ notebook1 = gtk_notebook_new();
+- gtk_notebook_set_scrollable(notebook1, TRUE);
++ gtk_notebook_set_scrollable(GTK_NOTEBOOK(notebook1), TRUE);
+ gtk_widget_show(notebook1);
+ gtk_box_pack_start(GTK_BOX(vbox1), notebook1, TRUE, TRUE, 0);
+
+https://bugs.gentoo.org/871012
+https://bugs.gentoo.org/919182
+--- a/src/main.c 2024-04-03 16:35:36.682662231 +0000
++++ b/src/main.c 2024-04-03 16:42:23.412236742 +0000
+@@ -11,7 +11,7 @@
+
+ #include "interface.h"
+ #include "support.h"
+-
++#include "callbacks.h"
+ int
+ main (int argc, char *argv[])
+ {
+--- a/src/callbacks.c 2024-04-03 17:00:00.604930862 +0000
++++ b/src/callbacks.c 2024-04-03 17:05:23.965001507 +0000
+@@ -23,7 +23,7 @@
+ #include "support.h"
+ #include "parse.h"
+
+-gint pids[256][2]; //pids[numberOFpidsAllowed][pid#,g_io_channel,ip]
++GIOChannel *pids[256][2]; //pids[numberOFpidsAllowed][pid#,g_io_channel,ip]
+ gchar *ips[256][1];
+ gint streams = 0;
+ gchar *binpath = "streamripper";
+@@ -165,7 +165,7 @@
+ return 0;
+ }
+
+- pids[streams][0] = child_pid;
++ pids[streams][0] = g_io_channel_unix_new(child_pid);
+ ips[streams][0] = g_strdup(ip);
+
+
+@@ -365,7 +365,7 @@
+ gint i = 0;
+ for(; i < streams; i++)
+ {
+- if(kill(pids[i][0], SIGKILL) == -1)
++ if(kill(g_io_channel_unix_get_fd(pids[i][0]), SIGKILL) == -1)
+ {
+ switch (errno)
+ {
+@@ -389,7 +389,7 @@
+ }
+ if(!all) //just want to close one tab
+ {
+- if((kill(pids[curtab][0], SIGKILL)) != -1)
++ if((kill(g_io_channel_unix_get_fd(pids[curtab][0]), SIGKILL)) != -1)
+ {
+ g_io_channel_shutdown((pids[curtab][1]), FALSE, NULL);
+ }
diff --git a/media-sound/gstreamripper/gstreamripper-0.2.ebuild b/media-sound/gstreamripper/gstreamripper-0.2-r1.ebuild
index 98a7de6e4bf2..0413f8eac1cb 100644
--- a/media-sound/gstreamripper/gstreamripper-0.2.ebuild
+++ b/media-sound/gstreamripper/gstreamripper-0.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop
@@ -22,6 +22,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES="
+ ${FILESDIR}/${P}-C99-fixes.patch
+"
+
src_compile() {
emake CFLAGS="${CFLAGS}"
}