summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-23 15:02:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-23 18:30:48 +0100
commit241d794514f48b754fa7ec9eada7c0cefcb925a7 (patch)
treedd9a2d1c4e3279e4fc8114fad2130247abbfc9e8
parentmedia-libs/libheif: Drop missing, and upstreamed, patch (diff)
downloadgentoo-241d794514f48b754fa7ec9eada7c0cefcb925a7.tar.gz
gentoo-241d794514f48b754fa7ec9eada7c0cefcb925a7.tar.bz2
gentoo-241d794514f48b754fa7ec9eada7c0cefcb925a7.zip
sci-chemistry/pymol: drop 3.0.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sci-chemistry/pymol/Manifest1
-rw-r--r--sci-chemistry/pymol/pymol-3.0.0.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 2ef25b2b27fa..7b6fd1d91c5d 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,2 +1 @@
-DIST pymol-1.8.4.0.png.xz 19528 BLAKE2B f3d23d4cedca3d8bb96b20646a548da4be570697e3346a11b01c5c3599b536ba4697be08472dfa8a4f6533167defc1a37a1de332931a73857319cb28fd42cd2b SHA512 40bb0d3f226476f6e047b5361956aad955232a97641474765eaa5204f0539aee3810e0266213618a45364f9f31f6eb18380b17e0c79f64065f7b62a9016caa7c
DIST pymol-3.0.0.tar.gz 29510174 BLAKE2B b67818e408045e386e44a203f29cd94a0ce34ec706776d29f78f1720bdc5c79d88f3b3e178882295b5a636d97fe70ff49eb1b021a9a6b96f0f4216bc392219d1 SHA512 eab05a46220339a05d8d4facdce6bfa08c6fc8a858a7b228236ef6c4054207059ef0f53a26bedebe4084a74b510015937fb4477f99612b21412cd75bf0c376a2
diff --git a/sci-chemistry/pymol/pymol-3.0.0.ebuild b/sci-chemistry/pymol/pymol-3.0.0.ebuild
deleted file mode 100644
index bb34934cd2fd..000000000000
--- a/sci-chemistry/pymol/pymol-3.0.0.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517="setuptools"
-DISTUTILS_EXT=1
-
-inherit desktop flag-o-matic xdg distutils-r1
-
-DESCRIPTION="A Python-extensible molecular graphics system"
-HOMEPAGE="https://www.pymol.org/"
-SRC_URI="
- https://dev.gentoo.org/~pacho/${PN}/${PN}-1.8.4.0.png.xz
- https://github.com/schrodinger/pymol-open-source/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
-
-S="${WORKDIR}"/${PN}-open-source-${PV}
-
-LICENSE="BitstreamVera BSD freedist HPND OFL-1.0 public-domain UoI-NCSA" #844991
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+netcdf web"
-
-DEPEND="
- dev-cpp/msgpack-cxx
- dev-libs/mmtf-cpp
- dev-python/numpy[${PYTHON_USEDEP}]
- sys-libs/zlib
- media-libs/freetype:2
- media-libs/glew:0=
- media-libs/glm
- media-libs/libpng:0=
- netcdf? ( sci-libs/netcdf:0= )
-"
-RDEPEND="
- ${DEPEND}
- media-video/mpeg-tools
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-python/pyqt5[opengl,${PYTHON_USEDEP}]
- dev-python/pmw[${PYTHON_USEDEP}]
- sci-chemistry/chemical-mime-data
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.5.0-format-security.patch"
-)
-
-python_prepare_all() {
- sed \
- -e "s:\"/usr:\"${EPREFIX}/usr:g" \
- -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
- -i setup.py || die
-
- sed \
- -e "s:/opt/local:${EPREFIX}/usr:g" \
- -e '/ext_comp_args/s:\[.*\]:[]:g' \
- -i setup.py || die
- sed \
- -e "s:\['msgpackc'\]:\['msgpack'\]:g" \
- -i setup.py || die
-
- append-cxxflags -std=c++17
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # -Werror=odr
- # https://bugs.gentoo.org/933235
- # https://github.com/schrodinger/pymol-open-source/issues/395
- filter-lto
-
- use !netcdf && DISTUTILS_ARGS=( --no-vmd-plugins )
-}
-
-python_install() {
- distutils-r1_python_install \
- --pymol-path="${EPREFIX}/usr/share/pymol"
-
- sed \
- -e '1i#!/usr/bin/env python' \
- "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
- python_doscript "${T}"/${PN}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # Move data to correct location
- dodir /usr/share/pymol
- mv "${D}/$(python_get_sitedir)"/pymol/pymol_path/* "${ED}/usr/share/pymol" || die
-
- # These environment variables should not go in the wrapper script, or else
- # it will be impossible to use the PyMOL libraries from Python.
- cat >> "${T}"/20pymol <<- EOF || die
- PYMOL_PATH="${EPREFIX}/usr/share/pymol"
- PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
- PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
- EOF
-
- doenvd "${T}"/20pymol
-
- newicon "${WORKDIR}"/${PN}-1.8.4.0.png ${PN}.png
- make_desktop_entry "${PN} %u" PyMol ${PN} \
- "Graphics;Education;Science;Chemistry;" \
- "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
-
- if ! use web; then
- rm -rf "${D}/$(python_get_sitedir)/web" || die
- fi
-
- rm -f "${ED}"/usr/share/${PN}/LICENSE || die
-}