summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-05-02 08:22:49 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-05-02 08:22:49 +0000
commit2408c9c44bc0d8822f2527d7b451dba6251ad365 (patch)
tree55c4296300d4ebec13c743467db7a44d0245a85c
parent2016-05-02 08:03:42 UTC (diff)
parentmedia-sound/tomahawk: Add use dependencies on media-video/vlc (diff)
downloadgentoo-2408c9c44bc0d8822f2527d7b451dba6251ad365.tar.gz
gentoo-2408c9c44bc0d8822f2527d7b451dba6251ad365.tar.bz2
gentoo-2408c9c44bc0d8822f2527d7b451dba6251ad365.zip
Merge updates from master
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch12
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch9
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch4
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch6
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild40
-rw-r--r--media-sound/tomahawk/tomahawk-9999.ebuild2
-rw-r--r--net-misc/ntp/ntp-4.2.8_p7.ebuild2
7 files changed, 68 insertions, 7 deletions
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch
new file mode 100644
index 000000000000..adb183de8f75
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6-cmake.patch
@@ -0,0 +1,12 @@
+Index: CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt (revision 1209280)
++++ b/CMakeLists.txt (revision 1209281)
+@@ -1,5 +1,7 @@
+ project(blitz)
+
++cmake_minimum_required(VERSION 2.6.4)
++
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules )
+ find_package(Qt4 REQUIRED)
+ # properly set up compile flags (QT_DEBUG/QT_NO_DEBUG, ...)
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch
new file mode 100644
index 000000000000..170bd709aa11
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6-exec-stack.patch
@@ -0,0 +1,9 @@
+Index: blitz/asm_scale.S
+===================================================================
+--- a/blitz/asm_scale.S (revision 1204247)
++++ b/blitz/asm_scale.S (revision 1204248)
+@@ -1,3 +1,4 @@
++.section .note.GNU-stack,"",%progbits
+
+ #if defined(__EMX__)
+ /* Due to strange behaviour of as.exe we use this macros */
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch
index 9b4d8128cb1d..b956d2dfd595 100644
--- a/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6-gcc.patch
@@ -1,5 +1,5 @@
---- blitz/CMakeLists.txt
-+++ blitz/CMakeLists.txt
+--- a/blitz/CMakeLists.txt
++++ b/blitz/CMakeLists.txt
@@ -31,12 +31,8 @@
if(HAVE_MMX)
diff --git a/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch b/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
index 8692c240f7bb..911c56b48ccb 100644
--- a/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
+++ b/media-libs/qimageblitz/files/qimageblitz-9999-exec-stack.patch
@@ -1,6 +1,6 @@
-diff -uar qimageblitz/blitz/asm_scale.S qimageblitz~/blitz/asm_scale.S
---- qimageblitz-orig/blitz/asm_scale.S 2007-10-17 01:17:57.000000000 +0200
-+++ qimageblitz/blitz/asm_scale.S 2007-10-17 01:19:12.000000000 +0200
+diff -Naur qimageblitz/blitz/asm_scale.S qimageblitz~/blitz/asm_scale.S
+--- a/qimageblitz-orig/blitz/asm_scale.S 2007-10-17 01:17:57.000000000 +0200
++++ b/qimageblitz/blitz/asm_scale.S 2007-10-17 01:19:12.000000000 +0200
@@ -814,3 +814,7 @@
SIZE(qimageScale_mmx_AARGBA)
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
new file mode 100644
index 000000000000..c57aa1c4b62c
--- /dev/null
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical effect and filter library by KDE"
+HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="cpu_flags_x86_3dnow altivec debug cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-exec-stack.patch"
+ "${FILESDIR}/${P}-gcc.patch"
+ "${FILESDIR}/${P}-cmake.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_ALTIVEC=$(usex altivec)
+ -DHAVE_3DNOW=$(usex cpu_flags_x86_3dnow)
+ -DHAVE_MMX=$(usex cpu_flags_x86_mmx)
+ -DHAVE_SSE=$(usex cpu_flags_x86_sse)
+ -DHAVE_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-sound/tomahawk/tomahawk-9999.ebuild b/media-sound/tomahawk/tomahawk-9999.ebuild
index f5b3f10c81e1..bacc86d1abd5 100644
--- a/media-sound/tomahawk/tomahawk-9999.ebuild
+++ b/media-sound/tomahawk/tomahawk-9999.ebuild
@@ -41,7 +41,7 @@ CDEPEND="
>=media-libs/libechonest-2.3.1:=[qt5]
media-libs/liblastfm[qt5]
>=media-libs/taglib-1.8.0
- media-video/vlc:=
+ media-video/vlc:=[flac,dvbpsi,ffmpeg,mp3]
>=net-libs/gnutls-3.2
x11-libs/libX11
hatchet? ( dev-cpp/websocketpp )
diff --git a/net-misc/ntp/ntp-4.2.8_p7.ebuild b/net-misc/ntp/ntp-4.2.8_p7.ebuild
index 7735b1e5a361..759bc53fc9f5 100644
--- a/net-misc/ntp/ntp-4.2.8_p7.ebuild
+++ b/net-misc/ntp/ntp-4.2.8_p7.ebuild
@@ -14,7 +14,7 @@ SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${MY_P}.tar
LICENSE="HPND BSD ISC"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~m68k-mint"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~m68k-mint"
IUSE="caps debug ipv6 libressl openntpd parse-clocks readline samba selinux snmp ssl +threads vim-syntax zeroconf"
CDEPEND="readline? ( >=sys-libs/readline-4.1:0= )