summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 09:40:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 11:06:45 +0100
commit197476858104f7919e1ac4884c29f3427c975175 (patch)
tree6926a60c5688a055b2accbf2d9c428676149660b
parentdev-python/django: Bump to 2.2.27 (diff)
downloadgentoo-197476858104f7919e1ac4884c29f3427c975175.tar.gz
gentoo-197476858104f7919e1ac4884c29f3427c975175.tar.bz2
gentoo-197476858104f7919e1ac4884c29f3427c975175.zip
dev-python/xarray: Bump to 0.21.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-0.21.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index f8fac2cbd735..db23a40b8926 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,2 +1,3 @@
DIST xarray-0.20.2.tar.gz 2906021 BLAKE2B 08ed46a27ce66ec1677e63000d74ecc4a01defa81b8ae1ec24595ff330713bf3e5585adce541e5e6769a74d64a4f5eb9d9aad27450e8088973681d0d60d00f83 SHA512 cd292af68ffd8016e01021e30a2ea83dd36e2f79bd9c3d8e7d83adc5a98a95615091d0102a19a0e3337ae334a701f575a142f476d1465804c8d5fe259ca35f1a
DIST xarray-0.21.0.tar.gz 2937088 BLAKE2B b40d57cbb018e563b92afef1e5208bb597bf8ae892b154f49e90079977c05ab955ba07f136fcf3f456efa8deb70ffd2590dd2d2429b6114a418882b8d96b535f SHA512 85461b86ced78ad5cfd1ace122f1ab89f779a8c0c7e8d0f06233b4654c5f6bcb081eeddc91e5df1c8c40c344d2477f2f18799858e23294c0929e8e59445508b0
+DIST xarray-0.21.1.tar.gz 2936861 BLAKE2B 4d419185a6c49f8054f43748fd7a0ba9694aa9e7377e371705dd6eceea84f5d611d445a7548a79133f8db4c65729c9b5f694ab586d5e2f55640a6369483e3df4 SHA512 be5d925971557f492c8ca7e90eb678a0f98cf0a670eaa8a8564bd160a02fcd8a22362a8691c5447a9baaa67b464257f2ab6954747296839b304f3e25cf13487a
diff --git a/dev-python/xarray/xarray-0.21.1.ebuild b/dev-python/xarray/xarray-0.21.1.ebuild
new file mode 100644
index 000000000000..6fddd59568f1
--- /dev/null
+++ b/dev-python/xarray/xarray-0.21.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.0-riscv_tests_datetime.patch
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+)