summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-17 15:19:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-17 15:49:53 +0200
commit15e7a33115d8885ace971491b717df39f967d3d0 (patch)
treeb1cd09960756ce24fdb7e9ee66c6770a5130902d
parentxfce-base/tumbler: Bump to 4.18.1 (diff)
downloadgentoo-15e7a33115d8885ace971491b717df39f967d3d0.tar.gz
gentoo-15e7a33115d8885ace971491b717df39f967d3d0.tar.bz2
gentoo-15e7a33115d8885ace971491b717df39f967d3d0.zip
xfce-base/xfconf: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.19.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index 20c4313d2915..a7332bdbc2b5 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,2 +1,3 @@
DIST xfconf-4.18.0.tar.bz2 625755 BLAKE2B dac7ccd7052818436f45e6c257cc6076221d9f5d7c2d836d909be0d9479abd88f6c17748cf0aa65be79a0642c7bb7ebb01b6cd5a22bb22d514fc3ed57be5d4af SHA512 49ac3070e44e0c699c157e6c029bf14d932bc1e60b01bc3b4f7451acf403d451ac52e2dfb14fc97298cc774c7a0895616788cdbfc189976805669fcdb7aa47b6
DIST xfconf-4.18.1.tar.bz2 629881 BLAKE2B 1344637b8f29f03e546d432f7703cba3add24d13e9615e3a69adab7050fbae7e0db44aec41dc322e3ee1e7aa744de3d9a41d80bf3d0a0ce9fbd91407d6db31d0 SHA512 cb4cc29497865755df4c9b8db7cbb84f9f2b5ce5eb7216bd5a3e7202424c565a36f4e4592c5ee0035a01fe4df043a87de43a536b0e63e1e200a077631e1c807a
+DIST xfconf-4.19.0.tar.bz2 755578 BLAKE2B 6442da9393c590a0d17e33081f161b115877fef02da9754d2d10baf377473a82a08ef01b007cbabc04637ff3441a1362ca9d3cf922d55a4ac6962389cc9befa9 SHA512 7acf5257996d8d36c50e373f25f6b0aa6ecfe4cecf4df6e18b221f7185f20bdb74a5571d21166ef2e7611c7e089242b0bc09c99a0d3735dc319736a230e7b2e6
diff --git a/xfce-base/xfconf/xfconf-4.19.0.ebuild b/xfce-base/xfconf/xfconf-4.19.0.ebuild
new file mode 100644
index 000000000000..b60487dfb1ba
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.19.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 vala
+
+DESCRIPTION="A configuration management system for Xfce"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfconf/start
+ https://gitlab.xfce.org/xfce/xfconf/
+"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ sys-apps/dbus
+ >=xfce-base/libxfce4util-4.17.3:=
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_enable debug checks)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ local service_dir=${HOME}/.local/share/dbus-1/services
+ mkdir -p "${service_dir}" || die
+ cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
+ [D-BUS Service]
+ Name=org.xfce.Xfconf
+ Exec=${S}/xfconfd/xfconfd
+ EOF
+
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ # -j>1 often hangs
+ # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
+ nonfatal emake -j1 check
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+}