summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-09 20:50:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-09 22:43:25 +0200
commit12324e5bf47b8b92223d2e2f01f56554fb7cdf26 (patch)
tree8be55f803b9c4df19cabe24f55fa373fa90f0d90
parentdev-python/imageio-ffmpeg: initial import, add 0.4.5 (diff)
downloadgentoo-12324e5bf47b8b92223d2e2f01f56554fb7cdf26.tar.gz
gentoo-12324e5bf47b8b92223d2e2f01f56554fb7cdf26.tar.bz2
gentoo-12324e5bf47b8b92223d2e2f01f56554fb7cdf26.zip
dev-python/django-allauth: add 0.47.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/django-allauth/Manifest1
-rw-r--r--dev-python/django-allauth/django-allauth-0.47.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-allauth/Manifest b/dev-python/django-allauth/Manifest
index fa7e7a90260c..cd6ca80e174f 100644
--- a/dev-python/django-allauth/Manifest
+++ b/dev-python/django-allauth/Manifest
@@ -1,2 +1,3 @@
DIST django-allauth-0.45.0.tar.gz 581007 BLAKE2B a0f586818e4d17ece5ed009481b71c0213bf265f45d391664d411268d53124c1d5df226ca40d98722691ace5f5ed50026b0a9db3bd34070ff855059bf3e237d6 SHA512 16b166a5f97e62fef3c801af17b6b7569bd27e597cec394032a2644397afc30512f52f0ff77af8036e414086cd207dc9f5d310dbc744627b55938243ba18e50f
DIST django-allauth-0.46.0.tar.gz 643238 BLAKE2B 91534f596e3fa2e6fa5e395bded16a793ccbec994a3099eef22980920013280f58b2204d226975c2fe7a7e2066b665789881a9bcc6d2342f70a9eb0b83c32f6c SHA512 8e89d6d6a10566e40f71845885c30c36994aef3ff9054731a7582484d12ff4c7df7903617777698e42838337ae436c41a59a318acc1d2fc0561883683f79df46
+DIST django-allauth-0.47.0.tar.gz 649860 BLAKE2B 9d230c546f5615a38be5fc915f080c44765c52f315910436af6e698af860efdf0debbe72a7d754cc7bd90a9791cd8647e3a186c748385c2d6e1f91a8ea8fc619 SHA512 b96acb3f44d5c04bef992cd5905e5cb3643d0329b10d9ae7df08f55a80c59bca8b59537a192f8de61b3776842fe166463e001a08585d5f701eeb839882cb6dac
diff --git a/dev-python/django-allauth/django-allauth-0.47.0.ebuild b/dev-python/django-allauth/django-allauth-0.47.0.ebuild
new file mode 100644
index 000000000000..815a68413f7c
--- /dev/null
+++ b/dev-python/django-allauth/django-allauth-0.47.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django 3rd party (social) account authentication"
+HOMEPAGE="
+ https://www.intenct.nl/projects/django-allauth/
+ https://github.com/pennersr/django-allauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# cryptography via pyjwt[crypto]
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/python3-openid[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+DOCS=( README.rst AUTHORS ChangeLog.rst )
+
+src_test() {
+ # cern provider tests require Internet
+ rm allauth/socialaccount/providers/cern/tests.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=test_settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
+}