summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2024-06-23 23:26:23 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-04 23:35:43 -0400
commit106f89c4bbb2935cc83f8f876a91a88cce7691f7 (patch)
tree928a2cfb87cee8bbfe39d604ccf9e036e8d5a7fc
parentgnome-extra/cinnamon-translations: drop 5.8.2 (diff)
downloadgentoo-106f89c4bbb2935cc83f8f876a91a88cce7691f7.tar.gz
gentoo-106f89c4bbb2935cc83f8f876a91a88cce7691f7.tar.bz2
gentoo-106f89c4bbb2935cc83f8f876a91a88cce7691f7.zip
gnome-extra/nemo: add 6.2.6
Bug: https://bugs.gentoo.org/934783 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
-rw-r--r--gnome-extra/nemo/Manifest1
-rw-r--r--gnome-extra/nemo/nemo-6.2.6.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/gnome-extra/nemo/Manifest b/gnome-extra/nemo/Manifest
index 88fee4f58952..04b8e49ef707 100644
--- a/gnome-extra/nemo/Manifest
+++ b/gnome-extra/nemo/Manifest
@@ -1,2 +1,3 @@
DIST nemo-5.8.4.tar.gz 1506620 BLAKE2B 948735bf75df2a0f8be9f5ddb29a73d6bf5127a6d932325855976da21334feb2c905b1a26c0ef285c8317b7e42223de098505802b1dde7a5e6fc1f4942d11681 SHA512 b636d5bbaa18e9259f74f086ed55e528be8dcfabdddbcdb0e3c82e3b93d0aa1b77573319f83df1529f1c473cdabbcab7280baa4169b482b5b9ecf6ade6e04427
DIST nemo-6.0.2.tar.gz 1480887 BLAKE2B d1e3892938cb81bcb676626a9ef54362939d522a6d09befe25dd77a236a7eee3e06461da1855317bff2a5f201bc142903ce085bfbafdbddca0700a177221ccdf SHA512 05e8a6ab785f527ad61c1fe57d372ae8ea8f77d27ec8608d38e99f5f0f9065aecef4b84d1b016b682d14320d7099806d5672a101c0a370429d1c3f2a341fed1c
+DIST nemo-6.2.6.tar.gz 1503182 BLAKE2B a8c469a6ebcb297e4cd2f8b3e9a07cb7fe6b7f399747c798a5b23ca930d8375275fc66b6d05ab78b660ec7b250f413ca0a16ba7ccdf46c0e93ad18d19839a969 SHA512 62a0d6a233f57fa3e9a078c3c90f7c735bf58aee4a37cfebdda20569f0b692e33998719152060e963b27dabee5a5a3da1c0d71a2b51dc5bf200331fd16b93135
diff --git a/gnome-extra/nemo/nemo-6.2.6.ebuild b/gnome-extra/nemo/nemo-6.2.6.ebuild
new file mode 100644
index 000000000000..6193e5aae1d7
--- /dev/null
+++ b/gnome-extra/nemo/nemo-6.2.6.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson gnome2-utils python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/nemo"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="exif gtk-doc +nls selinux test tracker wayland xmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# https://github.com/linuxmint/nemo/issues/2501
+RESTRICT="test"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.45.7:2[dbus]
+ >=dev-libs/gobject-introspection-0.9.12:=
+ >=dev-libs/json-glib-1.6.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-extra/cinnamon-desktop-6.2:0=
+ gnome-extra/libgsf:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.10.0:3[introspection,wayland=]
+ x11-libs/libX11
+ >=x11-libs/pango-1.40.0
+ >=x11-libs/xapp-2.8.4[introspection]
+
+ exif? (
+ >=media-libs/libexif-0.6.20
+ )
+ selinux? (
+ sys-libs/libselinux
+ )
+ tracker? (
+ app-misc/tracker:3
+ )
+ wayland? (
+ >=gui-libs/gtk-layer-shell-0.8.0
+ )
+ xmp? (
+ >=media-libs/exempi-2.2.0:=
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-themes/adwaita-icon-theme
+
+ nls? (
+ >=gnome-extra/cinnamon-translations-6.2
+ )
+"
+PDEPEND="
+ >=gnome-base/gvfs-0.1.2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.31.0
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ gtk-doc? (
+ dev-util/gtk-doc
+ )
+"
+
+PATCHES=(
+ # Undo the switch to untex as it's not packaged.
+ "${FILESDIR}/${PN}-5.0.3-use-detex.patch"
+)
+
+DISABLE_AUTOFORMATTING="yes"
+FORCE_PRINT_ELOG="yes"
+DOC_CONTENTS="
+${PN} functionality can be extended by installing other packages.
+
+sys-apps/gnome-disk-utility - Mount archive files
+gnome-extra/nemo-fileroller - Extract/Create archive files
+
+${PN} search capabilities can be extended through external
+helpers. Install any of the following packages to make
+their associated file types searchable.
+
+epub - app-arch/unzip and app-text/html2text
+Image metadata - media-gfx/exif
+MP3 tags - media-sound/id3
+Microsoft Office .doc - app-text/catdoc
+Microsoft Office .xls - dev-python/xlrd
+OpenDocument/LibreOffice - app-text/odt2txt or app-office/unoconv
+PDF - app-text/poppler[utils]
+PostScript - app-text/ghostscript-gpl
+TeX - app-text/texlive-core
+"
+
+src_prepare() {
+ default
+ python_fix_shebang files/usr/share/nemo/actions install-scripts
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif)
+ $(meson_use xmp)
+ $(meson_use selinux)
+ $(meson_use tracker)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use wayland gtk_layer_shell)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}