summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-03 04:28:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-03 04:28:36 +0100
commit0daaa1784c327352b2ad7fcaccc2d97d3aa0e2e7 (patch)
tree38f8578d95c16ad38315d0b3ed1b2b1263779b8a
parentdev-python/flit-core: Bump to 3.10.1 (diff)
downloadgentoo-0daaa1784c327352b2ad7fcaccc2d97d3aa0e2e7.tar.gz
gentoo-0daaa1784c327352b2ad7fcaccc2d97d3aa0e2e7.tar.bz2
gentoo-0daaa1784c327352b2ad7fcaccc2d97d3aa0e2e7.zip
dev-python/flit: Bump to 3.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flit/Manifest1
-rw-r--r--dev-python/flit/flit-3.10.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index de0cf876779c..7897bfe5332b 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1 +1,2 @@
+DIST flit-3.10.1.tar.gz 143162 BLAKE2B d98c18a161380c2eb605083a700d7f5226fdc08f72defe9fd60cc8dba5947e9904d4a4df05a9620ef2fcbef8c4913f596b19ef365df7614c4fba7434acc764fd SHA512 37ff7e4de10d4b123cee854e692511574748a050d177e50f06330223ae94a4347e358ff07ca9545c3c8346c51c6734227808929f59401fdd062498d6bf69209a
DIST flit-3.9.0.tar.gz 141104 BLAKE2B 4ca268c49a34817756dea5fe7d2bd2fa15fe8f4247bcdea50765d56c43fd9c89292f45ae2a68d6f210d994ed1bce159121aba02e769f22940c548baf3e212afe SHA512 3cbca4530fe463e27fb43130e0d00681e63434bdd552bd61b4a2f3b7967729d9d9a49c69b1a2380ed99bcca1e66a38e592f41cbe38a471d3e7297ab00cdabc29
diff --git a/dev-python/flit/flit-3.10.1.ebuild b/dev-python/flit/flit-3.10.1.ebuild
new file mode 100644
index 000000000000..14958054148d
--- /dev/null
+++ b/dev-python/flit/flit-3.10.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="
+ https://github.com/pypa/flit/
+ https://flit.readthedocs.io/
+ https://pypi.org/project/flit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-${PV}[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ tests/test_config.py::test_invalid_classifier
+ # failing due to Gentoo pip patches
+ tests/test_install.py::InstallTests::test_install_data_dir
+ tests/test_install.py::InstallTests::test_install_module_pep621
+ tests/test_install.py::InstallTests::test_symlink_data_dir
+ tests/test_install.py::InstallTests::test_symlink_module_pep621
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \
+ dev-python/sphinx-rtd-theme
+
+src_prepare() {
+ # make sure system install is used
+ rm -r flit_core || die
+ distutils-r1_src_prepare
+}