summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-08-22 17:16:49 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-08-22 17:16:49 +0000
commit03be3ae46ff2a0ca819cc8e35db5453436eb7294 (patch)
treecdee288dcfc4b9584834a24a9c7e1aa118f79bee
parent2023-08-22 17:01:42 UTC (diff)
parentcheck-reqs.eclass: clarify failed requirements error (diff)
downloadgentoo-03be3ae46ff2a0ca819cc8e35db5453436eb7294.tar.gz
gentoo-03be3ae46ff2a0ca819cc8e35db5453436eb7294.tar.bz2
gentoo-03be3ae46ff2a0ca819cc8e35db5453436eb7294.zip
Merge updates from master
-rw-r--r--dev-libs/libei/libei-1.0.0.ebuild2
-rw-r--r--dev-python/structlog/structlog-23.1.0.ebuild2
-rw-r--r--eclass/check-reqs.eclass8
-rw-r--r--eclass/cmake.eclass7
4 files changed, 14 insertions, 5 deletions
diff --git a/dev-libs/libei/libei-1.0.0.ebuild b/dev-libs/libei/libei-1.0.0.ebuild
index 1debac5de82d..227b825ec103 100644
--- a/dev-libs/libei/libei-1.0.0.ebuild
+++ b/dev-libs/libei/libei-1.0.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI+=" https://github.com/nemequ/munit/archive/${MUNIT_COMMIT}.tar.gz -> mun
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
IUSE="elogind systemd test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/structlog/structlog-23.1.0.ebuild b/dev-python/structlog/structlog-23.1.0.ebuild
index de8c60a8db4b..cb6588d1bfcc 100644
--- a/dev-python/structlog/structlog-23.1.0.ebuild
+++ b/dev-python/structlog/structlog-23.1.0.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="Apache-2.0 MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
BDEPEND="
dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
diff --git a/eclass/check-reqs.eclass b/eclass/check-reqs.eclass
index f6409e9a02c5..fac2f4553d74 100644
--- a/eclass/check-reqs.eclass
+++ b/eclass/check-reqs.eclass
@@ -291,9 +291,11 @@ _check-reqs_output() {
[[ ${EBUILD_PHASE} == "pretend" && -z ${CHECKREQS_DONOTHING} ]] && msg="eerror"
if [[ -n ${CHECKREQS_FAILED} ]]; then
${msg}
- ${msg} "Space constraints set in the ebuild were not met!"
- ${msg} "The build will most probably fail, you should enhance the space"
- ${msg} "as per failed tests."
+ ${msg} "Memory or space constraints set in the ebuild were not met!"
+ ${msg} "The build will most probably fail, you should:"
+ ${msg} "- enhance the memory (reduce MAKEOPTS, add swap), or"
+ ${msg} "- add more space"
+ ${msg} "as required depending on the failed tests."
${msg}
[[ ${EBUILD_PHASE} == "pretend" && -z ${CHECKREQS_DONOTHING} ]] && \
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index 16b3e300ccae..fb3f9b6352be 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -125,6 +125,12 @@ fi
# read-only. This is a user flag and should under _no circumstances_ be set in
# the ebuild. Helps in improving QA of build systems that write to source tree.
+# @ECLASS_VARIABLE: CMAKE_SKIP_TESTS
+# @USER_VARIABLE
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Array of tests that should be skipped when running CTest.
+
[[ ${CMAKE_MIN_VERSION} ]] && die "CMAKE_MIN_VERSION is banned; if necessary, set BDEPEND=\">=dev-util/cmake-${CMAKE_MIN_VERSION}\" directly"
[[ ${CMAKE_BUILD_DIR} ]] && die "The ebuild must be migrated to BUILD_DIR"
[[ ${CMAKE_REMOVE_MODULES} ]] && die "CMAKE_REMOVE_MODULES is banned, set CMAKE_REMOVE_MODULES_LIST array instead"
@@ -681,6 +687,7 @@ cmake_src_test() {
[[ -e CTestTestfile.cmake ]] || { echo "No tests found. Skipping."; return 0 ; }
[[ -n ${TEST_VERBOSE} ]] && myctestargs+=( --extra-verbose --output-on-failure )
+ [[ -n ${CMAKE_SKIP_TESTS} ]] && myctestargs+=( -E '('$( IFS='|'; echo "${CMAKE_SKIP_TESTS[*]}")')' )
set -- ctest -j "$(makeopts_jobs "${MAKEOPTS}" 999)" \
--test-load "$(makeopts_loadavg)" "${myctestargs[@]}" "$@"