summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-18 20:26:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-18 21:11:38 +0300
commit02c23f75ac47f50e91114094d95d63918835cc2f (patch)
treeac32aebb36631e2891cafd38267b46d0c9b56cb8
parentdev-python/hatch-fancy-pypi-readme: new package, add 22.3.0 (diff)
downloadgentoo-02c23f75ac47f50e91114094d95d63918835cc2f.tar.gz
gentoo-02c23f75ac47f50e91114094d95d63918835cc2f.tar.bz2
gentoo-02c23f75ac47f50e91114094d95d63918835cc2f.zip
dev-python/ipywidgets: add 8.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 26c03187d5c5..818851ad02b9 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-7.7.1.tar.gz 4075672 BLAKE2B 1e52d3b3b9380f42f67ad658f6e8579a61220e7160c10b1569437c1fd74ce962fbe746f3a6a3e302b5417812f69807deddc0ae3fe255b8e2f213d65103d55362 SHA512 ed6bf1a59a511714a3af96cc66e7665b9b264f56862ca4ea02d943137fcc6018da8fcb8dff4a8f9157bfb46cc19b7d58ceaff028e84f2f8d18ee16e57ce7fb96
+DIST ipywidgets-8.0.1.tar.gz 111771 BLAKE2B 78217eaf6386f18a634c016562925213233ed6fc3b35266fede83f66e831f761766be0db3e23ef694edd9bc6089ff987df97f6addf2a17bc5ef1d4b6d59585b7 SHA512 cb443734897f786a86a34ab6177d84e32d00155513c835756dc53a76b7201144e0cb34c3701c06b07df22de78f6d43973f4b9be456c3b4a22db39c16de4a4dc6
diff --git a/dev-python/ipywidgets/ipywidgets-8.0.1.ebuild b/dev-python/ipywidgets/ipywidgets-8.0.1.ebuild
new file mode 100644
index 000000000000..1067cdc66e26
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.py || die
+ distutils-r1_src_prepare
+}